Package Details: ncspot 0.11.1-1

Git Clone URL: https://aur.archlinux.org/ncspot.git (read-only, click to copy)
Package Base: ncspot
Description: Cross-platform ncurses Spotify client written in Rust, inspired by ncmpc and the likes.
Upstream URL: https://github.com/hrkfdn/ncspot
Licenses: BSD
Conflicts: ncspot
Provides: ncspot
Submitter: alevalv
Maintainer: alevalv
Last Packager: alevalv
Votes: 43
Popularity: 4.52
First Submitted: 2019-11-22 19:08 (UTC)
Last Updated: 2022-09-26 14:53 (UTC)

Latest Comments

1 2 Next › Last »

cyqsimon commented on 2022-08-14 16:56 (UTC)

@m8D2

rustup is rust's toolchain version manager, which allows you to install multiple rust toolchains of different versions simultaneously. Unless you are a Rust developer (which doesn't sound like it), this is likely going to do you more trouble than good. You can see the version of Rust toolchain you actually have with rustc --version. (And in case you are interested in rustup, run rustup help)

As a user of Rust software, just remove community/rustup and install extra/rust instead. Then pacman will keep the actual Rust toolchain up to date and you won't get problems like this.

TL;DR:

sudo pacman -R rustup
rm -rf ~/.rustup # this removes toolchains installed by rustup
sudo pacman -Syu rust

m8D2 commented on 2022-08-12 19:29 (UTC) (edited on 2022-08-12 19:30 (UTC) by m8D2)

I'm getting this error while trying to build on Asahi (ArchLinux Arm on M1, basically aarch64):

==> Starting build()...
error: package `enum-map v2.4.1` cannot be built because it requires rustc 1.61 or newer, while the currently active rustc version is 1.57.0-nightly
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: ncspot

The rust package I installed is community/rustup 1.25.1-1

Can I ask how to fix this? Thanks!

cyqsimon commented on 2022-06-11 03:16 (UTC)

Thanks for the speedy updates. Also the source now ships with a .desktop file which allows for better integration. See my PR. Can you please install it as well? Much thanks and godspeed.

install -Dm 644 "misc/ncspot.desktop" "${pkgdir}/usr/share/applications/ncspot.desktop"

cyqsimon commented on 2022-06-03 10:13 (UTC) (edited on 2022-06-03 10:17 (UTC) by cyqsimon)

Probably should install the logo image file, for use in notification and desktop file.

install -Dm 644 "images/logo.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/ncspot.svg"

Also, line 36 can be shortened, and the mode shouldn't be 755:

 install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"

codicodi commented on 2021-12-22 09:33 (UTC)

Since the latest devtools update, ncspot fails to build in a chroot with a link error. To fix this, lto needs to be disabled in PKGBUILD:

options=(!lto)

adsoncicilioti commented on 2021-11-13 17:45 (UTC)

Enable cover feature. cargo build --release --features cover --locked

nayaabkhan commented on 2021-09-02 07:08 (UTC)

Hi, I'm getting the following error when updating:

error: failed to get `chrono` as a dependency of package `ncspot v0.8.2 (/home/nayaabkhan/.cache/yay/ncspot/src/ncspot-0.8.2)`

Caused by:
  failed to create directory `/cargo/registry/index/github.com-1ecc6299db9ec823`

Caused by:
  Permission denied (os error 13)

anftorresf commented on 2021-08-08 19:44 (UTC)

Hi. Im having issues with the sound when run ncspot. I dont know why didnt work. I tried in two different Pcs

oncomouse commented on 2021-07-30 18:44 (UTC)

Installing 0.8.1-1, I get the following error:

==> Starting prepare()...
error: failed to download `zvariant_derive v2.7.0`

Caused by:
  unable to get packages from source

Caused by:
  failed to parse manifest at `/home/user/.cargo/registry/src/github.com-1ecc6299db9ec823/zvariant_derive-2.7.0/Cargo.toml`

Caused by:
  feature `resolver` is required

  this Cargo does not support nightly features, but if you
  switch to nightly channel you can add
  `cargo-features = ["resolver"]` to enable this feature
==> ERROR: A failure occurred in prepare().
    Aborting...
error: failed to build 'ncspot-0.8.1-1':
error: packages failed to buid: ncspot-0.8.1-1

I added +nightly to the three calls to cargo in the PKGBUILD and it looks to have built. I don't know if this is a configuration error on my system or a general problem, though.

vagorafaelino commented on 2021-05-14 17:55 (UTC) (edited on 2021-05-14 17:57 (UTC) by vagorafaelino)

ncspot 0.7.1 is out! Fixes issues from previous version Thanks in advance