Package Details: ncurses-full-git 6.0+20170902-1

Git Clone URL: https://aur.archlinux.org/ncurses-full-git.git (read-only)
Package Base: ncurses-full-git
Description: System V Release 4.0 curses emulation library, with static and shared libraries, Inclusion of libTinfo.
Upstream URL: http://invisible-island.net/ncurses/ncurses.html
Licenses: MIT
Conflicts: libtinfo, ncurses, ncurses-full, ncurses5-compat-libs
Provides: libformw.a, libformw.so, libmenuw.a, libmenuw.so, libncurses++w.a, libncurses++w.so, libncursesw.a, libncursesw.so, libpanelw.a, libpanelw.so, libtinfo, libtinfo.a, libtinfo.so, ncurses, ncurses-full
Submitter: EndlessEden
Maintainer: EndlessEden
Last Packager: EndlessEden
Votes: 4
Popularity: 1.811955
First Submitted: 2017-09-11 22:26
Last Updated: 2017-09-11 22:54

Required by (720)

Sources (1)

Pinned Comments

EndlessEden commented on 2017-11-19 06:32

@ATrigger
@transmutated:

Ive noted both of your issues. it apparently applies to the non-git pkgbuild of this as well. Ill have my fix put up asap...

Latest Comments

EndlessEden commented on 2017-11-19 06:32

@ATrigger
@transmutated:

Ive noted both of your issues. it apparently applies to the non-git pkgbuild of this as well. Ill have my fix put up asap...

ATrigger commented on 2017-11-18 12:47

libtinfo issue caused by this package breaks mkinitcpio
# mkinitcpio -p linux
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
-> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
hexdump: error while loading shared libraries: libtinfo.so.6: cannot open shared object file: No such file or directory
==> ERROR: invalid kernel specified: `/boot/vmlinuz-linux'
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
-> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
hexdump: error while loading shared libraries: libtinfo.so.6: cannot open shared object file: No such file or directory
==> ERROR: invalid kernel specified: `/boot/vmlinuz-linux'

transmutated commented on 2017-11-06 20:14

After installing this on a new system, it appears that it doesn't install the libtinfo library. Just before installing the package, it spits this out:

==> WARNING: Cannot find library listed in 'provides': libtinfo.so

Ultimately, the installed package creates symlinks to a file the doesn't exist, please see the following pastebin: https://pastebin.com/gXnEnbzX

Currently this has vim fubared on the box which lead me to this package.