Package Details: ncurses5-compat-libs 6.1-1

Git Clone URL: https://aur.archlinux.org/ncurses5-compat-libs.git (read-only)
Package Base: ncurses5-compat-libs
Description: System V Release 4.0 curses emulation library, ABI 5
Upstream URL: http://invisible-island.net/ncurses/ncurses.html
Licenses: MIT
Conflicts: libtinfo5
Provides: libtinfo5
Submitter: Barthalion
Maintainer: Barthalion
Last Packager: Barthalion
Votes: 506
Popularity: 1.731360
First Submitted: 2015-09-18 21:03
Last Updated: 2018-02-24 18:38

Required by (114)

Sources (2)

Pinned Comments

Barthalion commented on 2018-01-02 11:53

For the lazy, you can also install ncurses5-compat-libs package from my personal repository.

[bpiotrowski]
Server = https://pkgbuild.com/~bpiotrowski/repo

WoefulDerelict commented on 2016-05-23 19:35

This PKGBUILD verifies the authenticity of the source via PGP signatures which are not part of the Arch Linux keyring. In order to complete the process it is necessary to import the key(s) from the ‘validpgpkeys’ array into the user’s keyring before calling makepkg. There is a helpful article explaining this process by one of Arch Linux's developers located here: http://allanmcrae.com/2015/01/two-pgp-keyrings-for-package-management-in-arch-linux/

Instructions on importing keys from a keyserver and how to automate the retrieval process can be found in the Arch Linux wiki here: https://wiki.archlinux.org/index.php/GnuPG#Use_a_keyserver This article also contains helpful information describing the installation of GnuPG, its configuration and usage.

Execute the following to import keys using gpg:

gpg --recv-keys <KEYID - See 'validpgpkeys' array in PKGBUILD>

The PGP signature check can be skipped by passing --skippgpcheck to makepkg.

Consult the makepkg manual page for a full list of options. [https://www.archlinux.org/pacman/makepkg.8.html]

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

beroal commented on 2017-08-01 14:38

@andrew-wja: Read the end of the pinned comment carefully.

Barthalion commented on 2017-08-01 12:37

You can't get this package to build because you are incapable of reading the only pinned comment, which explains why it fails for you and how can you fix it.

andrew-wja commented on 2017-08-01 10:48

I can't get this package to build because the associated PGP key is not trusted by the Arch keychain. I ran pacman-key --recv-keys <KEYID>, which was successful, but the package still will not build.

The only way I could get the package to install was to download the PKGBUILD and build and install the package manually with makepkg.

Xandaros commented on 2017-07-30 01:05

Seems to build fine on armv7h. Maybe add that to the arch array?

Musikolo commented on 2017-07-29 06:18

@agentcobra, you need to import WoefulDerelict's public key. You can learn how to do it, but reading the message pinned on top of this message.

I hope it helps!

agentcobra commented on 2017-07-29 05:26

impossible a installer

==> Création du paquet ncurses5-compat-libs 6.0+20170527-1 (sam. juil. 29 07:23:18 CEST 2017)
==> Vérification des dépendances pour l’exécution...
==> Vérification des dépendances pour la compilation...
==> Récupération des sources...
-> Téléchargement de ncurses-6.0-20170527.tgz...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 3212k 100 3212k 0 0 1786k 0 0:00:01 0:00:01 --:--:-- 1786k
-> Téléchargement de ncurses-6.0-20170527.tgz.asc...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 267 100 267 0 0 819 0 --:--:-- --:--:-- --:--:-- 819
==> Validation des fichiers source avec md5sums...
ncurses-6.0-20170527.tgz ... Réussite
ncurses-6.0-20170527.tgz.asc ... Ignoré
==> Vérification des signatures des fichiers sources grâce à gpg...
ncurses-6.0-20170527.tgz ... ÉCHEC (Clé publique inconnue 702353E0F7E48EDB)
==> ERREUR : Une ou plusieurs signatures PGP n’ont pas pu être vérifiées.

mohag commented on 2017-07-26 06:03

I had some build options (other than the GPG ones) that went away when disabling ccache using "CC=gcc"

Musikolo commented on 2017-06-20 00:51

@peverous, I'm not completely sure whether this will help you out, but I've got the feeling that you aren't using ABS to build your package. If you don't know what this is or you are unsure, I suggest you to check the documentation available at https://wiki.archlinux.org/index.php/Arch_Build_System

Once you have ABS set up in your PC, get https://aur.archlinux.org/cgit/aur.git/snapshot/ncurses5-compat-libs.tar.gz in your local, uncompress it and issue the following:
makepkg -rsi PKGBUILD

The above command should compile, create and install ncurses5-compat-lib package.

I hope it helps!

peverous commented on 2017-06-19 08:39

I followed the steps provided on pinned comments to install lib32-ncurses (AUR). But error "/usr/local/MATLAB/R2014a/bin/glnxa64/MATLAB: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory" still exists. I used "locate libncurses.so.5" and returns to me "/usr/lib32/libncurses.so.5"
Am i doing something wrong?
I new on Arch world!

chris.r commented on 2017-05-13 21:04

I've had this issue intermittently on manjaro. Executing: gpg --recv-keys 702353E0F7E48EDB fixed this for me. (In response to an error with Matlab R2015a)