Package Details: ncurses5-compat-libs 6.5-1

Git Clone URL: https://aur.archlinux.org/ncurses5-compat-libs.git (read-only, click to copy)
Package Base: ncurses5-compat-libs
Description: System V Release 4.0 curses emulation library, ABI 5
Upstream URL: http://invisible-island.net/ncurses/ncurses.html
Licenses: MIT
Conflicts: libtinfo5
Provides: libtinfo5
Submitter: Barthalion
Maintainer: micwoj92
Last Packager: micwoj92
Votes: 586
Popularity: 1.81
First Submitted: 2015-09-18 21:03 (UTC)
Last Updated: 2024-07-16 20:06 (UTC)

Required by (116)

Sources (2)

Pinned Comments

WoefulDerelict commented on 2016-05-23 19:35 (UTC) (edited on 2018-08-18 20:22 (UTC) by WoefulDerelict)

This PKGBUILD verifies the authenticity of the source via PGP signatures which are not part of the Arch Linux keyring. In order to complete the process it is necessary to import the key(s) from the ‘validpgpkeys’ array into the user’s keyring before calling makepkg. There is a helpful article explaining this process by one of Arch Linux's developers located here: http://allanmcrae.com/2015/01/two-pgp-keyrings-for-package-management-in-arch-linux/

Instructions on importing keys from a keyserver and how to automate the retrieval process can be found in the Arch Linux wiki here: https://wiki.archlinux.org/index.php/GnuPG#Use_a_keyserver This article also contains helpful information describing the installation of GnuPG, its configuration and usage.

Execute the following to import keys using gpg:

gpg --recv-keys <KEYID - See 'validpgpkeys' array in PKGBUILD>

The PGP signature check can be skipped by passing --skippgpcheck to makepkg.

Consult the makepkg manual page for a full list of options. [https://www.archlinux.org/pacman/makepkg.8.html]

Latest Comments

1 2 3 4 5 6 .. 27 Next › Last »

micwoj92 commented on 2024-07-16 20:05 (UTC)

Thanks.

seds commented on 2024-07-16 19:59 (UTC)

@micwoj92 I am quite sure I’ve clicked adopt by mistake and didn’t notice until you said it. I am not interested in adopting it. Disowning.

micwoj92 commented on 2024-07-16 19:05 (UTC)

@seds, since you adopted this pkg so fast, can you also update it?🙃

JstKddng commented on 2024-07-16 12:33 (UTC)

disowning since i no longer use xilinx-ise

bdjnk commented on 2024-01-01 16:32 (UTC)

b186fd9ae86a, which adopts yan12125 PKGBUILD, broke adom (https://michael.plotke.me/adom-mess.png).

Vincentimetr commented on 2023-11-28 03:06 (UTC) (edited on 2023-11-28 03:07 (UTC) by Vincentimetr)

Running on Steam deck, I have this when attempting a makepkg -si

checking if this is really Intel C compiler... no
checking if this is really Clang C compiler... no
checking for gcc option to accept ANSI C... none needed
checking $CFLAGS variable... broken
configure: WARNING: your environment uses the CFLAGS variable to hold CPPFLAGS options
checking $CC variable... ok
checking how to run the C preprocessor... /lib/cpp
configure: error: C preprocessor "/lib/cpp" fails sanity check
==> ERROR: A failure occurred in build().
    Aborting...

JstKddng commented on 2023-10-06 05:55 (UTC)

All files except the .a libs are already provided by arch's ncurses package. You are free to not delete the static libraries if you need them.

Atom194 commented on 2023-10-05 13:22 (UTC) (edited on 2023-10-05 13:22 (UTC) by Atom194)

Why are these files removed?

rm -rf "$pkgdir/usr/include/" "$pkgdir/usr/lib/pkgconfig" "$pkgdir"/usr/lib/.so "$pkgdir"/usr/lib/.a

They are useful for static linking.

JstKddng commented on 2023-04-23 16:29 (UTC)

sorry guys, forgot to enable notifications for this package. Just updated the package.

malacology commented on 2023-04-09 15:20 (UTC)

I can confirm that yan12125's PKGBUILD works well.