Package Details: neard 0.18-1

Git Clone URL: https://aur.archlinux.org/neard.git (read-only, click to copy)
Package Base: neard
Description: Intel's Near Field Communication manager
Upstream URL: https://github.com/linux-nfc/neard
Licenses: GPL2
Submitter: dimich
Maintainer: codyps (KokaKiwi)
Last Packager: codyps
Votes: 6
Popularity: 0.001551
First Submitted: 2013-03-12 18:20 (UTC)
Last Updated: 2021-11-22 14:54 (UTC)

Latest Comments

codyps commented on 2021-10-13 18:07 (UTC)

Thanks KokaKiwi, I applied your change and added you as a co-maintainer so you can add future changes directly.

KokaKiwi commented on 2021-10-13 16:07 (UTC)

Got it building with makechrootpkg with following PKGBUILD diff applied:

diff --git a/PKGBUILD b/PKGBUILD
index 051fd74..1e6c934 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ arch=('i686' 'x86_64')
 url="https://github.com/linux-nfc/neard"
 license=('GPL2')
 depends=('dbus>=1.2' 'libnl' 'glib2>=2.28')
-makedepends=('automake' 'autoconf>=2.60' 'libtool' 'chrpath')
+makedepends=('automake' 'autoconf>=2.60' 'autoconf-archive' 'libtool' 'chrpath')
 backup=(etc/neard/main.conf)
 source=(https://git.kernel.org/cgit/network/nfc/neard.git/snapshot/$pkgname-$pkgver.tar.gz
         bindir.patch
@@ -32,5 +32,7 @@ build() {
   ./configure \
     --prefix=/usr \
     --sysconfdir=/etc \
+    --with-systemdsystemunitdir=/usr/lib/systemd/system \
+    --with-systemduserunitdir=/usr/lib/systemd/user \
     --disable-debug \
     --enable-tools

piater commented on 2021-09-30 16:49 (UTC)

The PKGBUILD is missing autoconf-archive in makedepends. Without that package installed, build fails because the AX_CHECK_COMPILE_FLAG autoconf macro is not defined.

christoph.gysin commented on 2020-10-20 07:24 (UTC)

Upstream URL is dead

aperez commented on 2017-02-09 11:37 (UTC)

This is missing “chrpath” in “makedepends”. Adding it fixes the build here.

koltrast commented on 2016-08-26 15:27 (UTC)

Disowning this package as I have no use for it anymore. Updated it to 0.16 though.

koltrast commented on 2015-04-13 15:22 (UTC)

Adopted package as dimich disowned it. Updated package version. My first package on the AUR, please tell me if something's wrong.

dimich commented on 2013-12-16 16:00 (UTC)

Added libtool as makedepend Updated package version Thanks

julroy67 commented on 2013-12-16 15:38 (UTC)

Neard 0.14 is out

julroy67 commented on 2013-12-11 20:56 (UTC)

Libtool should be added as makedepend