Package Details: nekoray-bin 3.26-1

Git Clone URL: https://aur.archlinux.org/nekoray-bin.git (read-only, click to copy)
Package Base: nekoray-bin
Description: Qt based cross-platform GUI proxy configuration manager (backend: v2ray / sing-box)
Upstream URL: https://github.com/MatsuriDayo/nekoray
Licenses: GPL 3.0
Conflicts: nekoray, nekoray-git
Provides: nekoray
Submitter: Molyuu
Maintainer: ali.molaei
Last Packager: ali.molaei
Votes: 14
Popularity: 0.49
First Submitted: 2023-02-07 17:36 (UTC)
Last Updated: 2023-12-09 08:48 (UTC)

Pinned Comments

m47h4r commented on 2022-10-29 15:58 (UTC) (edited on 2022-10-29 17:08 (UTC) by m47h4r)

Due to some limitations see here, I wasn't able to compile via source, so this downloads and populates a pre-compiled zip file (this is temporary, hence lack of -bin in name). And since the application operates in its main directory, I had to install it in the user's home directory (otherwise, root permissions were needed to run the app). This is my first PKGBUILD, so let me know if something could be handled better/more efficiently. Enjoy freedom :)

Latest Comments

1 2 Next › Last »

AzureZeng commented on 2024-04-05 10:30 (UTC)

If you meet errors similar to 'geosite.db not found' when using sing-box, it is required to change the asset location to '/usr/share/sing-box' in Basic Settings.

amiria703 commented on 2023-07-13 11:47 (UTC)

Version 3.9 released and this package needs to be updated.

<deleted-account> commented on 2023-05-31 15:37 (UTC)

git patch for update v3.6 https://filebin.net/pbstkcja9gn1y2kx

dnslin commented on 2023-04-20 14:32 (UTC)

错误:无效选项 '-s' -> 安装时出错: [/home/dnslin/.cache/yay/nekoray-bin/nekoray-bin-2.26-1-x86_64.pkg.tar.zst] - exit status 1

lonble commented on 2023-04-13 05:01 (UTC)

The debian package is already available in the release, you can extract the binary from the .deb package and install it as a real system level software

lonble commented on 2023-03-18 15:08 (UTC)

Please refer to nekoray's package page to modify PKGBUILD and .desktop file.

zhaose commented on 2023-02-08 09:06 (UTC)

A package shouldn't install files to the user's home dir. Please change it, install the files to /usr/share. You can take a look of the PKGBUILD of nekoray-git.

zhaose commented on 2023-02-08 09:03 (UTC)

A package shouldn't install files to the user's home dir. Please change it, install the files to /usr/share. You can take a look of the PKGBUILD of nekoray-git.

aflt98 commented on 2022-11-30 16:25 (UTC) (edited on 2022-11-30 16:28 (UTC) by aflt98)

I get permission denied when not using sudo and with sudo i get /usr/bin/nekoray: line 3: /root/.local/opt/nekoray/launcher: No such file or directory

I had to change /usr/bin/nekoray permissions to 755

SunRed commented on 2022-11-28 13:49 (UTC) (edited on 2022-11-28 13:49 (UTC) by SunRed)

This package should have the -bin suffix as it uses a binary release and does not build from source. It should also not install to the home directory of the user creating that package. This user might not exist on the system where the package is installed. The package should come with an install script similar to tor-browser if it has to be installed in ~/.local/opt / in the user directory to function properly.