Package Details: nemo-terminal 3.0.1-2

Git Clone URL: https://aur.archlinux.org/nemo-terminal.git (read-only)
Package Base: nemo-terminal
Description: An embedded terminal for Nemo, the Cinnamon file manager.
Upstream URL: https://github.com/linuxmint/nemo-extensions
Licenses: GPL2
Groups: nemo-extensions
Submitter: Serede
Maintainer: nullptr_t
Last Packager: nullptr_t
Votes: 12
Popularity: 0.266868
First Submitted: 2014-07-11 07:19
Last Updated: 2016-07-12 10:30

Latest Comments

nullptr_t commented on 2016-07-12 10:32

Thanks, I applied that changes.

Until 3.0.0, nemo-terminal worked with that changes and I did not notice the problem.

ptrxyz commented on 2016-07-08 12:21

Take care, your patches in the PKGBUILD mess up some stuff:

"sed -i 's/2.90/2.91/'":
This will also rename the variable "VTE_2_90_API" to "VTE_2.91_API" causing a syntax error. Maybe just escape the "." in your sed command, otherwise "." will match /any character/.

"sed -i 's/self.vscrollbar =/..." and "sed -i 's/self.hbox.pack_end/#...":
Those commands will comment out the only lines within a "if" block (lines 135 + 137). But Python expects at least one statement to function, so maybe just insert an additional "pass".

I created a working PKGBUILD addressing those things here:
http://pastebin.com/raw/wT4JByWf

nullptr_t commented on 2016-03-04 15:03

Now fixed for vte3

nullptr_t commented on 2016-03-04 14:37

Seems to be broken with both - vte and vte3...

Cake commented on 2016-02-26 15:22

Missing the dependency "vte290". Could you fix it?

nullptr_t commented on 2015-12-04 11:27

dependencies are updated, sorry for being late

alium commented on 2015-11-26 11:05

need 'gobject-introspection-runtime', not 'gobject-introspection' and Python2 fix:


depends=('nemo-python' 'vte290' 'gobject-introspection-runtime')

package() {
# Python2 fix
find -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'

install -d ${pkgdir}/usr/share/nemo-python/extensions


Use "#Python2 fix" in your all another nemo- packages too, nemo need and use python2, not python (=python3)

Merrick commented on 2015-11-22 13:29

error in the PKGBUILD, the pkg version 2.8.0 is "betsy", "rosa" is version 2.8.1.
So either set it up to use "rosa" or "betsy".
"betsy" PKGBUILD vars:
pkgver=2.8.0
_mintrel=betsy
sha256sum=('c78e5cb4c7f85d52a7a14f373795af2ebf8f8afb3bd59f6ea897cdd4d45c312d')

"rosa" PKGBUILD vars:
pkgver=2.8.1
_mintrel=rosa
sha256sum=('17eb327a6065f52384dc344c83f1b97e75170989420be1138b2d01d09d2852eb')

nullptr_t commented on 2015-06-03 01:04

Thanks & done.

petrucci4prez commented on 2015-06-02 23:00

updated for 2.6; now requires vte290 instead of vte

All comments