Package Details: neo4j-community 4.1.3-1

Git Clone URL: https://aur.archlinux.org/neo4j-community.git (read-only, click to copy)
Package Base: neo4j-community
Description: A fully transactional graph database implemented in Java
Upstream URL: http://neo4j.org/
Licenses: custom
Conflicts: neo4j-enterprise
Submitter: tucho
Maintainer: hakami1024
Last Packager: hakami1024
Votes: 61
Popularity: 0.027164
First Submitted: 2015-12-30 05:23
Last Updated: 2020-10-12 14:08

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

mgd commented on 2015-10-16 09:00

All I said about 2.2.3, 2.2.4 and 2.2.5 seems to be is still valid for 2.2.6.

Kind regards,
Michael

ajendrex commented on 2015-10-15 21:07

Hello,

Is it possible to ask for an upgrade to 2.2.6?

Thanks in advance,
H.

mgd commented on 2015-08-28 12:51

Just tried this with 2.2.5 - works unchanged

mgd commented on 2015-08-27 07:57

FWIW I've taken the 2.2.1 patches and adjusted them for 2,2,3. These seem to work unchanged for 2.2.4. I have no idea if that is all that needs to be done. However on my system it seems to work...but then I'm only toying with it...

Only changes were to bin.patch and conf.patch. Since I can't add attachments to this comment and the patches are 10k in total size - anybody interested contact me directly and I'll send them.

Hope it helps somebody, regards

Dietr1ch commented on 2015-08-13 23:09

neo4j.com/docs/stable/ says that we should be on v2.2.4

mgd commented on 2015-04-15 16:55

Thanks alot !

I did not see error messages regarding the number of files. Since I'm just starting to toy with neo4j I wasn't sure this was due to me not putting real load on the server...

tucho commented on 2015-04-15 14:56

Version 2.2.1-1 (soon enough, right?)

tucho commented on 2015-04-15 14:23

Here it is , folks. Sorry for the delay. And I know, we have 2.2.1 already. Coming soon...

@mgd: Thank you very much for your reports. Let me briefly explain what I did on those matters.

1) There is an undocumented property, dbms.security.auth_store.location, that tells Neo4j where to create the user auth data directory. I have put it in /etc/neo4j/neo4j-server.properties pointing to /var/lib/neo4j/data/dbms/auth, so that the owner is correctly set.

2) The max number of opened files was already been addressed by the systemd service declaration. Did you see any error messages on this?

Once again, thank you.

mgd commented on 2015-04-14 14:16

As an afterthought:
Some stuff from the neo4j manual, especially the bottom of the section "24.12 Linux Performance Guide" IMO should be mentioned during installation of the package.

Namely I mean these lines:

Edit /etc/security/limits.conf and add these two lines:

neo4j soft nofile 40000
neo4j hard nofile 40000

Edit /etc/pam.d/su and uncomment or add the following line:

session required pam_limits.so

A restart is required for the settings to take effect.

Kind regards

mgd commented on 2015-04-14 14:12

I have tried to adjust the package file for 2.1.7 to 2.2.0.

With a few manual adjustments (some patches need manual tweaking) it worked and I could create a package that installed.

However upon starting the server it almost instantly crashes with an exception. The server tries to create an authstore under /usr/share/java/neo4j/data. /usr/share/java/neo4j is root:root 755 and thus the process owned by neo4j can't create that directory.

I assume the intention of the changed directory layout as of the ArchLinux package is that the above store should instead be created under /var/lib/neo4j (and then ./data) which is neo4j:neo4j 755 and thus would work.

I have no idea how to tell the neo4j server to use that other path instead.
I therefor manually created /usr/share/java/neo4j/data and made it neo4j:neo4j 755 and after that the server starts and seems to run w/o apparent issues.

Any ideas how to do this properly ?