Package Details: neon-wallet-bin 2.12.9-1

Git Clone URL: https://aur.archlinux.org/neon-wallet-bin.git (read-only, click to copy)
Package Base: neon-wallet-bin
Description: Lightweight Wallet for the NEO CryptoCurrency
Upstream URL: https://github.com/CityOfZion/neon-wallet
Licenses: MIT
Submitter: DescartesHorse
Maintainer: pablogomez
Last Packager: pablogomez
Votes: 17
Popularity: 0.034362
First Submitted: 2018-01-25 04:42 (UTC)
Last Updated: 2022-07-14 23:04 (UTC)

Latest Comments

LucasBeyak commented on 2022-01-04 22:44 (UTC)

@pablogomez

Thanks for updating the package to 2.11.0, but the PKGBUILD still has the old checksum, and hence fails the validity check.

Can you please update the checksum in the PKGBUILD?

jsimon0 commented on 2020-12-11 03:05 (UTC)

In case anybody wants to build from PKGBUILD manually...

# Maintainer: Stephen Argent <steve [at] tuxcon [dot] com>

pkgname=neon-wallet-bin
pkgdesc='Lightweight Wallet for the NEO CryptoCurrency'
license=('MIT')
url='https://github.com/CityOfZion/neon-wallet'
pkgver=2.6.1
pkgrel=1
arch=('x86_64')
deb_package="Neon.${pkgver}.deb"
source_x86_64=(
  "${url}/releases/download/v${pkgver}/${deb_package}"
)
sha256sums_x86_64=(cf081f99f8c6874568c60716ad61f03007602e454211eaba728f4f8b1dd04db4)

install=neon-wallet-bin.install

package() {
  if [ "$CARCH" = "x86_64" ] ; then
    deb_arch="amd64"
  else
    echo "Unknown arch: $CARCH"
    exit 1
  fi

  cd "$srcdir"
  ar xf "$deb_package"
  tar xf data.tar.xz -C "$pkgdir"
}

pablogomez commented on 2020-09-18 10:20 (UTC)

There's a missing dependency (gconf)

archlinux error while loading shared libraries: libgconf-2.so.4

DescartesHorse commented on 2018-08-28 03:15 (UTC) (edited on 2018-08-28 03:17 (UTC) by DescartesHorse)

Thanks @andykluger - not sure what happened there :/ Will push a fix momentarily! Edit: fixed!

andykluger commented on 2018-08-28 02:56 (UTC)

The install file is what scientists call "all screwy." Three functions start, but only one ends.

DescartesHorse commented on 2018-01-25 04:44 (UTC)

@evilgnome - apologies for misleading you. I've submitted a request to have this moved to neon-wallet-bin. Thanks

andykluger commented on 2018-01-25 02:30 (UTC)

I think this is misleading, as it's convention to append package names with -bin when they just plop binary blobs into the system. Can you please update this to build from source, as the package name suggests?