Package Details: neovim-git 0.4.0.r2116.geee0668818-1

Git Clone URL: https://aur.archlinux.org/neovim-git.git (read-only, click to copy)
Package Base: neovim-git
Description: Fork of Vim aiming to improve user experience, plugins, and GUIs.
Upstream URL: https://neovim.io
Keywords: editor vim
Licenses: custom:neovim
Conflicts: neovim
Provides: neovim=0.4.0.r2116.geee0668818
Submitter: fhahn
Maintainer: fwalch
Last Packager: fwalch
Votes: 207
Popularity: 1.67
First Submitted: 2014-02-21 19:50
Last Updated: 2020-11-03 17:55

Dependencies (20)

Required by (98)

Sources (1)

Pinned Comments

fwalch commented on 2016-07-04 19:52

Please don't flag this package out-of-date just because the version number displayed on AUR seems old. This is normal for VCS packages. As long as building the package works without problems, it isn't necessary to update the PKGBUILD here. makepkg will automatically retrieve the latest version when you build the package locally.

fhahn commented on 2014-04-27 09:23

I've updated the PKBUILD, thanks for your feedback dtzWill & petelewis

petelewis commented on 2014-04-27 09:03

It also seems that once installed, it expects to find things in /usr/local rather than /usr. E.g.

"syntax on" in .nvimrc gives me this:

E484: Can't open file /usr/local/share/vim/syntax/syntax.vim

Is there a build-time flag which should be set to make nvim look in /usr instead?

petelewis commented on 2014-04-27 09:00

I had to add luarocks as a dep (possibly just a makedep?) to build this. Thanks.

dtzWill commented on 2014-04-22 17:14

This package fails to build when 'ninja' is installed on the system.

'make cmake' generates ninja build files if possible, which causes
the later attempt to 'cd build' and 'make' to fail since
no Makefiles were generated.

Easiest solution is to simply remove 'cd build' from the PKGBUILD entirely,
as 'make' in the root directory defaults to invoking the proper build tool on the build directory.

Alternatively you could choose to specify the build tool if desired, but that seems more fragile.

philpirj commented on 2014-04-21 12:50

Any idea what's wrong with yanking to/pasting from X clipboard?
I have autocutsel installed, and this works perfectly fine with mainline vim:
set clipboard=unnamedplus
But not for neovim.
From :help clipboard-unnamedplus
{only in GUI versions or when the +xterm_clipboard
Cannot find xterm_clipboard anywhere in neovim's source.

nNa commented on 2014-04-15 21:54

I successfully built neovim with system libraries, but it's probably better to fetch them at build, since lua-cmsgpack isn't available on AUR without installing luarocks.

nNa commented on 2014-04-15 21:52

I got the same issue, but I wasn't able to reproduce it later. I've submitted a pull request on GitHub to fix this.

nNa commented on 2014-04-15 21:51

I've got the same issue, but I wasn't able to reproduce it later. I've submitted a pull request on GitHub to fix this.

fhahn commented on 2014-04-15 21:26

I looked into the build issues. Neovim needs msgpack, lua51-lpeg and cmsgpack to build, but it seems like the build script does not take system libraries into account. I've updated the PKGBUILD to use `make cmake` which fetches and builds the dependencies (using luarocks for the lua stuff). But there seems to be a build error :

pkgbuilds/neovim/src/neovim/src/term.c:3452:48: error: ‘row_char’ may be used uninitialized in this function [-Werror=maybe-uninitialized]
if (j == 1 && tp[i] == 'R' && row_char == '2' && col >= 2) {
^

fkoehler commented on 2014-04-15 20:14

msgpack
lua51-lpeg

and cmsgpack (https://github.com/antirez/lua-cmsgpack not in the AUR yet) are required