Package Details: neovim-git 0.4.0.r1426.g4ab7bbf3ea-1

Git Clone URL: https://aur.archlinux.org/neovim-git.git (read-only, click to copy)
Package Base: neovim-git
Description: Fork of Vim aiming to improve user experience, plugins, and GUIs.
Upstream URL: https://neovim.io
Keywords: editor vim
Licenses: custom:neovim
Conflicts: neovim
Provides: neovim=0.4.0.r1426.g4ab7bbf3ea
Submitter: fhahn
Maintainer: fwalch
Last Packager: fwalch
Votes: 206
Popularity: 1.80
First Submitted: 2014-02-21 19:50
Last Updated: 2020-07-06 08:07

Dependencies (19)

Required by (96)

Sources (1)

Pinned Comments

fwalch commented on 2016-07-04 19:52

Please don't flag this package out-of-date just because the version number displayed on AUR seems old. This is normal for VCS packages. As long as building the package works without problems, it isn't necessary to update the PKGBUILD here. makepkg will automatically retrieve the latest version when you build the package locally.

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 12 13 14 ... Next › Last »

fwalch commented on 2015-11-02 09:08

eolianoe: Thanks! Will incorporate that later.

flannelhead: It's still required, I just linked it statically in the "neovim" package. Probably will do the same here, as the libvterm API will likely get breaking changes soon (and thus Neovim would not build with the latest -bzr version anymore).

flannelhead commented on 2015-11-02 09:05

Is libvterm-bzr required as a dependency any longer? The non-git neovim package seems to have dropped it.

eolianoe commented on 2015-11-02 08:21

Could you clean the build directory before the build [1], in order to have a clean build each time ?

[1] https://framabin.org/?37f851ddcc3c223d#s0Th79VogWdEq2KqBtVUEO35nMZ+e93VUC9Oc1fFYuo=

fwalch commented on 2015-10-27 07:41

FYI, from [1]:

Neovim now supports XDG configuration. The default config paths changed, so ~/.nvimrc and ~/.nvim/ will *not* be found by default. See :help nvim-from-vim for quick migration steps.

[1] https://github.com/neovim/neovim/wiki/Following-HEAD#20151026

fwalch commented on 2015-10-24 05:43

This package has been flagged out-of-date with a note "please update to the latest version", but AFAIK manually updating the version should not be necessary for a VCS package. I therefore unflagged the package without any PKGBUILD changes. If I'm missing something, please let me know.

fwalch commented on 2015-10-06 22:03

eworm: Ha, timing.. just after you write this (and months after the last commit to libtermkey), it looks like libtermkey 0.18 will released soon, because of bugfixes for Neovim [1]. When that's up, I'll change the dependency.

[1] https://github.com/neovim/neovim/issues/2048#issuecomment-146011718

fwalch commented on 2015-10-06 21:01

eworm: upstream uses a non-released version [1] (from a Git mirror, otherwise identical to the original bzr repo), therefore I'd rather not change that. Some commits to libtermkey after its last release (therefore only in -bzr package) were contributed by Neovim when it switched the terminal UI to libtermkey, so changing the dependency would probably introduce bugs.

[1] https://github.com/neovim/neovim/blob/master/third-party/CMakeLists.txt#L89

eworm commented on 2015-10-06 08:09

Looks like this works just fine with libtermkey (the non-bzr package). Can we change the dependency, please? This will not break existing setups as libtermkey-zr provides libtermkey.

fwalch commented on 2015-09-26 21:59

willemw:

1) Yes:

$ vercmp 1.0 1.0.r1
-1

3) Well, that's a legacy that can't be changed, because:

$ vercmp 0.r1 r1
1

Also, according to the wiki a leading zero is allowed: "If there are no public releases and no repository tags then zero could be used as a release number".

Anyway, this will be moot as soon as the first release is out (which is soon). Then the version will be in format 1.0.r1.

willemw commented on 2015-09-26 17:09

1) Dependency check against Neovim's release version ("neovim>=1.0"): OK.
Dependency check against an AUR VCS-package version ("neovim>=$pkgver") ==> ("neovim>=1.0.r10"): does not seem OK to me.
Didn't know that "pkgver=1.0.r10" would satisfy "neovim>=1.0". Sure?
2) To be honest, in one of my packages I also have a 'depends' refer to a VCS-package.
3) pkgver() function should return a string starting with a version number or with an 'r', not with a dummy '0'.