Package Details: neovim-nightly-git 0.5.0.r828.g0a95549d6-2

Git Clone URL: https://aur.archlinux.org/neovim-nightly-git.git (read-only, click to copy)
Package Base: neovim-nightly-git
Description: Fork of Vim aiming to improve user experience, plugins, and GUIs (pre-release build)
Upstream URL: https://neovim.io
Keywords: development editor text text-editor
Licenses: custom:neovim
Conflicts: neovim
Provides: neovim=0.5.0, vim-plugin-runtime
Submitter: BertalanD
Maintainer: BertalanD
Last Packager: BertalanD
Votes: 3
Popularity: 1.15
First Submitted: 2020-08-19 12:58
Last Updated: 2020-11-17 13:28

Dependencies (15)

Required by (208)

Sources (1)

Pinned Comments

BertalanD commented on 2020-11-18 20:59

The Neovim developers have been updating the nightly tag very inconsistently lately, so this package lags quite a bit behind HEAD. Currently, completion-nvim is broken due to it (https://github.com/nvim-lua/completion-nvim/issues/274).

If you experience any issues, you might want to switch to the better maintained and up-to-date neovim-git AUR package instead.

Latest Comments

BertalanD commented on 2020-11-18 20:59

The Neovim developers have been updating the nightly tag very inconsistently lately, so this package lags quite a bit behind HEAD. Currently, completion-nvim is broken due to it (https://github.com/nvim-lua/completion-nvim/issues/274).

If you experience any issues, you might want to switch to the better maintained and up-to-date neovim-git AUR package instead.

kflak commented on 2020-11-17 14:05

Works now! Thanks, @BertalanD, for the quick fix.

vetse commented on 2020-11-17 12:46

I had the same compilation issue. I solved it by installing tree-sitter before trying to build the package.

kflak commented on 2020-11-17 09:08

Getting this when trying to build:

CMake Error at cmake/LibFindMacros.cmake:263 (message):
  REQUIRED PACKAGE NOT FOUND

  We could not find development headers for TreeSitter.  Do you have the
  necessary dev package installed? This package is REQUIRED and you need to
  install it or adjust CMake configuration in order to continue building
  nvim.

  Relevant CMake configuration variables:

    TreeSitter_INCLUDE_DIR=<not found>
    TreeSitter_LIBRARY=<not found>

  You may use CMake GUI, cmake -D or ccmake to modify the values.  Delete
  CMakeCache.txt to discard all values and force full re-detection if
  necessary.

Call Stack (most recent call first):
  cmake/FindTreeSitter.cmake:11 (libfind_process)
  CMakeLists.txt:377 (find_package)


-- Configuring incomplete, errors occurred!

BertalanD commented on 2020-08-19 13:06

This package -- unlike neovim-nightly -- automatically downloads the latest available nightly tag from GitHub.

When 0.5.0 is released, this PKGBUILD will stop working correctly, so please send me an email or a message on Matrix if I forget about it.