Package Details: netatop 2.0-2

Git Clone URL: https://aur.archlinux.org/netatop.git (read-only, click to copy)
Package Base: netatop
Description: Atop network kernel module, enables network statistics in atop
Upstream URL: http://www.atoptool.nl/
Keywords: atop kernel module netatop
Licenses: GPL
Groups: modules
Submitter: Spider.007
Maintainer: Spider.007
Last Packager: Spider.007
Votes: 24
Popularity: 0.23
First Submitted: 2013-02-16 11:58
Last Updated: 2020-02-12 17:48

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

eigengrau commented on 2015-02-22 15:51

The official grsecurity kernels are using a uname of the form «3.18.7.201502200813-1-grsec». The extramodules path includes the subminor version number, so we’d have «/usr/lib/modules/extramodules-3.18.7-grsec/» there.

Best regards!

Spider.007 commented on 2015-02-09 17:14

@ttoirrah; this is a known issue; you'll probably need to recompile this package.

ttoirrah commented on 2015-02-08 23:03

After upgrading to kernel 3.18.6-1, bootup error:
system-modules-load: Failed to insert 'netatop'

kgunders commented on 2015-01-21 08:22

Man, this should be in official arch repos.... But I guess the average arch desktop user is not interested in network performance. Sigh....

eigengrau commented on 2015-01-08 22:32

Works nicely, thanks!

Spider.007 commented on 2015-01-08 17:40

I have adressed both issues with some regexp magic

Spider.007 commented on 2015-01-08 17:40

I have adressed both issues with some regexp magic

eigengrau commented on 2015-01-08 06:49

I’m also seeing the conflict on /lib. This is likely due to the changed behavior in Pacman 4.2:

«Previously, if pacman was installing a package and it found files in /lib, it would follow the symlink and install it in /usr/lib. However the filelist for that package still recorded the file in /lib. This caused heaps of difficulty in conflict resolving – primarily the need to resolve every path of all package files to look for conflicts. That was a stupid idea! So now if pacman sees a /lib directory in a package, it will detect a conflict with the symlink on the filesystem.»

http://allanmcrae.com/2014/12/pacman-4-2-released/

cobalt commented on 2015-01-08 00:59

With this new version I have

error: failed to commit transaction (conflicting files)
netatop: /lib exists in filesystem

And also I am using linux-ck kernel and each time I have to edit PKGBUILD for netatop and replace "-ARCH" with "-ck" in the line

install -Dm 0744 module/netatop.ko $pkgdir/lib/modules/extramodules-${v%.*}-ARCH/netatop.ko

Spider.007 commented on 2014-10-26 11:37

I have created a patch for 3.17; it seems to work; comments welcome!