Package Details: netfabb-basic 7.4.0-1

Git Clone URL: https://aur.archlinux.org/netfabb-basic.git (read-only)
Package Base: netfabb-basic
Description: view and repair STL files
Upstream URL: http://www.netfabb.com/downloadcenter.php?basic=1
Licenses: custom:freeware
Submitter: swiftgeek
Maintainer: swiftgeek
Last Packager: swiftgeek
Votes: 9
Popularity: 0.032040
First Submitted: 2013-06-02 01:36
Last Updated: 2016-04-19 00:26

Latest Comments

nivata commented on 2016-04-25 11:45

Hi guys,

On my computer with 64bit architecture, netfabb-basic works fine with gtk2 (i.e. we can comment l.23 of the PKGBUILD).

mrunion commented on 2016-04-19 01:41

OK, here's the deal -- for whatever reason, when cower updates the package, it did NOT update the PKGBUILD info, so the checksum was wrong in there.

swiftgeek commented on 2016-04-19 01:05

@mrunion Start from answering to my comment from 2016-02-26 or reaching me on freenode (eg. #slic3r channel but you can just /query swiftgeek)

mrunion commented on 2016-04-19 01:01

Update for 7.4.0, still checksum problem. I will try to download it manually and check the difference.

I am on Arch 64-bit. I don't know the file size or checksum because when the download fails checksum it deleted the file (what sense is that? Why not leave the file? I know that's not your fault.) I have to download the file manually and then run the md5sum on it and it takes a while for me to ferret out all that stuff from the PKGBUILD.

swiftgeek commented on 2016-04-18 23:59

For 32bit i cannot download it anymore: "Your download is unfortunately no longer available or your key has expired." - that's in chrome and firefox browsers

swiftgeek commented on 2016-02-26 06:37

@mrunion: can you provide some details? arch, file size, md5sum of that file
Also check if download wasn't corrupted (this is what md5sum is for)

mrunion commented on 2016-02-26 01:43

Are the md5sums right in this latest release?

swiftgeek commented on 2015-11-22 01:58

Ok, install is for strange DRM protection not sure if needed for anything (obviously not installing THAT and giving it root rights on system, hell no)
So what is left are 3 libs and 21M binary, which is not enough to make a package, sigh. I will have to figure out something from 5.2.1 and 6.4.0 and a way to download EULA from site in pikey grabbing step as it isn't inside archive anymore

hax commented on 2015-03-11 21:28

you are right, the tar.gz file which is downloaded automatically is the 32bit version, even tough the file is named netfabb-basic_5.2.1_linux64.tar.gz

when I download it manually I get the 64bit version which works fine with the calculated hashes.

now I have to find out, why the wrong version is loaded...

BRGDS

swiftgeek commented on 2015-03-11 11:42

That's hash of 32-bit version, check your environment [$CARCH] (And check PKGBUILD next time)

hax commented on 2015-03-11 07:20

64bit version needs an update on the md5 hash:
50b43a88530b5bd4736a88048d121801

brgds

swiftgeek commented on 2015-03-10 15:17

It actually fails only from within DLAGENT line, works anywhere else in pkgbuild

swiftgeek commented on 2015-03-10 14:58

I have no idea why my DLAGENT fails from within PKGBUILD, while when called from user bash/zsh with the same command as in /proc/PID/cmdline - finishes download successfully

swiftgeek commented on 2014-09-01 15:30

Changed DLAGENT for sending special, required message to netfabb (Customizable in PKGBUILD)

swiftgeek commented on 2014-09-01 15:16

now download requires POST data :<

swiftgeek commented on 2014-02-25 14:44

Ok, new version has also 64-bit and i have lost interwebz access so 64-bit version will arrive later … if it really is 64-bit ofc

swiftgeek commented on 2013-09-10 19:15

New version (5.0.0) is at least for now 32-bit only, so regular gtk2 theming may not work properly :<
Thx for nickoe for providing pikey fetching, required for download

swiftgeek commented on 2013-09-03 05:58

Oh… new version (5.0.0) is at least for now 32-bit only, so regular gtk2 theming may not work properly :<
And has generated pikey in download url http://www.netfabb.com/download.php?pikey=WuHOZzhsQZUjHAT so automagic download probably wont work :<

swiftgeek commented on 2013-09-03 05:37

Oh… new version (5.0.0) is at least for now 32-bit only :<
And has generated pikey in download url http://www.netfabb.com/download.php?pikey=WuHOZzhsQZUjHAT so automagic download probably wont work :<

swiftgeek commented on 2013-09-03 05:28

FFS why nobody is bitching about this package being outdated for so long!?

swiftgeek commented on 2013-06-02 01:36

NOT READY yet