Package Details: netrik 1.16.1-2

Git Clone URL: https://aur.archlinux.org/netrik.git (read-only)
Package Base: netrik
Description: The ANTRIK Internet Viewer/Browser/Explorer/Navigator/whatever.
Upstream URL: http://netrik.sourceforge.net/
Licenses: GPL
Submitter: None
Maintainer: aksr
Last Packager: aksr
Votes: 16
Popularity: 0.000000
First Submitted: 2006-11-15 15:45
Last Updated: 2015-06-27 09:19

Latest Comments

aksr commented on 2013-05-10 15:38

sleduc: Thank you, applied. If better solution comes along, I'll apply it.

sleduc commented on 2011-11-01 16:58

It seems that netrik now uses ncursesw library instead of ncurses since version 1.16.1.
The problem with ncursesw (as exposed in [0] and [1] for instance) is that since archlinux only provide
the wide headers of ncurses (that is to say ncursesw), so including <ncursesw/curses.h> will fail on archlinux
since the only available header file is in /usr/lib/curses.h

I guess some ways to fix this is to modify sources (sed -e -i s#<ncursesw/curses.h>#<curses.h>#g) for all
source file including ncursesw, or simply create simlinks.
I don't see a proper way to do that thought…
Nevertheless you can try this which is working : http://pastebin.com/HRb6ZypD

[0] https://bugs.archlinux.org/task/13994
[1] https://bugs.archlinux.org/task/17590

Sara commented on 2011-04-22 21:13

I can't build netrik 1.16.1 (using this package and updating the version number), for I get the following error:

links.c:12:29: fatal error: ncursesw/curses.h: No such file or directory
compilation terminated.
make[2]: *** [links.o] Error 1
make[2]: Leaving directory `/tmp/packerbuild-1000/netrik/netrik/src/netrik-1.16.1'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/packerbuild-1000/netrik/netrik/src/netrik-1.16.1'
make: *** [all] Error 2

However, the version provided by this PKGBUILD by default (1.16-2) does work. Could someone provide me a pointer?