Package Details: network-manager-applet-gtk2 0.9.8.10-2

Git Clone URL: https://aur.archlinux.org/network-manager-applet-gtk2.git (read-only)
Package Base: network-manager-applet-gtk2
Description: GNOME frontends to NetWorkmanager compiled for gtk2
Upstream URL: http://www.gnome.org/projects/NetworkManager/
Licenses: GPL
Conflicts: network-manager-applet
Provides: network-manager-applet=0.9.8.10
Submitter: None
Maintainer: bidulock
Last Packager: bidulock
Votes: 40
Popularity: 0.000003
First Submitted: 2011-07-10 18:30
Last Updated: 2015-06-10 13:16

Required by (20)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

bidulock commented on 2014-01-12 09:45

Because the package builds a gnome-bluetooth plugin.

Louis commented on 2014-01-12 05:19

Why is gnome-bluetooth listed as a makedep? This doesn't make any sense to me.

bidulock commented on 2013-11-19 20:52

Ask the maintainer of https://www.archlinux.org/packages/extra/x86_64/network-manager-applet/

Louis commented on 2013-11-19 16:43

Why is gnome-icon-theme not optional? I'm using MATE and don't see the reason why I need that dependency.

JoveYu commented on 2013-05-05 16:29

thinks @ptrxyz,

vldmr commented on 2013-03-21 07:10

In .ui files I change GtkBox to GtkVBox. It's work now.

ptrxyz commented on 2013-03-21 06:54

I can confirm what vldmr said.
I added the two "sed ..."-lines to the build() function in PKGBUILD to replace the GtkBox with GtkVBox and it seems to be working now. However, some GTK warnings remain.

...
build() {
cd ${_pkgname}-${pkgver}
# Next two lines should fix the error when editing connections
# --> see vldmr's post.
sed -i 's/GtkBox/GtkVBox/g' src/connection-editor/ce-page-general.ui
sed -i 's/GtkBox/GtkVBox/g' src/connection-editor/nm-connection-editor.ui
./configure --prefix=/usr --sysconfdir=/etc --with-gtkver=2 \
--localstatedir=/var \
--libexecdir=/usr/lib/networkmanager \
--disable-static \
--disable-more-warnings \
--disable-maintainer-mode \
--disable-migration
make
}
...

vldmr commented on 2013-03-21 05:47

In .ui files I change GtkBox to GtkVBox. It's work now.

ptrxyz commented on 2013-03-21 05:29

Same error here when trying to edit connections:
(nm-connection-editor:8518): Gtk-WARNING **: Unknown property: GtkComboBox.margin-left
(nm-connection-editor:8518): Gtk-WARNING **: Unknown property: GtkComboBox.margin-bottom
(nm-connection-editor:8518): Gtk-WARNING **: Unknown property: GtkCheckButton.margin-bottom
(nm-connection-editor:8518): Gtk-WARNING **: Unknown property: GtkBox.valign
(nm-connection-editor:8518): Gtk-WARNING **: Unknown property: GtkBox.vexpand
(nm-connection-editor:8518): GLib-GObject-ERROR **: cannot create instance of abstract (non-instantiatable) type `GtkBox'

However, version 0.9.6 works like a charm. (--> edit PKGBUILD, set pkgver=0.9.6.4 and md5sums=('8750d83a1151f5f9b0edd2ffcd4e8fc6'))

ptrxyz commented on 2013-03-21 05:17

Still getting the error mentioned below:

(nm-connection-editor:8518): Gtk-WARNING **: Unknown property: GtkComboBox.margin-left
(nm-connection-editor:8518): Gtk-WARNING **: Unknown property: GtkComboBox.margin-bottom
(nm-connection-editor:8518): Gtk-WARNING **: Unknown property: GtkCheckButton.margin-bottom
(nm-connection-editor:8518): Gtk-WARNING **: Unknown property: GtkBox.valign
(nm-connection-editor:8518): Gtk-WARNING **: Unknown property: GtkBox.vexpand
(nm-connection-editor:8518): GLib-GObject-ERROR **: cannot create instance of abstract (non-instantiatable) type `GtkBox'

Any ideas how to fix it?