Package Details: network-ups-tools 2.7.4-5

Git Clone URL: https://aur.archlinux.org/network-ups-tools.git (read-only)
Package Base: network-ups-tools
Description: NUT is a collection of programs for monitoring and administering UPS hardware
Upstream URL: http://www.networkupstools.org/
Licenses: GPL2
Submitter: Atsutane
Maintainer: The-Compiler
Last Packager: The-Compiler
Votes: 79
Popularity: 0.391071
First Submitted: 2010-09-21 19:10
Last Updated: 2017-04-28 20:10

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

BeepDog commented on 2013-01-17 04:02

I'm getting a failure building this:

make[2]: Leaving directory `/build/src/nut-2.6.5'
make[1]: Leaving directory `/build/src/nut-2.6.5'
install: cannot stat '/build/upsd.init': No such file or directory

this line:
`install -D -m755 $startdir/upsd.init $pkgdir/etc/rc.d/upsd || return 1`
seems to be at fault. It doesn't seem to be able to find upsd.init.

realx commented on 2012-10-21 10:18

configure options updated, thanks mrechte

mrechte commented on 2012-10-19 15:57

Could you please check the configure options? The current ones create a /share directory at the root of the fs. I suggest:

--prefix=/usr \
--with-udev-dir=/usr/lib/udev \
--with-systemdsystemunitdir=/lib/systemd/system/ \
--datadir=/usr/share/ups \
--with-udev-dir=/usr/lib/udev \
--sysconfdir=/etc/ups || return 1

mrechte commented on 2012-10-16 06:04

The nut-driver.service.patch problem has been reported upstream and should be corrected in next release. See http://trac.networkupstools.org/projects/nut/changeset/3757

realx commented on 2012-10-15 19:17

updated to 2.6.5

realx commented on 2012-10-15 19:15

updated to 2.6.5

gborzi commented on 2012-07-17 20:28

I suggest adding --with-udev-dir=/usr/lib/udev to configure and !makeflags in options.

gborzi commented on 2012-07-17 20:16

I suggest adding --with-udev-dir=/usr/lib/udev to configure and !makeflags in options.

apoulos commented on 2012-07-14 16:11

upsd.init md5sum: 089ea4a56552253328d17603ff5670cc

Anonymous comment on 2012-07-11 16:14

"USB drivers requested, but libusb not found." error while trying to compile.
Solved by installing libusb-compat. Dependencies should probably be updated.
To build a new version, change pkgver to 2.6.4 and md5sum to 78d672fbbcd90683e49c667665a95f87