Package Details: networkmanager-git 1.37.1.r29870.g1a5b85ad-1

Git Clone URL: https://aur.archlinux.org/networkmanager-git.git (read-only, click to copy)
Package Base: networkmanager-git
Description: Network Management daemon
Upstream URL: http://www.gnome.org/projects/NetworkManager
Licenses: GPL2, LGPL2.1
Conflicts: networkmanager
Provides: networkmanager
Submitter: None
Maintainer: SolarAquarion
Last Packager: SolarAquarion
Votes: 28
Popularity: 0.000000
First Submitted: 2008-12-20 09:14 (UTC)
Last Updated: 2022-02-27 17:02 (UTC)

Required by (262)

Sources (3)

Latest Comments

kogasa commented on 2022-03-25 17:39 (UTC) (edited on 2022-03-25 17:39 (UTC) by kogasa)

error: failed to lookup: networkmanager-git: fatal: remote error:

The unauthenticated git protocol on port 9418 is no longer supported.

Please see https://github.blog/2021-09-01-improving-git-protocol-security-github/ for more information.

nariox commented on 2019-10-11 15:30 (UTC)

Seems like few people are using this package. Following jamespharvey20's suggestion, I was able to compile the PKGBUILD from extra using commit cab2e4fc96bbe21d048ade49fd1db0a7b5c5d0f4

jamespharvey20 commented on 2019-05-01 22:33 (UTC) (edited on 2019-05-01 22:35 (UTC) by jamespharvey20)

This fails to build in a chroot environment:

Dependency qtcore found: NO (tried pkgconfig)

examples/C/qt/meson.build:12:0: ERROR: Dependency "QtCore" not found, tried pkgconfig

This PKGBUILD differs so much from the one in extra, I'd recommend grabbing that PKGBUILD and making as few changes as necessary to get it to build the -git version. It builds without qt. IMO, if you want one with qt, I'd call it networkmanager-qt-git.

Someone in IRC was saying they can build this but can't install it via pacman due to conflicting files with package python-pygments, on /usr/lib/python3.7/site-packages/pygments/__init__.py, which this package shouldn't have in it. Good chance going off the extra PKGBUILD will fix this issue too.

wknapik commented on 2018-06-25 23:59 (UTC)

Missing dependencies: gtk-doc, intltool.

Also, this is just broken. Like lines 154-157 (or should I say 154-166) of PKGBUILD - that's not how heredocs work.

AmishNazi commented on 2018-06-19 15:26 (UTC)

Install qt4 and dnsmasq

cp ~/.cache/pacaur/networkmanager-git/src/networkmanager-git/build/man/common.ent ~/.cache/pacaur/networkmanager-git/src/networkmanager-git/build/docs/api/

Fixes the current package.

Depau commented on 2018-06-09 13:02 (UTC) (edited on 2018-06-09 13:02 (UTC) by Depau)

The package is currently not building because of:

  • missing qt4 and dnsmasq build deps
  • gtkdoc-mkhtml error during build - can't find build/docs/api/common.ent, it's actually in build/docs/man/common.ent.

I don't know if last one is an upstream bug though.

mweinelt commented on 2018-02-13 22:28 (UTC)

Please configure "--with-iwd=yes" to allow iwd as a wifi.backend.

mirh commented on 2017-04-02 00:23 (UTC)

2to3 is useless since 4 months fiy. And shouldn't this replace (and be in conflict with) "standard" libnm? You screwed something up in its repackaging then. Files are going to root instead of /usr. Remove line 190. Aside of this, the thing finally builds fine.

commented on 2017-03-20 15:19 (UTC)

I have the same error like the one on Tuerai's comment.

Tuerai commented on 2017-03-19 11:41 (UTC)

Hey. I am getting the following failure to build this package today: Traceback (most recent call last): File "./libnm/generate-setting-docs.py", line 197, in <module> settings = sorted(settings, cmp=cmp_settings) TypeError: 'cmp' is an invalid keyword argument for this function make[2]: *** [Makefile:16996: libnm/nm-property-docs.xml] Error 1 make[2]: *** Deleting file 'libnm/nm-property-docs.xml' make[2]: Leaving directory '/tmp/yaourt-tmp-fury/aur-networkmanager-git/src/networkmanager-git' make[1]: *** [Makefile:15631: all-recursive] Error 1 make[1]: Leaving directory '/tmp/yaourt-tmp-fury/aur-networkmanager-git/src/networkmanager-git' make: *** [Makefile:6422: all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build networkmanager-git. ----- From some googling, it looks like it may be trying to use python 3 instead of python 2 or something?

alextu commented on 2016-12-27 06:18 (UTC)

it works well on my vmware guest, $ pacman -Q | grep network network-manager-applet-git 1.4.3.dev.r124.gad9fb7b5-1 networkmanager-git 1.5.3.r16518.g8adbeb821-1 $ pacman -Q | grep libnm libnm-glib-git 1.5.3.r16518.g8adbeb821-1

rumanzo commented on 2016-06-21 19:00 (UTC)

/usr/bin/ld: ../../properties/.libs/libnm-vpn-plugin-openvpn-test.a(libnm_vpn_plugin_openvpn_test_la-nm-vpn-plugin-utils.o): undefined reference to symbol 'dlclose@@GLIBC_2.2.5' /usr/lib/libdl.so.2: error adding symbols: DSO missing from command line collect2: error: ld returned 1 exit status

Viper_Scull commented on 2014-10-18 14:28 (UTC)

Please update pkgbuild with ppp = 2.4.7 or at least > 2.4.6 Core version of ppp = 2.4.7-1

luolimao commented on 2014-08-18 06:51 (UTC)

Updated.

asppsa commented on 2014-08-18 04:42 (UTC)

Hi, Here is a patch for this. I've taken the changes mentioned by quequotion below and also merged all the changes from the current PKGBUILD for NetworkManager 0.9.10. Most of the patches seem to be no longer required. https://gist.github.com/asppsa/0a756ba3ac3dbf9fc2eb

quequotion commented on 2014-08-13 16:09 (UTC)

also, need to add "libnm-glib=$pkgver" to provides() and 'libnm-glib' to conflicts()

quequotion commented on 2014-08-13 16:04 (UTC)

I was able to install by deleting nm-polkit-permisive.patch and disable_set_hostname.patch then updating dnsmasq-path.patch There is one new line to add to each section of dnsmasq-path.patch (check the source files). disable_set_hostname.patch may be irrelevant; this code has significantly changed. nm-polkit-permissive.patch could be updated, but I want to see the default security setting first.

commented on 2014-02-07 05:37 (UTC)

The patches are failing to apply and build is failing.

luolimao commented on 2013-07-04 20:33 (UTC)

Updated.

ksj commented on 2013-05-26 06:55 (UTC)

It doesn't work. It needs this: https://live.gnome.org/LibGSystem

luolimao commented on 2012-11-02 21:43 (UTC)

Thanks, fixed.

yegorius commented on 2012-11-02 20:06 (UTC)

Please change this line "--with-session-tracking=ck \" to this "--with-session-tracking=systemd \"

luolimao commented on 2012-10-09 23:12 (UTC)

Updated with systemd, correct /lib folder, and other stuff from the original networkmanager package.

popsch commented on 2012-08-31 00:40 (UTC)

FYI, networkmanager-git doesn't work with systemd

XeCycle commented on 2012-08-14 05:55 (UTC)

We moved /lib to /usr/lib, udev rule files should move accordingly.

commented on 2011-01-09 19:01 (UTC)

--disable-wimax to PKGBUILD

td123 commented on 2011-01-08 06:37 (UTC)

I get the following error when building: http://aur.pastebin.com/4bsb7hkT

td123 commented on 2011-01-05 06:52 (UTC)

orphaning because maintainer has disappeared

eazy commented on 2010-12-15 10:17 (UTC)

Since the maintainer has disappeared, here's a working PKGBUILD: http://pastebin.ca/raw/2020121

rnestler commented on 2010-09-16 13:50 (UTC)

could you add gtk-doc and git to the makedepends as lz3060 and gonX suggested? And fix the provides, replaces and conflicts fields as ProgDan requested?

commented on 2010-08-03 18:00 (UTC)

You need git to be able to compile this package. Please add it to makedepends.

commented on 2010-07-01 21:57 (UTC)

policykit-gnome is now polkit-gnome

lz3060 commented on 2010-05-15 18:57 (UTC)

building this package requires /usr/bin/gtkdocize which comes from gtk-doc

commented on 2010-04-29 16:08 (UTC)

Please fix the provides, replaces and conflicts fields, there should networkmanager instead of libnetworkmanager.