Package Details: networkmanager-ifupdown 0.9.8.10-6

Git Clone URL: https://aur.archlinux.org/networkmanager-ifupdown.git (read-only)
Package Base: networkmanager-ifupdown
Description: Network Management daemon
Upstream URL: http://www.gnome.org/projects/NetworkManager/
Licenses: GPL2, LGPL2.1
Conflicts: networkmanager
Provides: networkmanager=0.9.8.10
Submitter: bidulock
Maintainer: bidulock
Last Packager: bidulock
Votes: 5
Popularity: 0.000708
First Submitted: 2013-03-29 15:12
Last Updated: 2016-06-13 00:34

Required by (108)

Sources (3)

Latest Comments

kozaki commented on 2016-06-12 13:42

Am trying to build your PKGBUILD to improve my i3bar.
Please how to set the SYSTEMD_LOGIN_CFLAGS and SYSTEMD_LOGIN_LIBS env variables so to try further building it?

---
<SNIP>
checking for SYSTEMD_200... yes
checking Session tracking support... checking for SYSTEMD_LOGIN... no
configure: error: Package requirements (libsystemd-login) were not met:

No package 'libsystemd-login' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables SYSTEMD_LOGIN_CFLAGS
and SYSTEMD_LOGIN_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

bidulock commented on 2015-08-02 00:02

0.9.8.10 is last version that supports GTK2

jamesan commented on 2015-08-01 13:27

The latest version of NetworkManager is 1.0.4, released July 14:
http://cgit.freedesktop.org/NetworkManager/NetworkManager/tag/?id=1.0.4

marlock commented on 2014-11-30 08:00

I find the patch that fixing bug with libnl-3.2.25. Please, add it.
http://pastebin.com/zbDpGk34
Patching with patch -Np1 -i

marlock commented on 2014-08-28 14:09

Yes, it works with libnl-3.2.24. I think it's incompatibility with new libnl (libnl's changelog is rather big).

bidulock commented on 2014-08-28 10:12

Did it work with libnl-3.2.24? I will put up (or embed) a libnl package that works if necessary. Or is it some upstream bug?

marlock commented on 2014-08-26 17:57

It doesn't work with libnl-3.2.25-1. Service doesn't starts.

bidulock commented on 2014-08-20 20:53

Not out of date. 0.9.8.10 is the last version that supports GTK2.

justbrowsing commented on 2014-08-06 15:27

@bidulock
Disregard this bug, works with yaourt (yaourt builds the whole thing twice though, so what's the point of using subpackages?)

I'll just leave this note: not all AUR helpers properly support subpackages, something to keep in mind.

justbrowsing commented on 2014-08-06 15:16

@bidulock

I think the problem may lie in the AUR helper not creating proper subpackages.

# apacman -S libnm-glib-ifupdown
Aur Targets (1): libnm-glib-ifupdown
==> Tidying install...
-> Purging unwanted files...
-> Removing libtool files...
-> Removing static library files...
-> Compressing man and info pages...
-> Stripping unneeded symbols from binaries and libraries...
==> Creating package "libnm-glib-ifupdown"...
-> Generating .PKGINFO file...
-> Generating .MTREE file...
-> Compressing package...
==> Finished making: networkmanager-ifupdown 0.9.8.10-4
-> Saved package: networkmanager-ifupdown-0.9.8.10-4-i686.pkg.tar.xz

# pacman -U /var/cache/apacman/pkg/networkmanager-ifupdown-0.9.8.10-4-i686.pkg.tar.xz
loading packages...
resolving dependencies...
warning: cannot resolve "libnm-glib-ifupdown", a dependency of "networkmanager-ifupdown"
:: The following package cannot be upgraded due to unresolvable dependencies:
networkmanager-ifupdown

# pacman -Q | grep -e libnm -e networkmanager
libnm-glib 0.9.10.0-2

All comments