Package Details: networkmanager-wireguard-git r87.0e1124d-1

Git Clone URL: https://aur.archlinux.org/networkmanager-wireguard-git.git (read-only, click to copy)
Package Base: networkmanager-wireguard-git
Description: NetworkManager VPN plugin for WireGuard - git
Upstream URL: https://github.com/max-moser/network-manager-wireguard/
Licenses: GPL
Conflicts: networkmanager-wireguard
Provides: networkmanager-wireguard
Submitter: Depau
Maintainer: Depau
Last Packager: Depau
Votes: 40
Popularity: 0.99
First Submitted: 2018-04-30 18:16
Last Updated: 2020-01-03 22:04

Latest Comments

1 2 Next › Last »

Depau commented on 2020-07-19 15:43

@dpriedel:

All Linux kernel packages (for normal Arch Linux x86_64) provide WIREGUARD-MODULE: https://www.archlinux.org/packages/core/x86_64/linux/

If you're using ALARM, that's a bug in the kernel packages, I'm gonna send them a pull-request.

Depau commented on 2020-07-19 15:39

This package does not depend on resolvconf. wireguard-tools does. Please open a bug on the issue tracker for wireguard-tools.

brackenhill-mob commented on 2020-07-19 08:44

Needs a dependency for a DNS resolver (ie openresolv)

/var/daemon.log always reports NetworkManager[2941]: /usr/sbin/wg-quick: line 32: resolvconf: command not found

dpriedel commented on 2020-05-05 20:05

Hi

Since kernel 5.6 includes the wireguard kernel module, how should I build this extension? Can I just delete the WIREGUARD-MODULE dependency?

Thanks

timttmy commented on 2019-12-29 21:06

Thanks for the PKGBUILD It also builds and works on arm by changing arch='any'

Depau commented on 2019-09-09 14:07

Added. Thank you

mhthies commented on 2019-09-08 10:44

Building in a clean chroot fails with the following error:

checking for LIBNM_GLIB... no
configure: error: Package requirements (NetworkManager >= 1.7.0
            libnm-util >= 1.7.0
            libnm-glib >= 1.7.0
            libnm-glib-vpn >= 1.7.0) were not met:

Package 'NetworkManager', required by 'virtual:world', not found
Package 'libnm-util', required by 'virtual:world', not found
Package 'libnm-glib', required by 'virtual:world', not found
Package 'libnm-glib-vpn', required by 'virtual:world', not found

It can be fixed by adding a build dependency on libnm-glib

Depau commented on 2019-02-12 08:54

Fixed. Thank you.

K900 commented on 2019-02-08 21:27

This doesn't actually need to depend on nm-connection-editor, just libnma.

Depau commented on 2019-01-28 21:08

Done. Sorry for having you wait, I forgot to update it.