Package Details: newlisp 10.7.0-1

Git Clone URL: https://aur.archlinux.org/newlisp.git (read-only)
Package Base: newlisp
Description: newLISP is a LISP like, general purpose scripting language.
Upstream URL: http://www.newlisp.org
Licenses: GPL
Submitter: scrawler
Maintainer: scrawler
Last Packager: scrawler
Votes: 20
Popularity: 0.100279
First Submitted: 2005-07-23 16:24
Last Updated: 2016-03-25 21:18

Dependencies (2)

Required by (0)

Sources (1)

Latest Comments

haawda commented on 2015-01-20 07:00

10.6.2 is out, using c680a5da323d0c07eaf985663a96ec51 as md5sum.

hav3lock commented on 2014-04-22 04:00

@scrawler, doesn't build. Build fails. PKGBUILD provided by @m3thodic works just fine.

m3thodic commented on 2014-04-14 19:51

Also update the version number for the symlinks in newlisp.install:

sed -ie 's/10.5.4/10.6.0/g' newlisp.install

m3thodic commented on 2014-04-14 19:48

New PKGBUILD for 10.6.0: http://pastebin.com/bY4hjEfZ

haawda commented on 2013-11-23 16:05

conan, see https://aur.archlinux.org/packages/newlisp-devel/

conan commented on 2013-11-21 13:05

BTW, yesterday a memory leak was found, so it's 10.5.6 now ;)

conan commented on 2013-11-21 13:01

While Lutz call them "development" versions, the true is they often include new features. This one in particular not only does that, but also has a several important bug fixes.

scrawler commented on 2013-11-21 01:10

I never have kept up with the development versions. 10.5.5 is a development version. Thanks for keeping me on my toes, though
:-)

conan commented on 2013-11-20 21:40

New stable version v10.5.5 :)

conan commented on 2013-10-01 17:45

New stable version v10.5.4 :)

conan commented on 2013-07-11 15:54

New stable version v10.5.3 :)

Also you missed .0, .1 and .2 updates. This package needs some love. I can maintain it if you don't have time. Just disown it.

conan commented on 2013-05-21 16:15

New stable version v10.5.0 :)

scrawler commented on 2012-07-16 14:10

will it build if you just remove the dependency altogether?

Anonymous comment on 2012-07-15 18:21

After I edited PKGBUILD and replaced `kernel-headers' with `linux-headers' in depends the package built.

conan commented on 2011-09-21 23:45

Version 10.3.3 is out and they removed 10.3.2, so this PKGBUILD will fail.

You need to edit the PKGBUILD and change pkgver and md5sums to:

pkgver=10.3.3
md5sums=('9f997690d09b96dca9c3843784b13702')

Then edit newlisp.install and change both references to /usr/bin/newlisp-10.3.2 to:

/usr/bin/newlisp-10.3.3

Also there's no need to have the last line in the PKGBUILD to remove /usr/bin/newlisp, this is taken care on newlisp.install already and it gives an error if there's no previous newlisp installation.