Package Details: nextcloud-client-appimage-daily 1:3.5.50.20220615-1

Git Clone URL: https://aur.archlinux.org/nextcloud-client-appimage-daily.git (read-only, click to copy)
Package Base: nextcloud-client-appimage-daily
Description: Nextcloud desktop client (official daily AppImage build)
Upstream URL: https://download.nextcloud.com/desktop/daily/Linux
Licenses: GPL2
Conflicts: nextcloud-client, nextcloud-client-git, owncloud-client
Provides: nextcloud-client
Submitter: leBasti
Maintainer: AkechiShiro
Last Packager: AkechiShiro
Votes: 6
Popularity: 0.021563
First Submitted: 2018-06-30 21:41 (UTC)
Last Updated: 2022-06-15 20:15 (UTC)

Required by (2)

Sources (1)

Pinned Comments

nobodywasishere commented on 2020-10-28 21:34 (UTC)

This PKGBUILD is updated everyday using a script very similar to this: https://gist.github.com/nobodywasishere/38ad7814f5e0fbf4ef18b2860b058a90. It checks to make sure the PKGBUILD works on the new version and updates the sha256sum. If necessary, just modifying pkgver will give you that date's build.

Latest Comments

AkechiShiro commented on 2021-12-13 15:36 (UTC)

The link to the AppImage is now fixed, I'll be maintaining the package now, if there is anything that goes wrong, feel free to comment here, also if @nobodywasishere could provide me the script to update, or I could write my own real quick based on the one linked.

leuko commented on 2021-12-10 13:31 (UTC)

The link to the AppImage seems to be broken.

nursoda commented on 2021-06-02 20:02 (UTC)

Seems that the script that creates PKGBUILD did not run, just got a version that is a month old.

nobodywasishere commented on 2021-05-03 16:22 (UTC)

@faisalm @AkechiShiro Fixed it, it should work now. Forgot to make the source file download have a unique filename so it was constantly setting the sha256 sum to an older version instead of the current one.

faisalm commented on 2021-03-05 04:53 (UTC)

I'm now getting the same issue as @AkechiShiro was. It fails the sha256 checksum.

Building nextcloud-client-appimage-daily...
==> Making package: nextcloud-client-appimage-daily 1:3.1.50.20210216-2 (Thu 04 Mar 2021 09:44:04 PM)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading nextcloud.AppImage...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  102M  100  102M    0     0  5911k      0  0:00:17  0:00:17 --:--:-- 9108k
==> Validating source files with sha256sums...
    nextcloud.AppImage ... FAILED
==> ERROR: One or more files did not pass the validity check!
Error: Failed to build nextcloud-client-appimage-daily

nobodywasishere commented on 2020-11-27 16:29 (UTC)

@@AkechiShiro Fixed, for some reason the update script didnt update the sha256sum. Thanks for the heads up

AkechiShiro commented on 2020-11-27 14:21 (UTC) (edited on 2020-11-27 14:22 (UTC) by AkechiShiro)

Actually I'm getting this error, it seems the sha256sum check fails.

aura >>= Building nextcloud-client-appimage-daily...
==> Making package: nextcloud-client-appimage-daily 1:3.1.0.20201102-1 (ven. 27 nov. 2020 15:19:56)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading nextcloud.AppImage...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  101M  100  101M    0     0  13.2M      0  0:00:07  0:00:07 --:--:-- 6734k
==> Validating source files with sha256sums...
    nextcloud.AppImage ... FAILED
==> ERROR: One or more files did not pass the validity check!
aura >>= There was a makepkg failure.

nobodywasishere commented on 2020-10-28 21:34 (UTC)

This PKGBUILD is updated everyday using a script very similar to this: https://gist.github.com/nobodywasishere/38ad7814f5e0fbf4ef18b2860b058a90. It checks to make sure the PKGBUILD works on the new version and updates the sha256sum. If necessary, just modifying pkgver will give you that date's build.

Chriss commented on 2019-11-25 17:18 (UTC) (edited on 2019-11-25 17:22 (UTC) by Chriss)

install: cannot stat 'nextcloud.desktop': No such file or directory

From: 7z x -y ${_pkgname}.AppImage ${_pkgname}.desktop > /dev/null

To: 7z x -y ${_pkgname}.AppImage com.${_pkgname}.desktopclient.${_pkgname}.desktop > /dev/null

From: install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"

To: install -Dm644 "com.${_pkgname}.desktopclient.${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"

Thanks!

leBasti commented on 2019-06-02 14:21 (UTC)

Thanks for the heads-up @nyi and @tinfoil-hacks! I changed the download strategy to retrieve the latest version dynamically. This might be pretty unstable, so be aware!

nyi commented on 2019-05-24 14:54 (UTC)

The download strategy unfortunately no longer works as https://download.nextcloud.com/desktop/daily/Linux/latest.AppImage returns a 403 forbidden. The public listing of https://download.nextcloud.com/desktop/daily/Linux/ only includes versioned filenames now.

tinfoil-hacks commented on 2019-03-31 15:46 (UTC)

Permissions for icons don't need to be 755. Please change to 644. Thanks.

mcnesium commented on 2018-09-02 11:02 (UTC)

This still installs Version 2.5.0daily (build 20180701) as shown above. I just removed and re-installed this package using Paman on Manjaro Linux:

Built from Git revision 09e2a4 on Jul 1 2018, 03:00:33 using Qt 5.11.0, OpenSSL 1.0.2g 1 Mar 2016

leBasti commented on 2018-08-22 20:28 (UTC)

I checked it again, and it installs the latest available build as intended. Make sure to quit and restart your client after the install!

leBasti commented on 2018-08-21 07:21 (UTC)

@mannp I'll have to check that tomorrow as I'm currently not at home.. The PKGBUILD retrieves the appimage from "https://download.nextcloud.com/desktop/daily/Linux/latest.AppImage" so I guess it's your problem locally.

mannp commented on 2018-08-18 17:29 (UTC)

I've flagged as out of date, but not sure if its an upstream problem or mine locally.

I have installed and it only installs the version from the 12th rather than the 18th, even though the 'latest' version is dated the 18th in the nextcloud downloads area?