Package Details: nginx-mainline-mod-modsecurity 1.0.3-1

Git Clone URL: https://aur.archlinux.org/nginx-mainline-mod-modsecurity.git (read-only, click to copy)
Package Base: nginx-mainline-mod-modsecurity
Description: ModSecurity v3 Nginx Connector (module for mainline nginx)
Upstream URL: https://github.com/SpiderLabs/ModSecurity-nginx
Licenses: GPL3
Submitter: mtorromeo
Maintainer: mtorromeo
Last Packager: mtorromeo
Votes: 5
Popularity: 0.000005
First Submitted: 2018-01-15 09:05 (UTC)
Last Updated: 2022-05-24 08:03 (UTC)

Latest Comments

duffydack commented on 2024-06-04 05:48 (UTC) (edited on 2024-06-07 18:15 (UTC) by duffydack)

Now getting this error building.

checking for ModSecurity library ... not found checking for ModSecurity library in /usr/local/modsecurity ... not found /usr/src/nginx/configure: error: ngx_http_modsecurity_module requires the ModSecurity library. ``

nginx-mainline-mod-modsecurity-git builds and works however.

matse commented on 2022-02-23 11:15 (UTC)

@jskier: Thanks for this hint. I had the same problem: currently this package doesn't build with default settings. Configuring with "--without-pcre2" is a workaround. Maybe the package should be updated, until the issue is fixed upstream?

jskier commented on 2022-01-04 21:13 (UTC)

Had to build without pcre2 in order to compile, as noted here: https://github.com/SpiderLabs/ModSecurity-nginx/issues/261

TesterMcTest commented on 2020-12-25 09:09 (UTC)

The current _nginxver is outdates (and its sha25sum as well): _nginxver=1.19.6

and 'b11195a02b1d3285ddf2987e02c6b6d28df41bb1b1dd25f33542848ef4fc33b5'