Package Details: nikola 7.8.10-5

Git Clone URL: https://aur.archlinux.org/nikola.git (read-only)
Package Base: nikola
Description: A modular, fast, simple, static website generator.
Upstream URL: https://getnikola.com/
Licenses: MIT
Conflicts: nikola-git, python-nikola, python-nikola-git, python2-nikola, python2-nikola-git
Replaces: python-nikola, python2-nikola
Submitter: Kwpolska
Maintainer: Kwpolska
Last Packager: Kwpolska
Votes: 16
Popularity: 0.222182
First Submitted: 2017-09-20 10:31
Last Updated: 2017-10-03 15:47

Dependencies (31)

Required by (1)

Sources (2)

Latest Comments

jswagner commented on 2017-10-06 00:58

Update: Says it completed successfully!

Kwpolska commented on 2017-10-03 15:47

@jswagner Thanks. I tried to fix it, and made failures non-fatal (as this is an optional component).

jswagner commented on 2017-10-03 05:53

@Kwpolska
--
Creating tab completion...
Traceback (most recent call last):
File "/home/jason/build/nikola/pkg/nikola/usr/bin/nikola", line 6, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3138, in <module>
@_call_aside
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3122, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3151, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 664, in _build_master
ws.require(__requires__)
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 981, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 867, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'Nikola==7.8.10' distribution was not found and is required by the application
==> ERROR: A failure occurred in package_nikola().
Aborting...

Kwpolska commented on 2017-10-02 09:35

@jswagner: how does it fail? Remove "2> /dev/null" on lines 49 and 50 of the PKGBUILD and tell me where it goes wrong. It works fine for me.

dvzrv commented on 2017-10-02 07:38

@Kwpolska: Thanks a lot!

jswagner commented on 2017-10-02 05:56

package_nikola() fails on my system at 'Creating tab completion...'.

Kwpolska commented on 2017-10-01 12:49

@dvzrv: added in 7.8.10-4

dvzrv commented on 2017-09-30 12:29

@Kwpolska: Could you add bash and zsh completion as per [1] to this package?

[1] https://getnikola.com/handbook.html#shell-tab-completion

Kwpolska commented on 2016-10-14 07:18

@hiliev

Oh, sorry. I sometimes wish things were less case-sensitive. Fixed in 7.8.1-2.

hiliev commented on 2016-10-13 22:22

Hi! The PKGBUILD is broken. The name of the directory in the archive is Nikola-7.8.1 while the PKGBUILD tries to cd into ${_pyname}-${pkgver}, which expands to nikola-7.8.1. Replacing ${_pyname} with ${_pynameweb} on lines 23, 46, and 56 fixes the problem.

All comments