Package Details: nitroshare 0.3.4-2

Git Clone URL: https://aur.archlinux.org/nitroshare.git (read-only)
Package Base: nitroshare
Description: Network File Transfer Application
Upstream URL: https://nitroshare.net
Licenses: MIT
Submitter: lobisquit
Maintainer: sakaru (nathan-osman)
Last Packager: nathan-osman
Votes: 40
Popularity: 0.584631
First Submitted: 2012-06-25 09:06
Last Updated: 2018-11-16 07:48

Dependencies (7)

Required by (0)

Sources (2)

Latest Comments

1 2 3 4 5 6 Next › Last »

nathan-osman commented on 2018-11-16 07:49

Sorry for the delay, everyone. I've updated the PKGBUILD to apply the patch now.

rhoit commented on 2018-11-05 09:09

maintainer please fix this package, as per https://github.com/nitroshare/nitroshare-desktop/issues/197

http://svnweb.mageia.org/packages/cauldron/nitroshare/current/SOURCES/nitroshare-0.3.4-fix-build-against-qt-5.11.0.patch?view=markup&pathrev=1233418

add following linein PKGBUILD, build() section for quick fix!

sed -i '26a#include <QStyle>' src/application/splashdialog.cpp

jhincks commented on 2018-10-20 21:44

@arun321 it compiled fine on my machine with the PKGBUILD and patch by glitsj16. did you try those? i copied the patch into a file called 'unfuck-0.3.4.patch' into the same folder of the PKGBUILD and in the PKGBUILD i changed the lines sha256sums=('29874e5909c29211a3c9e13f8c0f49b901ec2996e5d60d80af80d2fb80c3d7ec' '64845271cec37bbd91084465ce124de8313f27da49a155e210cdd2abc14b04f5') into sha256sums=('29874e5909c29211a3c9e13f8c0f49b901ec2996e5d60d80af80d2fb80c3d7ec' 'SKIP') then it worked.

arun321 commented on 2018-08-10 11:57

Cannot compile. It throws errors

mozo commented on 2018-05-30 15:49

Thank you. The PKGBUILD and the patch are working.

glitsj16 commented on 2018-05-26 07:05

Due to a bug in the 0.3.4 code this package doesn't build correctly at the moment. People who don't want to wait for an official fix can use this PKGBUILD with the accompaning patch.

Anonymous comment on 2018-03-01 12:42

@nathan-osman oh I just realized why the http api has made no sense for me. because it lacks in your package the dependency to "python2-requests", so it was not installed with me and the nautilus plugin does not work! i think you should add "qhttpengine", "qmdnsengine" and "python2-requests" as required dependencies or add "python2-requests" as optional dependencie for the nautilus plugin. thanks, for the App. ;-)

nathan-osman commented on 2018-02-27 19:57

Yes, QMdnsEngine is required for discovering Android devices since they do not support the legacy IPv4 broadcast discovery mechanism. QHttpEngine does not affect transfers with Android devices - its purpose is to expose an HTTP API that other local applications (ones running under the same user account as the NitroShare client) can use to initiate transfers.

I will consider making both of them required dependencies.

Anonymous comment on 2018-02-27 18:54

Hi, there. The "qhttpengine" and "qmdnsengine" package should not set as an optional option, because without the "qhttpengine" you can not send files to some Android Devices and without the "qmdnsengine" package the Devices can not find each other. It must be installed befor you build nitroshare!

sakaru commented on 2016-10-18 12:10

Thanks, I've changed it to use your PKGBUILD