Package Details: nodejs-0.12 0.12.15-1

Git Clone URL: https://aur.archlinux.org/nodejs-0.12.git (read-only)
Package Base: nodejs-0.12
Description: Evented I/O for V8 javascript (legacy version 0.12)
Upstream URL: http://nodejs.org/
Licenses: MIT
Conflicts: nodejs
Provides: nodejs=0.12.15
Submitter: phw
Maintainer: None
Last Packager: phw
Votes: 5
Popularity: 0.000000
First Submitted: 2015-09-17 09:23
Last Updated: 2016-12-05 07:42

Required by (660)

Sources (1)

Latest Comments

ejona86 commented on 2016-12-04 02:56

nodejs 0.12.17 builds and runs for me.

I was unable to build earlier versions, even ones that had built successfully before. mksnapshot would get a segmentation fault. I'm blaming a gcc upgrade, since it looks like the addition of -fno-delete-null-pointer-checks in 0.12.16 may have resolved the crash. https://github.com/nodejs/node/issues/6724

phw commented on 2016-08-17 08:23

So I tried to compiling the new package, but it will always fail for me. Anybody succeeded in compiling 0.12.15 on an up-to-date arch install? If so please tell me how :D

Otherwise I'm actually considering giving up on this package. I have personally switched to a Vagrant VM for the last project where I need 0.12, as running node 0.12 on my Arch box caused more issues than it solved. If somebody wants to take over this package let me know. Otherwise I would of course like to have this up-to-date, but I cannot currently invest much time into hunting down the compile issue :(

phw commented on 2016-08-04 16:32

@muhviehstarr Thanks, I will update it soon. But for the future it is enough to use the "flag as outdated" function, no need for a double notification by comment and spam everyone ;)

muhviehstarr commented on 2016-08-04 16:03

please update to Version 0.12.15
sha256sum : c446d40d9b0eb876dab9a87c3dbd1935dc85155d2ad991b36ddd6c5ca3825a5e

phw commented on 2015-11-05 13:21

Thanks Svenstaro, fixed

Svenstaro commented on 2015-11-04 21:24

Make sure you make it provide nodejs=$pkgver in order to prevent bad bad conflicts.