Package Details: nodejs-elm 0.18.0-1

Git Clone URL: https://aur.archlinux.org/nodejs-elm.git (read-only)
Package Base: nodejs-elm
Description: Binaries for the Elm programming language
Upstream URL: https://www.npmjs.com/package/elm
Keywords: Elm
Licenses: BSD
Submitter: aepsil0n
Maintainer: thorsten
Last Packager: thorsten
Votes: 5
Popularity: 0.032558
First Submitted: 2015-04-17 09:53
Last Updated: 2016-11-30 14:58

Latest Comments

thorsten commented on 2016-11-30 14:59

Thanks cippaciong! I've updated the optional dependency to libtinfo5, so ncurses5-compat-libs is suggested automatically by the aurweb.

cippaciong commented on 2016-11-30 14:33

Hello, the libtinfo optional dependency is not working anymore because provides libtinfo 6 now while elp-repl requires libtinfo 5. As an alternative you can use ncurses5-compat-libs: https://aur.archlinux.org/packages/ncurses5-compat-libs/

mherold commented on 2015-11-24 16:27

Personally, I would rather compile it myself so I'm going to disown this package in favor of Luchs' version.

Luchs commented on 2015-11-21 23:08

I created an (up-to-date) alternative to this package which compiles Elm from source: https://aur.archlinux.org/packages/elm-platform

Compiling Haskell is really slow though, so you may still prefer the prebuilt binaries from NPM.

jtojnar commented on 2015-09-22 20:17

I get following error when makepkging.

npm WARN lifecycle elm@2.0.0~postinstall: cannot run in wd %s %s (wd=%s) elm@2.0.0 node lib/install.js

Had to run the post-install hook (`node lib/install.js`) manually.