Package Details: nodejs-groovebasin 1.5.1-1

Git Clone URL: (read-only, click to copy)
Package Base: nodejs-groovebasin
Description: Music player server with a web-based user interface inspired by Amarok 1.4
Upstream URL:
Licenses: MIT
Submitter: christoph.gysin
Maintainer: christoph.gysin
Last Packager: christoph.gysin
Votes: 6
Popularity: 0.000000
First Submitted: 2012-03-14 19:30
Last Updated: 2016-02-24 13:33

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

kevinf28 commented on 2015-02-18 14:11

Can someone please confirm that it builds correctly as 1.5.0 with a fully updated system / nodejs 0.12 ?

Getting some weird compile errors, and im not a node dev, so no ideas... Where is ?!

make: Entering directory '/tmp/makepkg/nodejs-groovebasin/src/groovebasin-1.5.0/node_modules/groove/build'
CXX(target) Release/
CXX(target) Release/
CXX(target) Release/
In file included from ../src/
../src/gn_file.h:8:40: error: expected class-name before ‘{’ token
class GNFile : public node::ObjectWrap {

Full log:

christoph.gysin commented on 2014-12-10 12:32

It hasn't crashed for me so far. Try getting a backtrace to see where it comes from, and report the bug in the respective upstream project.

espenaf commented on 2014-12-10 11:31

With 1.4.0-1 and nodejs-0.10.33-8 I am getting random crashed with the following log message:

groovebasin[22578]: node: ../nptl/pthread_mutex_lock.c:81: __pthread_mutex_lock: Assertion `mutex->__data.__owner == 0' failed.

jprjr commented on 2014-08-11 19:08

Can you add python2 as a make dependency?

I'm making a small vm just for this, and none of the deps actually install python2. It's listed as an optional dep for nodejs.

richli commented on 2014-08-07 04:38

@Mo6eB: Thanks, that did the trick!

Mo6eB commented on 2014-08-06 14:43

richli, run as your regular user

npm config set python /usr/bin/python2

This sets the default python executable which gyp will use.

richli commented on 2014-07-29 14:44

I get the following error:

> Error: Python executable "python" is v3.4.1, which is not supported by gyp.
> You can pass the --python switch to point to Python >= v2.5.0 & < 3.0.0.

I have the python and python2 packages installed. I'm not familiar with node so I'm not sure where I pass the "--python" switch to point to the Python 2.7 binary.

jerebear commented on 2014-07-16 20:43


christoph.gysin commented on 2014-07-16 20:41

There are some node modules included that can use gnuplot, but groovebasin does not use it. Therefore it should not be listed as a dependency.

jerebear commented on 2014-07-14 22:04

Nice job cleaning up the package.

You're correct: this package does not need graphviz. However, namcap does recommend gnuplot be installed. [1] Please excuse my mention of graphviz. I was working off memory.