Package Details: nodejs-heroku-cli 6.14.20-1

Git Clone URL: https://aur.archlinux.org/nodejs-heroku-cli.git (read-only)
Package Base: nodejs-heroku-cli
Description: The next generation Node-based Heroku CLI
Upstream URL: https://github.com/heroku/cli
Keywords: heroku heroku-cli
Licenses: ISC
Conflicts: heroku, heroku-toolbelt
Submitter: terut
Maintainer: terut
Last Packager: terut
Votes: 5
Popularity: 0.258962
First Submitted: 2017-06-05 05:04
Last Updated: 2017-09-10 16:29

Latest Comments

terut commented on 2017-06-14 22:58

Thank you for your report.
I add some packages to avoid conflict :)

About your error, would you tell me your node version?
cli-engine requires the node version higher than 7.10.0 and this tool works well with community/nodejs on my enviroments. The latest node version is 8.1.1.

I updated this package, so please try new one.

springer commented on 2017-06-14 10:32

I think this package conflicts with the old aur/heroku-toolbelt package. Both provide the heroku executable.

Additionally I'm encountering the following error:

% heroku :(
/usr/lib/node_modules/heroku-cli/node_modules/cli-engine/lib/cli.js:73
async run() {
^^^
SyntaxError: Unexpected identifier
at Object.exports.runInThisContext (vm.js:76:16)
at Module._compile (module.js:528:28)
at Object.Module._extensions..js (module.js:565:10)
at Module.load (module.js:473:32)
at tryModuleLoad (module.js:432:12)
at Function.Module._load (module.js:424:3)
at Module.require (module.js:483:17)
at require (internal/module.js:20:19)
at Object.<anonymous> (/usr/lib/node_modules/heroku-cli/bin/run.js:2:34)
at Module._compile (module.js:556:32)