Package Details: nodejs-jshint 2.9.2-1

Git Clone URL: https://aur.archlinux.org/nodejs-jshint.git (read-only)
Package Base: nodejs-jshint
Description: Static analysis tool for JavaScript
Upstream URL: http://jshint.com/
Licenses: MIT
Submitter: None
Maintainer: jnbek
Last Packager: jnbek
Votes: 52
Popularity: 0.841370
First Submitted: 2011-11-17 23:50
Last Updated: 2016-04-20 21:00

Latest Comments

BoySka commented on 2016-02-24 20:01

https:// in the source will work; could you switch to it? I can submit a patch, but it is probably easier if you just do it yourself.

justin8 commented on 2015-05-21 23:44

Hi, it looks like this needs to depend on npm now as well:

Notice: npm is not shipped with nodejs since 0.12.2-4, please install npm manually if you need it.
Optional dependencies for nodejs
npm: nodejs package manager
/startdir/PKGBUILD: line 22: npm: command not found

Marcel_K commented on 2014-12-02 22:51

I now see that the MIT license is available in the source code, you can extract it from /usr/lib/node_modules/jshint/src/jshint.js. BTW, you shouldn't add multiple maintainer lines in your PKGBUILD, only add yourself as maintainer and the others as contributors. That way, it's easier to contact the current maintainer.

soul_rebel commented on 2014-12-02 21:32

PKGBUILD for version 2.5.10:

# Author: Anton Kovalyov <anton@kovalyov.net> (http://anton.kovalyov.net/)
# Maintainer: brentlintner <brent.lintner@gmail.com>
# Maintainer: antonkovalyov <anton@kovalyov.net>
# Maintainer: cracoucass14
# Maintainer: jnbek
pkgname=nodejs-jshint # All lowercase
_npmname=jshint
pkgver=2.5.10
_npmver=$pkgver
pkgrel=1
pkgdesc="Static analysis tool for JavaScript"
arch=(any)
url="http://jshint.com/"
license=(MIT)
depends=('nodejs')
optdepends=()
source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
noextract=($_npmname-$_npmver.tgz)
sha1sums=('2fef47ee0901914e31832123d5d3f434c28060ef')

package() {
cd "$srcdir"
local _npmdir="$pkgdir/usr/lib/node_modules/"
mkdir -p "$_npmdir"
cd "$_npmdir"
npm install --user root -g --prefix "$pkgdir/usr" $_npmname@$_npmver
}

Marcel_K commented on 2014-10-13 14:21

You should at lesat really fix the ownership of the files, like http://pastebin.com/Ab2CBAEN

michurin commented on 2014-07-01 10:57

Update PKGBUILD please:
6c6
< _npmver=2.5.0
---
> _npmver=2.5.1
8c8
< pkgver=2.5.0
---
> pkgver=2.5.1
18c18
< sha1sums=('82fd1a235ffce75fad1b40b2a38bef47beac8c54')
---
> sha1sums=('8e96d27377806767d40f16676fbec113d33520ec')

jnbek commented on 2014-04-14 19:48

Releasing to the wild. The project I was working on that required this package fell through and I don't really have the time to maintain this, along with the 800 other packages I'm working on.

Lekensteyn commented on 2013-03-16 09:38

This package suffers from the same problem as nodejs-grunt, installed files are owned by nobody (nobody shouldn't get any write access!). Furthermore, the license (LICENSE -> MIT) is missing.
https://github.com/Lekensteyn/aur/commit/b6647bd