Package Details: nodejs-lts-fermium 14.21.3-3

Git Clone URL: https://aur.archlinux.org/nodejs-lts-fermium.git (read-only, click to copy)
Package Base: nodejs-lts-fermium
Description: Evented I/O for V8 javascript (LTS release: Fermium)
Upstream URL: https://nodejs.org/
Keywords: javascript legacy longtermsupport lts node
Licenses: MIT
Conflicts: nodejs
Provides: nodejs
Submitter: GI_Jack
Maintainer: GI_Jack
Last Packager: GI_Jack
Votes: 0
Popularity: 0.000000
First Submitted: 2023-10-14 20:32 (UTC)
Last Updated: 2023-10-22 22:39 (UTC)

Required by (1774)

Sources (6)

Pinned Comments

GI_Jack commented on 2023-10-22 22:38 (UTC)

NOTE: This this version of node is entirely unsupported, is EOL, but is kept because its needed for legacy code.

If you can get away with not using this package, you probably should.

Latest Comments

servimo commented on 2023-10-23 19:28 (UTC) (edited on 2023-10-23 19:32 (UTC) by servimo)

Get an error when compiling: make[1]: *** [libnode.target.mk:316: /var/tmp/pamac-build-sergio/nodejs-lts-fermium/src/node-v14.21.3/out/Release/obj.target/ libnode/src/node.o] Error 1 make[1]: ** Waiting for other processes to finish. rm b44552320a2fb6fbc60be917bac50ca2b9e5afaf.intermediate f620cda02b8978a92cc626134c38ca48ed0991bc.intermediate make: *** [Makefile:109: node] Error 2 ==> ERROR: A failure occurred in package(). Aborting... At the beginning I saw this warning: Error: the key 1C4F0DFFF4E8C1A8236409D08E73BC641CC11F4C8 cannot be imported Error: the key 177984A986EBC2AA786BC0F66B01FBB92821C587A cannot be imported Error: the key 1B9AE9905FFD7803F25714661B63B535A4C206CA9 cannot be imported Error: the key 1DD8F2338BAE7501E3DD5AC78C273792F7D83545D cannot be imported Error: the key 1B9E2F5981AA6E0CD28160D9FF13993A75599653C cannot be imported Error: the key 14ED778F539E3634C779C87C6D7062848A1AB005C cannot be imported Error: the key 1C82FA3AE1CBEDC6BE46B9360C43CEC45C17AB93C cannot be imported Error: the key 174F12602B6F1C4E913FAA37AD3A89613643B6201 cannot be imported

GI_Jack commented on 2023-10-22 22:38 (UTC)

NOTE: This this version of node is entirely unsupported, is EOL, but is kept because its needed for legacy code.

If you can get away with not using this package, you probably should.

PolarianDev commented on 2023-10-20 09:42 (UTC)

Fermium released EOL (end of life) earlier this year.

Any package which depends on this needs to migrate to a newer version for security, unless it is not possible to do so (for example legacy code).

https://nodejs.org/en/blog/release/v14.15.0

Take care,
Polarian

delthas commented on 2023-10-17 08:54 (UTC)

The package build is failing:

Validating source files with sha256sums... nodejs-lts-fermium-openssl3-fix-test-tls-no-sslv3.patch ... FAILED ERROR: One or more files did not pass the validity check!

I changed line 25 of the PKGBUILD from:

bb5f91aeb0f87e7bcbed531fe8922beec1b51bd2ceeec91e9d25ede800817459 to bf7a1159078ff80037cb98414f2c9fb55a09475137b3cadcce5f0386c09e0cbf

This fixed the build.