Package Details: nodejs-lts-gallium 16.13.0-1

Git Clone URL: https://aur.archlinux.org/nodejs-lts-gallium.git (read-only, click to copy)
Package Base: nodejs-lts-gallium
Description: Evented I/O for V8 javascript
Upstream URL: https://nodejs.org/
Licenses: MIT
Conflicts: nodejs
Provides: nodejs
Submitter: truocolo
Maintainer: truocolo
Last Packager: truocolo
Votes: 3
Popularity: 2.48
First Submitted: 2024-02-07 01:37 (UTC)
Last Updated: 2024-02-07 01:37 (UTC)

Dependencies (10)

Required by (1795)

Sources (2)

Latest Comments

evgfilim1 commented on 2024-02-12 19:59 (UTC)

Fails to build with python from repos:

==> Making package: nodejs-lts-gallium 16.13.0-1 (Tue 13 Feb 2024 12:40:40 AM +05)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found nodejs-16.13.0.tar.gz
  -> Found system-c-ares.patch
==> Validating source files with sha512sums...
    nodejs-16.13.0.tar.gz ... Passed
    system-c-ares.patch ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting nodejs-16.13.0.tar.gz with bsdtar
==> Starting prepare()...
patching file src/cares_wrap.h
==> Sources are ready.
==> Making package: nodejs-lts-gallium 16.13.0-1 (Tue 13 Feb 2024 12:40:49 AM +05)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Removing existing $pkgdir/ directory...
==> Starting build()...
Node.js configure: Found Python 3.11.7...
Please use python3.10 or python3.9 or python3.8 or python3.7 or python3.6.
==> ERROR: A failure occurred in build().
    Aborting...

Successfully fixed by installing python310