Package Details: nodejs-nativefier 47.1.3-1

Git Clone URL: (read-only, click to copy)
Package Base: nodejs-nativefier
Description: A command-line tool to easily create a desktop app for any web site with minimal configuration
Upstream URL:
Licenses: MIT
Submitter: rokoucha
Maintainer: frealgagu
Last Packager: frealgagu
Votes: 68
Popularity: 1.85
First Submitted: 2016-02-20 05:39 (UTC)
Last Updated: 2022-05-04 19:25 (UTC)

Pinned Comments

frealgagu commented on 2021-11-08 15:02 (UTC)

I maintain the latest built package at:

Latest Comments

Technetium1 commented on 2022-01-17 03:28 (UTC) (edited on 2022-02-24 05:18 (UTC) by Technetium1)

Seems to work fine after bumping pkgver to 46.0.4. EDIT: 46.1.1 also works with no further changes.

frealgagu commented on 2021-11-08 15:02 (UTC)

I maintain the latest built package at:

ronjouch commented on 2021-09-20 15:53 (UTC) (edited on 2021-09-25 13:45 (UTC) by ronjouch)

Hi, upstream Nativefier maintainer here.

Heads up to the maintainers of this AUR package: in 45.0.1 I'm (re-)introducing lockfiles (package-lock.json + app/package-lock.json), for security & reproducibility reasons. Looking at your PKGBUILD I don't see obvious trouble with it, but please confirm. If upstream changes are needed, GitHub issue/PR welcome.


EDIT 2021-09-25 45.0.1 meant to introduce lockfiles, but a misunderstanding of npm publishing caused it to actually not have them. This was fixed in 45.0.4, which now actually includes the lockfiles.

ZorinArch commented on 2021-07-29 09:03 (UTC)

hi, please upgrade checksum to sha256sums.

lostkhaos commented on 2021-04-14 13:41 (UTC)

@gdamjan good call! Removed

gdamjan commented on 2021-04-14 11:47 (UTC)

--user root needs to be removed from the npm install

nevernow commented on 2021-03-25 13:12 (UTC)

I had the same problem as @najahiri. This fixed it:

sudo npm install -g semver@7.2.0 sudo npm install -g npm@7.7.4

najahiri commented on 2021-03-23 13:33 (UTC)

I am compiling the package and it gives an error in the form npm ERR! semver.simplifyRange is not a function and cannot complete the installation.

Freso commented on 2021-03-23 13:08 (UTC)

Has a bunch of /usr/lib/node_modules/root/ files conflicting with now.

7314776 commented on 2021-03-17 20:18 (UTC) (edited on 2021-03-17 21:20 (UTC) by 7314776)

@Superjolly002 21-03-17 I can confirm straight building in "clean" Arch worked (yaourt and pamac-aur failed in remnants of Antergos: dead repos disabled, survives just as "Arch w/graphic install", 2 different PCs; this may be a problem of messy optional [system, not package] dependencies preventing clean upgrade, if the problem persists, try building in clean chroot)

felixoi commented on 2021-03-15 17:45 (UTC)

@Superjolly002 upgrading npm from 7.6.0 to 7.6.3 fixed it for me.

lostkhaos commented on 2021-03-15 13:57 (UTC)

@Superjolly002 Can you build directly without a helper and post a gist to the debug error log? Alternatively, feel free to email me directly (email is in my profile).

Superjolly002 commented on 2021-03-15 08:29 (UTC)

@lostkhaos I tried to remove the npm and paru cache, but it didn't work. Other ideas?

lostkhaos commented on 2021-03-14 20:06 (UTC)

@Superjolly002 it looks like that might happen if something is confusing npm's cache (old version of npm or the use of nvm). Someone else on AUR managed to fix it by clearing their local npm cache, but we're overriding the cache in our PKGBUILD, so I would think that would prevent this.

Are you able to remove your helper's cache (~/.cache/paru/clone/nodejs-nativefier/) or build directly without using a helper?

Superjolly002 commented on 2021-03-14 08:58 (UTC) (edited on 2021-03-14 09:00 (UTC) by Superjolly002)

I can't update the package because of a missing function (I think):

npm ERR! semver.simplifyRange is not a function

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/foo/.cache/paru/clone/nodejs-nativefier/src/npm-cache/_logs/2021-03-14T08_57_50_764Z-debug.log

lostkhaos commented on 2020-11-17 05:11 (UTC)

Folks on NPM 7, be aware that there's an upstream issue that breaks --prefix see here.

lostkhaos commented on 2020-11-17 05:08 (UTC)

@mxfm your issue is likely related to that bug then.

mxfm commented on 2020-11-17 04:51 (UTC)

@lostkhaos yes, I have npm 7.0.5-1

lostkhaos commented on 2020-11-14 16:19 (UTC) (edited on 2020-11-14 16:32 (UTC) by lostkhaos)

Edit: If you're on NPM 7, this could be related to a bug upstream there.

Otherwise.. I'm honestly mystified how it fails to build in a clean environment for you but not for me. Does the tweak proposed by NobodyDBG fix the problem for you? I'll just fold it in if it fixes the problem for folks since I can't recreate it myself. Here's the Dockerfile I'm using to make sure my environment isn't accidentally fixing the problem:

FROM archlinux/base

# General setup
RUN pacman -Syu --noconfirm && pacman -S --needed --noconfirm base-devel
RUN useradd lowpriv -m
RUN echo 'lowpriv   ALL=(ALL) NOPASSWD: ALL' >> /etc/sudoers
USER lowpriv

# Build
RUN cd /tmp && \
    curl -LO && \
    tar -xzf nodejs-nativefier.tar.gz
RUN sudo pacman -S --noconfirm nodejs unzip jq npm
RUN cd /tmp/nodejs-nativefier && makepkg

mxfm commented on 2020-11-12 06:22 (UTC) (edited on 2020-11-12 06:22 (UTC) by mxfm)

I cannot update the package either in my local environment or in clean chroot (via aurutils) because of error 'npm ERR! enoent ENOENT: no such file or directory, lstat '/build/nodejs-nativefier/pkg/nodejs-nativefier/usr''.

NobodyDBG commented on 2020-11-11 04:03 (UTC) (edited on 2020-11-11 04:09 (UTC) by NobodyDBG)

Npm wanted a update yesterday to update WhatsApp

lostkhaos commented on 2020-11-10 19:50 (UTC) (edited on 2020-11-10 19:51 (UTC) by lostkhaos)

@damico: I've seen that error when mixing architectures (e.g. trying to run x86 ELF files on ARM).

@NobodyDBG: I don't get that error but I see some folks online also getting that issue (e.g. lerna).

Do you have any environment variables or etc that might be messing with npm? I just tested it in a clean environment with npm 6.14.8-2 (nodejs 15.1.0-1).

NobodyDBG commented on 2020-11-10 18:58 (UTC)

Hi. Sorry, I must modify your PKGBUILD to install the Update. Error: ==> Beginne package()... npm ERR! code ENOENT npm ERR! syscall lstat npm ERR! path /tmp/AUR/nodejs-nativefier/pkg/nodejs-nativefier/usr/lib npm ERR! errno -2 npm ERR! enoent ENOENT: no such file or directory, lstat '/tmp/AUR/nodejs-nativefier/pkg/nodejs-nativefier/usr/lib' npm ERR! enoent This is related to npm not being able to find a file. npm ERR! enoent

npm ERR! A complete log of this run can be found in: npm ERR! /tmp/AUR/nodejs-nativefier/src/npm-cache/_logs/2020-11-10T18_52_30_968Z-debug.log ==> FEHLER: Ein Fehler geschah in package().

To fix this error: package() { # Thanks jeremejevs and je-vv for the pointers on these! mkdir "$pkgdir/usr/" mkdir "$pkgdir/usr/lib" npm install -g --user root --cache "${srcdir}/npm-cache" --prefix "$pkgdir/usr" "$srcdir/$_npmname-$pkgver.tgz"

damico commented on 2020-11-06 09:33 (UTC) (edited on 2020-11-06 09:45 (UTC) by damico)

Hi, I'm getting this error:

==> Starting package()...
/usr/local/bin/node: /usr/local/bin/node: cannot execute binary file
==> ERROR: A failure occurred in package().
error making: nodejs-nativefier

Could you help me fix it?

schard commented on 2020-11-04 16:52 (UTC)

License is missing. Should be MIT according to upstream.

lostkhaos commented on 2020-06-29 14:47 (UTC)

@nahuelwexd added!

nahuelwexd commented on 2020-06-28 16:23 (UTC)

This package needs unzip as dependency :) Or you will get an Error during build. Run with --verbose for details. Error: spawn unzip ENOENT when using it

alecmev commented on 2020-05-01 14:17 (UTC)


lostkhaos commented on 2020-05-01 13:57 (UTC)

Nice, thanks @alecmev for the heads-up! Added that new chown recommendation+a quick noextract.

alecmev commented on 2020-04-30 16:41 (UTC)

There has been a development, more cleanup is necessary now, unfortunately. Also, a noextract would be nice. More information in this wiki diff.

tal.hadad2001 commented on 2020-02-11 21:46 (UTC)

Currently this is the only package that seems to give me this error during makepkg, which hasn't happened UNTIL there was a new update: ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.

may i have some help? (this honestly only happens with this package, i can install other packages with ease)

alecmev commented on 2018-10-12 11:11 (UTC)

@lostkhaos Thank you!

lostkhaos commented on 2018-10-11 20:15 (UTC)

@jeremejevs nice. Folded in the guideline changes. Been mildly irritated by that permission problem too.

alecmev commented on 2018-10-11 16:24 (UTC) (edited on 2018-10-11 16:30 (UTC) by alecmev)

@lostkhaos Please, take a look at the Node.js package guidelines: I personally am interested in the addition of the permission fix (777 vs. 755), but it also explains why the cache override suggested by @je-vv is needed. And why download the tarball, but not use it when installing? Here's a full PKGBUILD which appears to be inline with the guidelines:

lostkhaos commented on 2018-10-11 14:51 (UTC)

@je-vv, does this solve a build issue or is it a sanity thing? I tried with and without that line and compared the generated packages and they look pretty similar to me other than timestamps.

je-vv commented on 2018-10-11 01:33 (UTC)

Can you please add export npm_config_cache="$srcdir/npm_cache" prior to calling any nbm command? This will prevent dirtying other areas, and also will prevent as well picking caches from other/prior builds which have set this up.

lostkhaos commented on 2017-11-09 15:57 (UTC)

@balwierz indeed, npm warns you about this at least (although the comment that your version is out-of-date is incorrect). You can watch the issue on github to see when they fix it:

balwierz commented on 2017-11-09 13:24 (UTC)

It won't build with the future nodejs currently in community-testing: $ npm --version 5.5.1 $ yaourt -Qa nodejs community-testing/nodejs 9.1.0-1 ==> Starting package()... npm WARN npm npm does not support Node.js v9.1.0 npm WARN npm You should probably upgrade to a newer version of node as we npm WARN npm can't make any promises that npm will work with this version. npm WARN npm Supported releases of Node.js are the latest release of 4, 6, 7, 8. npm WARN npm You can find the latest version at WARNING: You are likely using a version of node-tar or npm that is incompatible with this version of Node.js.ock Please use either the version of npm that is bundled with Node.js, or a version of npm (> 5.5.1 or < 5.4.0) or node-tar (> 4.0.1) that is compatible with Node.js 9 and above. /usr/bin/node[8608]: ../src/ void node::{anonymous}::ZCtx::Init(const v8::FunctionCallbackInfo<v8::Value>&): Assertion `args.Length() == 7 && "init(windowBits, level, memLevel, strategy, writeResult, writeCallback," " dictionary)"' failed. 1: node::Abort() [npm] 2: node::Assert(char const* const (*) [4]) [npm] 3: 0x55f369e0e628 [npm] 4: v8::internal::FunctionCallbackArguments::Call(void (*)(v8::FunctionCallbackInfo<v8::Value> const&)) [npm] 5: 0x55f3696fafaf [npm] 6: 0x55f3696fb4ff [npm] 7: 0x14d0bd5842fd /tmp/yaourt-tmp-foo/aur-nodejs-nativefier/./PKGBUILD: line 16: 8608 Aborted (core dumped) npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver

rokoucha commented on 2017-05-09 12:54 (UTC)

Sorry for late. I updated it.

gromain commented on 2017-05-04 14:42 (UTC)

Hi! Version 7.3.1 is out! Here and Could you please update? Thanks!

gamezelda commented on 2017-04-03 17:59 (UTC)

I had to install extra/gconf for the generated apps to work, should be a dependency.

rokoucha commented on 2016-09-02 08:04 (UTC)

Sorry for being late. I have updated the PKGBUILD.

tembleking commented on 2016-08-31 14:27 (UTC)

Hey there! Version v7.0.1 is already out! Please could you update this package?