Package Details: nodejs-sails 0.12.13-1

Git Clone URL: https://aur.archlinux.org/nodejs-sails.git (read-only)
Package Base: nodejs-sails
Description: Realtime MVC Framework for Node.js.
Upstream URL: http://sailsjs.org
Licenses: MIT
Submitter: supermario
Maintainer: supermario
Last Packager: supermario
Votes: 0
Popularity: 0.000000
First Submitted: 2015-05-05 01:20
Last Updated: 2017-05-30 00:32

Latest Comments

positronicbrain commented on 2015-11-18 09:49

My bad, I had an older node version in use (nvm). Thanks!

supermario commented on 2015-11-18 01:03

@positronicbrain I can not reproduce your error

$ python --version
Python 3.5.0

...

> node-gyp rebuild succeeds for me

positronicbrain commented on 2015-11-17 11:57

Same error, it looks for python which is the 3.5 version.

> node-gyp rebuild

gyp ERR! configure error
gyp ERR! stack Error: Python executable "python" is v3.5.0, which is not supported by gyp.
gyp ERR! stack You can pass the --python switch to point to Python >= v2.5.0 & < 3.0.0.
gyp ERR! stack at failPythonVersion (/home/federico/.nvm/v0.12.3/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:108:14)
....
....
....

supermario commented on 2015-11-16 12:31

@positronicbrain I am able to build the package just fine without specifying the python version. Can you try again since I've updated the package?

positronicbrain commented on 2015-11-16 08:57

Build fails: need to change install commands:

npm install --python=python2 ...

==============================================================================
gyp ERR! configure error
gyp ERR! stack Error: Python executable "python" is v3.5.0, which is not supported by gyp.