Package Details: nodejs-svgo 1.1.1-1

Git Clone URL: https://aur.archlinux.org/nodejs-svgo.git (read-only)
Package Base: nodejs-svgo
Description: Nodejs-based tool for optimizing SVG vector graphics files
Upstream URL: https://github.com/svg/svgo
Licenses: MIT
Submitter: bchretien
Maintainer: simon04
Last Packager: simon04
Votes: 16
Popularity: 0.008939
First Submitted: 2015-01-13 16:47
Last Updated: 2018-10-10 05:55

Required by (4)

Sources (0)

Latest Comments

tensor5 commented on 2018-02-09 17:05

I've seen this issue in other npm packages, it didn't show up in my build though.

Calimero commented on 2018-02-09 14:35

I wanted to ask for a fix of the permission issues: there are lots of files and directories with mode 777. But installing a second time fixes that, I'm not sure what's happening.

tensor5 commented on 2017-11-17 10:51

@Enverex, do you have that permission mismatch only on /usr/bin?

Enverex commented on 2017-11-16 15:40

Also worth fixing this...

warning: directory permissions differ on /usr/bin/
filesystem: 755 package: 777

JP-Ellis commented on 2017-05-30 01:20

@tensor5, could you either update the PKGBUILD or disown it? It's been flagged out-of-date since October last year :/

krevedko commented on 2015-08-29 12:28

Thank you for your answer!

I've found the root cause:
svgo >= 0.5.1 breaks svg-fonts by default.
https://github.com/svg/svgo/issues/404

bchretien commented on 2015-08-29 05:31

@krevedko: works for me.

$ svgo -i test.svg -o out.svg

Done in 373 ms!
170.614 KiB - 48.2% = 88.369 KiB

Have you tried with another SVG file? It may be due to some SVG features that are not properly supported by svgo.

krevedko commented on 2015-08-28 11:17

Hmm, all latest versions >= 0.5.1 including 0.5.6 outputs empty svg files for me.
Looks like, i've build something wrong...
Could you please confirm or refute this issue?


$ svgo -i transport.svg -o transport3.svg

Done in 546 ms!
493.805 KiB - 100% = 0.04 KiB

bchretien commented on 2015-08-05 16:03

@krevedko: done, thanks!

krevedko commented on 2015-08-05 14:19

Please add "npm" to makedepends.
Thanks.