Package Details: nodemcu-tool 3.2.1-3

Git Clone URL: https://aur.archlinux.org/nodemcu-tool.git (read-only, click to copy)
Package Base: nodemcu-tool
Description: Upload/Download Lua files to your ESP8266 module with NodeMCU firmware
Upstream URL: https://www.npmjs.com/package/nodemcu-tool
Licenses: MIT
Submitter: cyrevolt
Maintainer: cyrevolt
Last Packager: cyrevolt
Votes: 5
Popularity: 0.26
First Submitted: 2017-08-10 21:45
Last Updated: 2021-10-17 00:57

Latest Comments

cyrevolt commented on 2021-10-27 21:00

Okay, please try the following (I do not expect much of a difference, but you never know...):

PYTHON=python2 npm install

Mind that to install the dependencies, only run npm install without the name if the module.

If this doesn't work either, please file an issue to upstream on GitHub, including your versions of npm and Node.js. I cannot reproduce it myself, unfortunately, sorry.

fred118 commented on 2021-10-27 20:13

Yes. I get the same error message

$ npm install nodemcu-tool
npm ERR! code 7
npm ERR! path /home/patrik/nodemcu-tool/node_modules/@serialport/bindings
npm ERR! command failed
npm ERR! command sh -c prebuild-install --tag-prefix @serialport/bindings@ || node-gyp rebuild
npm ERR! gyp info it worked if it ends with ok
npm ERR! gyp info using node-gyp@7.1.2
npm ERR! gyp info using node@16.11.0 | linux | x64
npm ERR! gyp info find Python using Python version 3.9.7 found at "/usr/bin/python3"
npm ERR! gyp ERR! UNCAUGHT EXCEPTION 
npm ERR! gyp ERR! stack Error: Cannot find module 'request'
npm ERR! gyp ERR! stack Require stack:
npm ERR! gyp ERR! stack - /usr/lib/node_modules/npm/node_modules/node-gyp/lib/install.js
npm ERR! gyp ERR! stack - /usr/lib/node_modules/npm/node_modules/node-gyp/lib/node-gyp.js
npm ERR! gyp ERR! stack - /usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js
npm ERR! gyp ERR! stack     at Function.Module._resolveFilename (node:internal/modules/cjs/loader:933:15)
npm ERR! gyp ERR! stack     at Function.Module._load (node:internal/modules/cjs/loader:778:27)
npm ERR! gyp ERR! stack     at Module.require (node:internal/modules/cjs/loader:1005:19)
npm ERR! gyp ERR! stack     at require (node:internal/modules/cjs/helpers:102:18)
npm ERR! gyp ERR! stack     at Object.<anonymous> (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/install.js:10:17)
npm ERR! gyp ERR! stack     at Module._compile (node:internal/modules/cjs/loader:1101:14)
npm ERR! gyp ERR! stack     at Object.Module._extensions..js (node:internal/modules/cjs/loader:1153:10)
npm ERR! gyp ERR! stack     at Module.load (node:internal/modules/cjs/loader:981:32)
npm ERR! gyp ERR! stack     at Function.Module._load (node:internal/modules/cjs/loader:822:12)
npm ERR! gyp ERR! stack     at Module.require (node:internal/modules/cjs/loader:1005:19)
npm ERR! gyp ERR! System Linux 5.14.10-1-MANJARO
npm ERR! gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
npm ERR! gyp ERR! cwd /home/patrik/nodemcu-tool/node_modules/@serialport/bindings
npm ERR! gyp ERR! node -v v16.11.0
npm ERR! gyp ERR! node-gyp -v v7.1.2
npm ERR! gyp ERR! Node-gyp failed to build your package.
npm ERR! gyp ERR! Try to update npm and/or node-gyp and if it does not help file an issue with the package author.

cyrevolt commented on 2021-10-27 19:34

Oh whew that went boom...

I can only guess a few things right now. The repo at least is missing a package-lock.json file, which would pin dependencies. However, the npm install part should resolve and install the dependency tree either way. Now with some bad luck, something can still go wrong in that process.

So let's see: Does the same issue occur when you clone the nodemcu-tool repo directly, and then run npm install and npm rebuild there?

fred118 commented on 2021-10-27 19:12

Last Update fails:

Erstelle nodemcu-tool...
==> Erstelle Paket: nodemcu-tool 3.2.1-3 (Mi 27 Okt 2021 21:09:54 CEST)
==> Prüfe Laufzeit-Abhängigkeiten...
==> Prüfe Buildtime-Abhängigkeiten...
==> Empfange Quellen...
  -> nodemcu-tool-3.2.1.tgz gefunden
==> Überprüfe source Dateien mit sha256sums...
    nodemcu-tool-3.2.1.tgz ... Erfolg
==> Entferne existierendes $srcdir/ Verzeichnis...
==> Entpacke Quellen...
  -> Entpacke nodemcu-tool-3.2.1.tgz mit bsdtar
==> Entferne existierendes $pkgdir/ Verzeichnis...
==> Betrete fakeroot Umgebung...
==> Beginne package()...
npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.
npm ERR! code 7
npm ERR! path /var/tmp/pamac-build-patrik/nodemcu-tool/src/package/node_modules/@serialport/bindings
npm ERR! command failed
npm ERR! command sh -c prebuild-install --tag-prefix @serialport/bindings@ || node-gyp rebuild
npm ERR! gyp info it worked if it ends with ok
npm ERR! gyp info using node-gyp@7.1.2
npm ERR! gyp info using node@16.11.0 | linux | x64
npm ERR! gyp info find Python using Python version 3.9.7 found at "/usr/bin/python3"
npm ERR! gyp ERR! UNCAUGHT EXCEPTION 
npm ERR! gyp ERR! stack Error: Cannot find module 'request'
npm ERR! gyp ERR! stack Require stack:
npm ERR! gyp ERR! stack - /usr/lib/node_modules/npm/node_modules/node-gyp/lib/install.js
npm ERR! gyp ERR! stack - /usr/lib/node_modules/npm/node_modules/node-gyp/lib/node-gyp.js
npm ERR! gyp ERR! stack - /usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js
npm ERR! gyp ERR! stack     at Function.Module._resolveFilename (node:internal/modules/cjs/loader:933:15)
npm ERR! gyp ERR! stack     at Function.Module._load (node:internal/modules/cjs/loader:778:27)
npm ERR! gyp ERR! stack     at Module.require (node:internal/modules/cjs/loader:1005:19)
npm ERR! gyp ERR! stack     at require (node:internal/modules/cjs/helpers:102:18)
npm ERR! gyp ERR! stack     at Object.<anonymous> (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/install.js:10:17)
npm ERR! gyp ERR! stack     at Module._compile (node:internal/modules/cjs/loader:1101:14)
npm ERR! gyp ERR! stack     at Object.Module._extensions..js (node:internal/modules/cjs/loader:1153:10)
npm ERR! gyp ERR! stack     at Module.load (node:internal/modules/cjs/loader:981:32)
npm ERR! gyp ERR! stack     at Function.Module._load (node:internal/modules/cjs/loader:822:12)
npm ERR! gyp ERR! stack     at Module.require (node:internal/modules/cjs/loader:1005:19)
npm ERR! gyp ERR! System Linux 5.14.10-1-MANJARO
npm ERR! gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
npm ERR! gyp ERR! cwd /var/tmp/pamac-build-patrik/nodemcu-tool/src/package/node_modules/@serialport/bindings
npm ERR! gyp ERR! node -v v16.11.0
npm ERR! gyp ERR! node-gyp -v v7.1.2
npm ERR! gyp ERR! Node-gyp failed to build your package.
npm ERR! gyp ERR! Try to update npm and/or node-gyp and if it does not help file an issue with the package author.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/patrik/.npm/_logs/2021-10-27T19_10_07_858Z-debug.log
==> FEHLER: Ein Fehler geschah in package().
    Breche ab...

ClawOfLight commented on 2019-10-03 11:06

When I try to install this, serialport fails to compile. Anyone have a solution?

mgisbers commented on 2019-05-12 18:45

Still needs npm and python2 to build.

Wild_Penguin commented on 2019-04-25 17:39

Any reason why this package installs files mostly with 750 permissions (owned by root:root) ? Is it by design or an oversight?

Speranskiy commented on 2019-03-18 18:56

python2 and npm should be added as makedepends

Elinvention commented on 2018-12-24 18:47

I think, npm is needed as a dependency.