Package Details: notes 2.2.1-2

Git Clone URL: https://aur.archlinux.org/notes.git (read-only, click to copy)
Package Base: notes
Description: Note taking application, write down your thoughts
Upstream URL: https://www.get-notes.com/
Keywords: note notepad notes scratchpad todo
Licenses: MPL
Submitter: gkbrk
Maintainer: kleintux (zjeffer)
Last Packager: zjeffer
Votes: 18
Popularity: 0.171167
First Submitted: 2016-03-16 18:14 (UTC)
Last Updated: 2023-09-14 17:34 (UTC)

Latest Comments

1 2 Next › Last »

tee commented on 2023-09-17 12:50 (UTC)

Can you provide a notes-bin package as well?

zjeffer commented on 2023-09-14 17:35 (UTC)

@txtsd Thanks for reporting, I removed the pkver() function and fixed the update to 2.2.1

txtsd commented on 2023-09-14 12:56 (UTC)

A non -git package does not need the pkgver() function. In this case it incorrectly sets the version to 2.2.0-1 which is always lower than the version in the PKGBUILD, so AUR helpers try to update it every time.

depressed_archer commented on 2023-08-14 13:34 (UTC)

It works perfectly now, thank you

zjeffer commented on 2023-07-27 21:27 (UTC)

@depressed_archer Thanks for reporting, it should be fixed now. Can you verify?

depressed_archer commented on 2023-07-27 21:09 (UTC)

Hi, the dependency qt6-quick3d is required to build as well.

zjeffer commented on 2023-02-15 20:28 (UTC) (edited on 2023-02-15 22:20 (UTC) by zjeffer)

Commit https://github.com/nuttyartist/notes/commit/0ef084e98c8fcaa4dabe982b1c6e13332f5e83c9 adds a CMake option to disable the updater. This should be enabled for this package (once 2.1.0 releases, will be soon).

2.1.0 will also support both Qt6 and Qt5, down to Qt 5.9. This should be reflected in the dependencies.

zjeffer commented on 2022-11-04 18:56 (UTC)

The latest git version includes a security fix that breaks the build. Please update the PKGBUILD to include protocol.file.allow=always before updating like here: https://wiki.archlinux.org/title/VCS_package_guidelines#Git_submodules

yochananmarqos commented on 2022-09-17 16:28 (UTC)

@txtsd: A package already provides and conflicts with itself. notes-git should provide and conflict with notes.

txtsd commented on 2022-09-17 15:55 (UTC)

Please add provides=('notes') to the PKGBUILD because it conflicts with notes-git.