Package Details: notify-sharp 0.4.1-3

Git Clone URL: https://aur.archlinux.org/notify-sharp.git (read-only, click to copy)
Package Base: notify-sharp
Description: C Sharp D-Bus client library for desktop notifications
Upstream URL: https://www.meebey.net/projects/notify-sharp/
Licenses: MIT
Submitter: City-busz
Maintainer: Rogach
Last Packager: City-busz
Votes: 2
Popularity: 0.000000
First Submitted: 2019-03-30 00:03 (UTC)
Last Updated: 2019-03-30 00:03 (UTC)

Latest Comments

Rogach commented on 2021-08-31 08:37 (UTC) (edited on 2021-08-31 08:37 (UTC) by Rogach)

Hi TrialnError,

It seems that smuxi already depends on gtk-sharp-2-git, so during building and installation gtk-sharp-2-git will be pulled in automatically, regardless of dependencies of other packages.

I'm a bit wary of including -git dependencies in non-git PKGBUILDs. (also there's notify-sharp-git, maybe such dependency makes more sense there)

P.S. Yes, this glade stuff is a mess, it was the final issue that resulted in me moving from gnome-do to drun.

TrialnError commented on 2021-08-25 22:36 (UTC)

Hello Rogach, Just a small question or maybe a suggestion.
Is it possible to change gtk-sharp-2 to gtk-sharp-2-git? The package from the repos dropped libglade as a dep which breaks building the smuxi package.
And no worries if you don't want to (as there are valid reasons to not do that). This would be just the easiest way. I can also add a pinned comment to said package. Just want to make some PKGBUILDs build again, although it's some old stuff :D

Best regards