Package Details: nspr-hg 4.35.r4.g3e25d69ba6b2-1

Git Clone URL: https://aur.archlinux.org/nspr-hg.git (read-only, click to copy)
Package Base: nspr-hg
Description: Netscape Portable Runtime
Upstream URL: https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSPR
Licenses: GPL, MPL
Conflicts: nspr
Provides: nspr
Submitter: franziskus
Maintainer: xiota
Last Packager: xiota
Votes: 2
Popularity: 0.000000
First Submitted: 2019-11-12 13:28 (UTC)
Last Updated: 2023-12-08 09:15 (UTC)

Required by (286)

Sources (1)

Latest Comments

MarsSeed commented on 2023-07-29 13:39 (UTC) (edited on 2023-07-29 13:39 (UTC) by MarsSeed)

I've fixed the package, implemented a proper pkgver(), added makedepends=mercurial.

But I'm disowning it since I wouldn't be interested in maintaining and testing it.

shoober420 commented on 2021-01-13 02:24 (UTC)

You can use the pkgver code from my lib32-nspr-git package so this has a proper version tag.

https://aur.archlinux.org/cgit/aur.git/plain/PKGBUILD?h=lib32-nspr-hg

shoober420 commented on 2021-01-06 02:11 (UTC)

Thank you for this package.

PedroHLC commented on 2020-06-12 03:43 (UTC)

Thanks @aereaux

aereaux commented on 2020-06-06 18:03 (UTC)

Hello. Thanks for this package. Here's a pkgver function that seems to work for me (I took it mostly from the nss-hg package):

pkgver() {
  local vmajor vminor vpatch
  cd "$_pkgname"

  { read vmajor; read vminor; read vpatch; } \
    < <(awk '/#define.*PR_V(MAJOR|MINOR|PATCH)/ {print $3}' pr/include/prinit.h)

  printf "%s.%s.%sr%s.%s" "$vmajor" "$vminor" "$vpatch" "$(hg identify -n)" "$(hg identify -i)"
}

I think this package also requires mercurial as a makedepend.

PedroHLC commented on 2020-01-07 22:23 (UTC)

This package is missing a dynamic pkgver function

PedroHLC commented on 2019-11-12 17:39 (UTC)

provides=("nspr=${pkgver}")

Hi, it seems like a provide tag like this is required so nss-hg constraint accepts it.

I can confirm nss-hg builds with this nspr! Thanks for the fast providing of this package.