Package Details: nutstore 5.1.6-3

Git Clone URL: https://aur.archlinux.org/nutstore.git (read-only, click to copy)
Package Base: nutstore
Description: a cloud service that lets you sync and share files anywhere.
Upstream URL: https://www.jianguoyun.com/
Licenses: custom
Submitter: bhoppi
Maintainer: bhoppi
Last Packager: bhoppi
Votes: 29
Popularity: 0.000549
First Submitted: 2012-03-07 09:03 (UTC)
Last Updated: 2022-04-07 10:41 (UTC)

Pinned Comments

bhoppi commented on 2019-03-21 03:57 (UTC) (edited on 2019-12-21 03:00 (UTC) by bhoppi)

This package is stuck to the latest STABLE version. If you hope to use the lastest published version including stable and experimental versions, please install nutstore-experimental (https://aur.archlinux.org/packages/nutstore-experimental/) instead.

Latest Comments

oaksharks commented on 2022-04-10 14:28 (UTC)

启动后页面空白

bhoppi commented on 2022-04-09 02:13 (UTC) (edited on 2022-04-09 02:31 (UTC) by bhoppi)

@SilverRainZ 我试了一下,v5.1.6在原www.jianguoyun.com网址上直接404,看来新版的地址直接迁移了。 你可以试着邮件给support@nutstore.net看能否解决问题。 ========= 这个地址程序更新时抓包可以看到,是官方的地址。你试试改成www.jianguoyun.com是否可以?如果还不行,可能需要联系官方来解决。

SilverRainZ commented on 2022-04-08 14:19 (UTC)

请问这个 pkg-cdn.jianguoyun.com 的地址是从哪里获得的呢? [archlinuxcn] 的编译机上会被限制,下载不下来 :'(

SilverRainZ commented on 2022-03-29 13:16 (UTC)

5.1.6 is out: https://www.jianguoyun.com/s/downloads

hsldymq commented on 2021-06-03 06:32 (UTC)

nutstore-experimental 5.1.2-1 解决了空白页问题, 亲测有效. 谢谢alon.

alon commented on 2021-06-02 02:22 (UTC)

5.1.1-1版本坚果云安装后打开显示空白页,nutstore-experimental 5.1.2-1版本可以正常使用,有需要的朋友可以下载nutstore-experimental这个包

hsldymq commented on 2021-05-13 10:49 (UTC)

尝试webkit2gtk-unstable的时候, 我也出现同样的错误 ‘ubrk_safeClone_69’ was not declared in this scope; did you mean ‘ucol_safeClone_69’?

有已经解决的朋友能给一个解决方案吗?

IAmKoishi commented on 2021-05-11 14:23 (UTC) (edited on 2021-05-12 03:56 (UTC) by IAmKoishi)

尝试使用 webkit2gtk-unstable 替代 webkit2gtk ,出现了和前面评论一样的编译错误:‘ubrk_safeClone_69’ was not declared in this scope; did you mean ‘ucol_safeClone_69’?

请问诸位还有其他的解决方法吗?

lalala commented on 2021-05-09 14:46 (UTC)

最新的版本在我的 KDE 环境中出现了这个错误,是 Java 环境的问题吗?

021-05-09 22:27:16,593 [Thread-2] run INFO: The java client is dead, try to restart it
/opt/nutstore/bin/nutstore-pydaemon.py:656: PyGIDeprecationWarning: Since version 3.11, calling threads_init is no longer needed. See: https://wiki.gnome.org/PyGObject/Threading
  GObject.threads_init()
2021-05-09 22:28:13,165 [MainThread] execute_cmd ERROR: execute cmd [open_invite_friends] error
Traceback (most recent call last):
  File "/opt/nutstore/bin/network_util.py", line 37, in execute_cmd
    sock.connect(('localhost', JAVA_SERVER_PORT))
ConnectionRefusedError: [Errno 111] Connection refused
^C^C2021-05-09 22:44:01,437 [MainThread] sigint_handler INFO: exit from SIGINT

nozomi22 commented on 2021-05-08 07:20 (UTC)

manjaro gnome 打开显示空白页,也看不到日志。

archblue commented on 2021-04-28 12:08 (UTC)

@shui 不能降级,会自动升到最新版;webkit2gtk-unstable编译报错“‘ubrk_safeClone_69’ was not declared in this scope; did you mean ‘ucol_safeClone_69’?”,还有其他解决方法不,谢谢

shui commented on 2021-04-21 02:20 (UTC)

更新后出现白屏,打不开主页面和设置页面的,可以使用webkit2gtk-unstable这个包替代webkit2gtk试试

shilka commented on 2021-04-19 07:49 (UTC)

After update to version 5.1.1, the "Main Panel" and "Preference" show up as a blank rectangular canvas. The previous version(5.0.4) works fine.

bhoppi commented on 2020-12-30 12:25 (UTC)

@manchong 你手动安装webkit2gtk这个包试试看能否解决问题

manchong commented on 2020-12-30 12:00 (UTC)

最新的版本在我的 KDE 环境中出现了这个错误,是依赖包的问题吗?在我的另外一台 Arch(KDE) 中使用没有遇到下面的错误

SWT Webkit: Warning, You are using an old version of webkitgtk. (pre 2.4) BrowserFunction functionality will not be avaliable
SWT WebKit: error initializing DBus server, dBusServer == 0
20/12/30 19:45:09 ERROR nutstore.client.gui.NutstoreGUI: Unable to launch web ui and fall back to the legacy ui.
org.eclipse.swt.SWTError: No more handles because there is no underlying browser available.
Please ensure that WebKit with its GTK 3.x bindings is installed (WebKit2 API level is preferred). Additionally, please note that GTK4 does not currently have Browser support.

bhoppi commented on 2020-08-07 09:09 (UTC) (edited on 2020-08-07 09:09 (UTC) by bhoppi)

Due to some necessary bug fixes, I updated this package to the experimental version temporarily.

bhoppi commented on 2019-03-21 03:57 (UTC) (edited on 2019-12-21 03:00 (UTC) by bhoppi)

This package is stuck to the latest STABLE version. If you hope to use the lastest published version including stable and experimental versions, please install nutstore-experimental (https://aur.archlinux.org/packages/nutstore-experimental/) instead.

yinflying commented on 2019-01-05 09:55 (UTC) (edited on 2019-01-05 10:05 (UTC) by yinflying)

2018年12月21日更新(Linux4.2.0版本)修复了 4.1.5 版本中无法迁移同步文件夹路径的 bug。最新版本忽然复制只读文件卡死的BUG,开心。不过,更新后版本界面在KDE下不如以前。

Gavin_Andre commented on 2018-12-20 06:04 (UTC)

@bhoppi 感谢 总管能用了

goldenmice commented on 2018-12-19 10:40 (UTC)

@bhoppi 666666

bhoppi commented on 2018-12-19 05:26 (UTC)

@goldenmice 我先打了个patch,暂时能用了。后续等官方的修复吧。

goldenmice commented on 2018-12-19 01:16 (UTC)

大家别升级,4.1.5 的程序有问题, 坚果云在启动时会判断路径,导致启动失败。

"Can't find dist"

commented on 2018-12-07 14:11 (UTC)

我遇到了安装错误: ==> Validating source files with sha256sums... nutstore ... Passed license ... Passed ==> Validating source_x86_64 files with sha256sums... nutstore_linux_dist_x64.tar.gz ... FAILED ==> ERROR: One or more files did not pass the validity check! 请问这是咋回事啊?

visitant commented on 2018-12-04 13:23 (UTC)

@shilka 也许可以试着咨询一下客服,我发给你的链接是我在咨询客服关于软件bug时售后给我的链接

shilka commented on 2018-12-04 01:40 (UTC)

@bhoppi 官方网站给出的3.4.5版本下载地址是: https://www.jianguoyun.com/static/exe/installer/nutstore_linux_dist_x64.tar.gz https://www.jianguoyun.com/static/exe/installer/nutstore_linux_dist_x86.tar.gz

bhoppi commented on 2018-12-03 09:25 (UTC)

@visitant 你发给我的链接版本确实较新,但不是官方链接,我无法验证那些内容的安全性,因此不能采用。

visitant commented on 2018-11-28 10:06 (UTC)

@bhoppi 上面那个问题在新版本已经修复了,但是aur的版本落后了,是有bug的版本

bhoppi commented on 2018-05-10 03:46 (UTC)

@Ming 这属于软件自身的bug,您可以到官方渠道(官网、微博、公众号等)反映bug

Ming commented on 2018-05-10 03:05 (UTC)

报告BUG:对本地无后缀长文件名文件(.git路径下的)会阻塞同步,一直处在分析阶段。比如新git clone一个项目到同步文件夹后。

Plexcon commented on 2018-02-07 18:06 (UTC)

It's working fine.

bhoppi commented on 2016-07-08 08:40 (UTC)

@bianjp 这个问题我在安装过程中有打印出提示,你一定没有仔细看^_^

bianjp commented on 2016-07-08 06:45 (UTC)

在 Preferences 中启用 "Auto Start Nutstore" 失败,报错 "ERROR nativeos.NativeOSHelper: The gnome autostart file does not exist"。 手动执行 "cp /opt/nutstore/gnome-config/autostart/nutstore-daemon.desktop ~/.config/autostart/" 可以实现自动启动。

bhoppi commented on 2014-11-11 09:43 (UTC)

@acgtyrant 不好意思看到晚了,我在原帖里回复你了。我不会把NutStore的启动命令放进系统路径的,也没有必要。那个nutstore-pydaemon.py其实是个程序内部使用的一个启动脚本,不适合放入系统。

acgtyrant commented on 2014-11-08 12:52 (UTC)

s/应用/应有

acgtyrant commented on 2014-11-08 12:52 (UTC)

http://bbs.jianguoyun.com/topic.php?id=4270&replies=3#post-14693 会不会是因为你的 PKGBUILD 没把命令放进应用的路径呢?

bhoppi commented on 2014-09-17 13:59 (UTC)

thanks @acgtyrant

acgtyrant commented on 2014-09-17 11:12 (UTC)

安装了 nautilus-nutstore, 有选项了。 看来得为喜欢的 spacefm 写个插件。 顺便把这这软件加到 ArchWiki 的相关条目里了:https://wiki.archlinux.org/index.php/Backup_programs#Cloud_backups 虽然坚果云似乎没打算开拓海外市场。

acgtyrant commented on 2014-09-17 10:54 (UTC)

用 pacman -Ql 查了下,没有 Command. 不过今天在 Synapse 找到这程序了。 @passchaos 我用 i3bar, 能正常显示图标。 这客户端做得确实不错,尤其「多文件夹同步」特性着实让我大吃一惊,这就是我梦寐以求的功能啊!不过可惜的是在文件管理器 pcmanfm, spacefm 和 Nautilus 中,右键菜单里没找到「坚果云同步」选项。

bhoppi commented on 2014-09-16 11:39 (UTC)

@passchaos 这个我也不清楚,我不用Gnome-shell。建议到官方的论坛询问

passchaos commented on 2014-09-16 10:46 (UTC)

为何在下方托盘处没有图标,而当坚果云有通知内容时却能正常显示图标?

passchaos commented on 2014-09-11 06:37 (UTC)

问题解决了,log里面提示the trustAnchors parameter must be non-empty,我把ca-certificates-java重新安装了一下就好了。不过,为何在gnome-shell最下面的消息栏处坚果云的托盘标志没有图标,只有一个方框?

bhoppi commented on 2014-09-11 05:26 (UTC)

@passchaos 我这里没有问题。AUR里已经是Linux下的最新版

passchaos commented on 2014-09-11 04:39 (UTC)

今天新安装的,提示“不能连接到服务器”,是不是客户端要更新(安装的就是AUR中最新的)?

acgtyrant commented on 2014-08-02 07:12 (UTC)

请问启动命令是什么呢……

bhoppi commented on 2014-06-30 13:22 (UTC)

@xgdgsc 还有一种方法,把/opt/nutstore/gnome-config/autostart/nutstore-daemon.desktop复制到~/.nutstore/dist/gnome-config/autostart/nutstore-daemon.desktop,那个选项就能起作用了。 没办法,这个路径是写在程序代码里的,我无权修改。不过我可以在安装脚本里增加这个提示,感谢反馈。

xgdgsc commented on 2014-06-30 12:56 (UTC)

启用自动启动的选项好像没用? 只能手动复制那个desktop文件到.config/autostart吗?

sfbi commented on 2013-10-20 08:23 (UTC)

Please update! The current version does not work anymore.

bhoppi commented on 2013-04-01 11:21 (UTC)

已更新,版本号还是变了的 xgdgsc的建议,我会向官方提议的

xgdgsc commented on 2013-03-29 14:46 (UTC)

nutstore has updated,I had to changed the md5sums to install it 貌似又更新了,但版本号没变 有时间去给官方提提意见,保留所有版本的下载链接,文件名加上版本号。

commented on 2012-10-28 02:23 (UTC)

nutstore has updated,I had to changed the md5sums to install it

bhoppi commented on 2012-10-22 00:42 (UTC)

If you encounter the problem 'nutstore: requires python-notify' when updating, please update nutstore before updating python2-notify, or use pacman's '-dd' option to temporarily ignore the dependency.

bhoppi commented on 2012-09-30 11:05 (UTC)

貌似又更新了,但版本号没变,只好修改release号了

qifei9 commented on 2012-09-28 05:54 (UTC)

nutstore_linux_dist_x64.tar.gz ... md5 校验失败

bhoppi commented on 2012-09-07 13:48 (UTC)

已更新至1.5.0版本

commented on 2012-09-06 08:41 (UTC)

似乎有更新了 md5sum不对,到 /tmp/yaourt-tmp-MY_USERNAME/aur-nutstore 中 用md5sum 检查了一下 然后更改,没搞定,不懂这个文件的细节,最后 把 source改成已经下载的本地文件 ,架构之类的只留下x64,md5sum留一个,改成我检查的结果,其他的不相关信息删除,搞定。

bhoppi commented on 2012-07-03 18:31 (UTC)

package updated, this time it will be okay.

jouyouyun commented on 2012-07-02 14:22 (UTC)

nutstore 升级了,麻烦更新 md5sum 。

sfbi commented on 2012-06-28 19:27 (UTC)

But how? The package is already up to date, and I just reinstalled again...

bhoppi commented on 2012-06-28 16:00 (UTC)

upgrading your package will solve this problem

sfbi commented on 2012-06-28 13:35 (UTC)

The deamon always prompts "Nutstore is going to upgrade itself ...", and then quits automatically. But it never really upgrades...

bhoppi commented on 2012-04-22 15:37 (UTC)

Split the origin pkg into two. To use nautilus plugin please refer to nautilus-nutstore.

bhoppi commented on 2012-03-17 18:21 (UTC)

已将二进制程序修改为"global"并添加到包中。但没有找到该程序的license声明,就没有添加,仍沿用GPL。不知道这样在AUR中是否合法

qifei9 commented on 2012-03-15 21:14 (UTC)

直接安装这个包的话,是没有用的。还要运行压缩包里的runtime_bootstrap这个脚本才能安装真正的程序。而且 ~/.nutstore/dist/bin/nutstore-pydaemon.py 里面要把python该改成python2