Package Details: nvidia-bl 0.17.3-10

Git Clone URL: https://aur.archlinux.org/nvidia-bl.git (read-only)
Package Base: nvidia-bl
Description: Driver to adjust display backlight on modern mobile NVidia graphics adapters.
Upstream URL: https://launchpad.net/~mactel-support/+archive/ppa
Licenses: GPL
Submitter: paulburton
Maintainer: dlandau
Last Packager: dlandau
Votes: 45
Popularity: 1.041372
First Submitted: 2009-04-11 10:34
Last Updated: 2016-11-05 20:45

Latest Comments

bacondropped commented on 2016-11-06 01:47

@nagar
This package now includes the patch, but just for posterity, here's how you would patch a package:

1) Clone the package with git
2) Apply the patch
3) Build and install the package with makepkg

So, in this case you'd do something like this:

$ cd /tmp
$ git clone https://aur.archlinux.org/nvidia-bl.git
$ cd nvidia-bl
$ curl --silent https://gist.githubusercontent.com/bacondropped/fdb1e71228dd4b100a8e9304f95d465a/raw/6f26b3dc3d436a436b415b71fc77a2bb670b74f5/nvidia-bl-0.17.3-linux4.8fix-3bea3c4.patch | patch -Np1
$ makepkg -ci
< makepkg builds the package and prompts you to install it >

dlandau commented on 2016-11-05 20:45

Thank you all, updated package.

nagar commented on 2016-10-31 01:43

@bacondropped
Can you please share with me how to apply your patch?!
Thanks

bacondropped commented on 2016-10-27 21:45

@habbbe @nakki87 @dlandau
I can confirm that edit works for me on a 4.8.4 kernel.
Made it into a patch: https://gist.githubusercontent.com/bacondropped/fdb1e71228dd4b100a8e9304f95d465a/raw/6f26b3dc3d436a436b415b71fc77a2bb670b74f5/nvidia-bl-0.17.3-linux4.8fix-3bea3c4.patch

habbbe commented on 2016-10-25 07:13

@nakki87
It seems the problem is that the macro DEFINE_PCI_DEVICE_TABLE is no longer available since the last kernel update.
The offending line is 212 in nvidia_bl.c:
static DEFINE_PCI_DEVICE_TABLE(nvidia_bl_device_table) = {

If you replace this with (as described here https://patchwork.kernel.org/patch/6813061/):
static const struct pci_device_id nvidia_bl_device_table[] = {


it compiled for me (and worked).

nakki87 commented on 2016-10-23 11:05

Hi, I can't install cause a lot of errors running build():

log file:
https://drive.google.com/open?id=0Bxt_59dqC0_6NFo5MVlVTTZXQjg

dlandau commented on 2016-02-20 19:00

Fixed, thanks for reporting.

flpa commented on 2016-02-03 18:07

Hi, right now this package can't be built on my machine using makepkg/pacman 5.0.0. The error message states:
`==> ERROR: backup should be an array`

After some research it seems to me like pacman 5 requires this variable to be an array. Wrapping the backupd dir into an array does solve that issue but I do not know whether there are other parts of the PKGBUILD which should be migrated for pacman 5.

Atsuri commented on 2015-09-27 16:24

Builds and works as advertised. Thank you, dlandau!

dlandau commented on 2015-01-11 10:33

Updated, thanks.

All comments