Package Details: nvidia-exec 0.2.9-1

Git Clone URL: https://aur.archlinux.org/nvidia-exec.git (read-only, click to copy)
Package Base: nvidia-exec
Description: Run programs in nvidia optimus setups with power management for Xorg and Wayland without log out
Upstream URL: https://github.com/pedro00dk/nvidia-exec#readme
Keywords: nvidia optimus prime
Licenses: GPL
Submitter: pedro00dk
Maintainer: pedro00dk
Last Packager: pedro00dk
Votes: 6
Popularity: 0.89
First Submitted: 2022-02-15 22:54 (UTC)
Last Updated: 2024-06-15 15:37 (UTC)

Latest Comments

MarsSeed commented on 2022-03-23 15:04 (UTC) (edited on 2022-03-23 15:04 (UTC) by MarsSeed)

Unfortunately it seems Pacman doesn't support version constraints for indirect provides.

Tested with depends=('NVIDIA-MODULE>=495.44') but it breaks build and install during dependency checking phase (cannot satisfy dependency).

pedro00dk commented on 2022-03-23 12:39 (UTC) (edited on 2022-03-23 12:40 (UTC) by pedro00dk)

I made the change so it allows nvidia-dkms to be used. Although, I think the script is only going to work with nvidia 495 driver or newer.

MarsSeed commented on 2022-03-23 10:32 (UTC)

What @gopalkaul asks for can be achieved with

depends=(NVIDIA-MODULE)
- instead of -
depends=(nvidia)

gopalkaul commented on 2022-03-23 08:17 (UTC)

Please change the dependencies to have Nvidia-dkms as well