Package Details: nvidia-merged-settings 510.47.03-1

Git Clone URL: https://aur.archlinux.org/nvidia-merged.git (read-only, click to copy)
Package Base: nvidia-merged
Description: NVIDIA drivers utilities; patched for vGPU support w/ Rust unlock & host DRM output (32-bit)
Upstream URL: https://krutavshah.github.io/GPU_Virtualization-Wiki/
Licenses: custom
Provides: nvidia-settings
Submitter: Erin-Allison
Maintainer: Erin-Allison
Last Packager: Erin-Allison
Votes: 7
Popularity: 2.07
First Submitted: 2021-12-19 21:45 (UTC)
Last Updated: 2022-05-15 20:51 (UTC)

Latest Comments

nezu commented on 2022-07-02 19:41 (UTC)

please add a conflict to the normal nvidia-settings in nvidia-merged-settings

lunainvictum commented on 2022-03-15 09:58 (UTC)

Cant build. First because of usage of Google. I dont have access to Google Services.

Workarounded this, with using VPN.

But then: Checksum fails ==> Überprüfe source Dateien mit sha256sums... nvidia-drm-outputclass.conf ... Erfolg nvidia-smi ... Erfolg nvidia-vgpu.conf ... Erfolg vgpu_unlock-rs.conf ... Erfolg twelve.patch ... Erfolg fourteen.patch ... Erfolg sixteen.patch ... Erfolg 99-nvidia-ignoreabi.conf ... Erfolg NVIDIA-Linux-x86_64-460.73.01-grid-vgpu-kvm-v5.run ... FEHLGESCHLAGEN vgpu_unlock-rs ... Übersprungen ==> FEHLER: Eine oder mehrere Dateien überstanden nicht die Gültigkeits-Prüfung! -> Fehler beim Herunterladen der Quellen: nvidia-merged context: exit status 1

If i skip checksum check, cant build it anyway, because Google Throw a Download Limit error:

==> Beginne prepare()... NVIDIA-Linux-x86_64-460.73.01-grid-vgpu-kvm-v5.run: Zeile 1: Syntaxfehler beim unerwarteten Symbol »<« NVIDIA-Linux-x86_64-460.73.01-grid-vgpu-kvm-v5.run: Zeile 1: `<!DOCTYPE html><html><head><title>Google Drive - Download warning</title><meta http-equiv="content-type" content="text/html; charset=utf-8"/><style nonce="scVb9iiPKogkWQ1zwY0yUQ">/ Copyright 2022 Google Inc. All Rights Reserved. /' ==> FEHLER: Ein Fehler geschah in prepare(). Breche ab... -> Fehler beim Ausführen: nvidia-merged (nvidia-merged-utils nvidia-merged-dkms nvidia-merged)

Would suggest a better/datafriendly mirror...

Erin-Allison commented on 2022-02-21 21:50 (UTC)

The system services "nvidia-suspend", "nvidia-resume", "nvidia-persistenced", and a couple others are provided with the stock DRM graphics driver, but not with the vgpu-kvm modules. As they are almost certainly not designed to function with the vgpu-kvm code, I opted to not include those binaries/services in this package.

teetest commented on 2022-02-19 04:48 (UTC)

There are no services like nvidia-suspend.service or nvidia-resume.service in nvidia-merged-utils. But they are in official package nvidia-utils.

Are these service not provided by NVIDIA's grid-vgpu-kvm file? Thank you for this aur package.

Erin-Allison commented on 2022-01-12 14:53 (UTC)

Good catch on the missing conflicts.

As far as cuda, cuda-tools and cudnn, there would be no point in hosting a different version of them as far as I know. They don't ship with the Nvidia driver, so they likely aren't as picky about a specific driver version.

I remember some others mentioning CUDA was iffy with this driver on the host, but I've never honestly worked with it to say one way or another.

Seas0 commented on 2022-01-12 10:39 (UTC)

May be adding a '-merged' version of cuda cuda-tools and cudnn would help?

Seas0 commented on 2022-01-12 08:12 (UTC) (edited on 2022-01-12 10:39 (UTC) by Seas0)

And for opencl-nvidia-merged, conflicts=('opencl-nvidia') may be added to ensure pacman auto remove the original opencl-nvidia package to avoid file confilct (Also same for the lib32-opencl-nvidia-merged)

Seas0 commented on 2022-01-12 08:04 (UTC)

It seems break CUDA?

FabioLolix commented on 2021-12-20 16:59 (UTC)

Ok, about gdrive nevermind, I misread a DLAGENT part

Erin-Allison commented on 2021-12-20 16:44 (UTC) (edited on 2021-12-20 16:44 (UTC) by Erin-Allison)

Where does the suffix -merged comes from?

The driver package has components from both the desktop graphics driver and the vGPU-KVM host driver "merged" into one to allow the host to still access compute resources/display output on the GPU.

Why the driver are not downloaded from download.nvidia.com?

The modifications noted above haven't yet been codified into patches so a partially-customized .run is referenced then with a handful of additional changes applied by the PKGBUILD.

git and gdrive are missing from makedepends

I'll add git, but gdrive is not referenced here. (Though if I could use that, it would likely make that DLAGENT entry a whole lot more reliable/less ugly... will test in a bit)

no need to specify gcc as makedepends since it is in the base-devel group

I'll remove that.

EDIT: Formatting fix

FabioLolix commented on 2021-12-20 16:13 (UTC)

Hello,

  • Where does the suffix -merged comes from?
  • Why the driver are not downloaded from download.nvidia.com?
  • git and gdrive are missing from makedepends
  • no need to specify gcc as makedepends since it is in the base-devel group