Package Details: nvidia-pae 367.35-1

Git Clone URL: https://aur.archlinux.org/nvidia-pae.git (read-only)
Package Base: nvidia-pae
Description: NVIDIA drivers for linux
Upstream URL: http://www.nvidia.com/
Licenses: custom
Submitter: None
Maintainer: jose1711
Last Packager: jose1711
Votes: 29
Popularity: 0.126138
First Submitted: 2010-08-21 16:24
Last Updated: 2016-08-18 06:12

Latest Comments

ManU commented on 2015-08-01 11:25

no, switched to x86_64, feel free to adopt!

jose1711 commented on 2015-08-01 11:01

hi, are you still maintaining this?

jose1711 commented on 2015-06-29 09:07

@ManU: can you please update pkgbuild to work with latest linux-pae ? thank you

clfarron4 commented on 2015-01-28 16:22

This should work. I hope.

cookies commented on 2014-12-22 22:11

I disowned this package, because I'm not using it anymore. Feel free to adopt.

Samleybrize commented on 2014-10-06 08:47

Here is the updated version (343.22)
https://github.com/samleybrize/aur/tree/master/nvidia-pae

cookies commented on 2014-09-03 11:27

Update to v340.32-2 for kernel 3.16

Samleybrize commented on 2014-08-27 08:40

Here is the updated version (340.32 / linux 3.16)
https://github.com/samleybrize/aur/tree/master/nvidia-pae

cookies commented on 2014-08-13 19:10

Update to v340.32

cookies commented on 2014-07-29 20:35

Update to v340.24

Samleybrize commented on 2014-07-15 12:11

Here is the updated version (340.24)
https://github.com/samleybrize/aur/tree/master/nvidia-pae

cookies commented on 2014-06-26 13:01

Update to v337.25-2. Sorry for the long delay.

Samleybrize commented on 2014-06-25 10:19

Here is the updated version (337.25 / linux 3.15)
https://github.com/samleybrize/aur/tree/master/nvidia-pae

Samleybrize commented on 2014-06-04 09:49

Here is the updated version (337.25)
https://github.com/samleybrize/aur/tree/master/nvidia-pae

jose1711 commented on 2014-05-03 13:24

any eta on update

cookies commented on 2014-03-12 18:36

Update to v334.21

cookies commented on 2014-02-28 22:25

Update to v331.49

cookies commented on 2014-02-09 13:17

Update to v331.38-2 for kernel 3.13

cookies commented on 2014-01-28 19:24

For the [testing] users out there:
The source files for this package with support for kernel 3.13 are in my git repository[1]. I will push the package to AUR when the new kernel is in [core] and the linux-pae package is updated.

[1] https://github.com/rookies/aur/tree/master/nvidia-pae

cookies commented on 2014-01-14 20:48

Update to v331.38

cookies commented on 2013-11-27 16:31

Update to v331.20

cookies commented on 2013-11-26 21:06

I'm testing the new version at the moment, should be available in approximately an hour. When it's online, you have to remove nvidia-pae, update your system (including nvidia-utils) and then reinstall the new version of nvidia-pae.
This should be the safest way to upgrade, without ignoring any dependencies.

koutheir commented on 2013-11-18 09:16

I cannot update "nvidia-utils" because "nvidia-pae: requires nvidia-utils=325.15". "nvidia-utils" is now at version "331.20-1". How can I update the package?

cookies commented on 2013-09-21 09:50

Update to v325.15-3 for kernel 3.11

Neutrino commented on 2013-09-21 00:34

PKGBUILD must be updated to install nvidia-pae with kernel-pae 3.11. I don't know how to do it.

cookies commented on 2013-09-01 08:57

Update to v325.15-2, the module is now in /usr/lib instead of /lib.

kokoko3k commented on 2013-08-31 12:24

Could you please take a look here?
Seems this package needs to be fixed somehow:
https://bbs.archlinux.org/viewtopic.php?pid=1319218#p1319218

thanks!

cookies commented on 2013-08-11 15:34

Reviewed and added your changes, thanks. Sorry for my long reaction time, but as I said, I hadn't access to an Arch Linux system the last days.

mwohlf commented on 2013-08-10 15:32

I patched a version for kernel 3.10 and NVIDIA 325.15 you can get it here: http://www.wohlfart.net/nvidia-pae.tar.gz

cookies commented on 2013-08-06 19:24

What's the exact error message?
I can't try building the package because I have only mobile internet until Saturday. Then I will be at home and try to solve it, but maybe we can find earlier a solution.

Neutrino commented on 2013-08-04 18:33

I set the package out of date because build failed for current kernel 3.10 and I cannot simply downgrade kernel-pae...

Anonymous comment on 2013-08-01 12:49

Can this package work with linux-pae 3.10 ?
I got a build error :-(

cookies commented on 2013-07-03 18:12

Update to v319.32

proft commented on 2013-07-02 15:42

error: failed to prepare transaction (could not satisfy dependencies)
:: Starting full system upgrade...
:: nvidia-pae: requires nvidia-utils=319.23

Update please :)

cookies commented on 2013-05-29 16:14

Update to v319.23

bayi commented on 2013-05-13 16:43

thank you ;)

cookies commented on 2013-05-13 14:27

Update to v319.17-1, new version and changes for kernel 3.9.x

Anonymous comment on 2013-05-13 08:47

@cookies it's in [extra] now

bayi commented on 2013-05-13 01:28

oh sorry, i always forget im on testing, btw i did it manually and everything works fine sofar...

cookies commented on 2013-05-11 21:04

I will update to v319.17 after the correspondent versions of nvidia and nvidia-utils moved from [testing] to [extra]. I don't know exactly when this will be the case.

bayi commented on 2013-05-11 14:57

yeah sorry for the late reply...

the porblem was when i updated the kernel, the header package wasnt updated with it, as it had hit the repo only a few hours later ... so this was solved

when will this be updated to 319.17-2 ?

cookies commented on 2013-04-13 10:55

Do you have the right version of linux-pae-headers (split package from linux-pae[1]) installed? Look at the output of:
$ pacman -Qi linux-pae linux-pae-headers

[1] https://aur.archlinux.org/packages/linux-pae/

bayi commented on 2013-04-08 18:28

Build fails for me with:
linux-pae-headers not found

cookies commented on 2013-04-04 19:00

Update to v313.30-2, fixed dependencies.

cookies commented on 2013-04-04 17:30

Update to v313.30

cookies commented on 2013-04-01 09:03

Update to v313.26-2

cookies commented on 2013-03-07 19:05

Update to v313.26.

cookies commented on 2013-02-17 17:10

I updated the package to v313.18-2 and added the patch, so everything should work now without changes.

zeppelinlg commented on 2013-02-13 09:33

You need this patch for kernel 3.7: http://www.meyithi.com/pubdock/linux-3.7.patch

Related bug: https://bugs.archlinux.org/task/33827

zeppelinlg commented on 2013-02-13 09:32

Please include this patch: http://www.meyithi.com/pubdock/linux-3.7.patch

Related bug: https://bugs.archlinux.org/task/33827

bayi commented on 2013-02-11 02:06

here is the patch if hosted page is unreachable:
--- a/NVIDIA-Linux-x86_64-313.18-no-compat32/kernel/conftest.sh 2013-02-04 15:10:20.669633666 -0500
+++ b/NVIDIA-Linux-x86_64-313.18-no-compat32/kernel/conftest.sh 2013-02-04 15:10:34.283334673 -0500
@@ -1701,7 +1701,7 @@
SUBLEVEL=$(grep "^SUBLEVEL =" $MAKEFILE | cut -d " " -f 3)

if [ -n "$PATCHLEVEL" -a $PATCHLEVEL -ge 6 \
- -a -n "$SUBLEVEL" -a $SUBLEVEL -le 5 ]; then
+ -a -n "$SUBLEVEL" -a $SUBLEVEL -le 6 ]; then
SELECTED_MAKEFILE=Makefile.kbuild
RET=0
fi

bayi commented on 2013-02-11 02:04

@Stvad and others getting the "Unable to deremine ... " error

See bug report: https://bugs.archlinux.org/task/33710

Patch is here: http://gitorious.org/chakra-packages/platform/blobs/3338af90ba310678ba4e8bb7467aced117413588/nvidia/conftest_new.diff

if the package fails for you simply edit the file (kernel/conftest.sh) in the PKGDIR and build from there manually ( look at the PKGBUILD and execute the commands manually), thats what i did to get X as fast as possible back for now...

Anonymous comment on 2013-02-10 19:23

==> Початок build()...
Creating directory NVIDIA-Linux-x86-313.18
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86 313.18..........................................................................................................................................
If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.

*** Unable to determine the target kernel version. ***

kernel 3.7.6-1-pae

cookies commented on 2013-01-25 19:29

Update to v313.18 and kernel 3.7

zeppelinlg commented on 2013-01-25 08:34

The linux-pae version is now 3.7. The dependency is for linux-pae<3.7

Thanks for your work

cookies commented on 2012-11-17 11:16

Update to v310.19

cookies commented on 2012-11-08 13:31

Update to v304.64

cookies commented on 2012-10-28 10:31

Update to v304.60-2 for Kernel 3.6.3

cookies commented on 2012-10-20 19:53

Update to v304.60-1

cookies commented on 2012-10-16 17:39

Update to v304.51-3 for Kernel 3.6

cookies commented on 2012-09-26 13:55

Update to v304.51-2

cookies commented on 2012-09-18 14:21

Update to v304.43-2, little bugfix in PKGBUILD

cookies commented on 2012-09-17 21:07

Update to 304.43-1

Anonymous comment on 2012-08-29 07:59

Here's an updated tarball for version 304.43 - It's a tarball since nvidia.install also had to be updated because of the 3.5.x kernel:
http://files.tenzer.dk/arch/nvidia-pae-304.43-1.tar.gz

Anonymous comment on 2012-08-15 08:46

And here's an updated PKGBUILD for version 304.37:
http://files.tenzer.dk/arch/nvidia-pae-PKGBUILD-304.37-1

Anonymous comment on 2012-08-10 07:24

I have made an updated PKGBUILD file for version 304.32, if you want to update:
http://files.tenzer.dk/arch/nvidia-pae-PKGBUILD-304.32-1

ShadowKyogre commented on 2012-06-18 19:08

The lines should be uncommented now.

ShadowKyogre commented on 2012-06-18 19:05

I commented out those lines so it wouldn't bother me while I was updating the MD5sums, but forgot to uncomment them.

jose1711 commented on 2012-06-17 18:17

why are these two lines commented out?
#_extramodules=extramodules-3.4-pae
#_kernver="$(cat /lib/modules/${_extramodules}/version)"

jose1711 commented on 2012-06-16 22:27

nvidia 302.17 is out

OvsInc commented on 2012-05-28 17:40

Please replace
_extramodules=extramodules-3.3-pae
to
_extramodules=extramodules-3.4-pae

in PKGBUILD

enderst commented on 2012-05-27 01:20

Not sure why the linux-pae version limits are in the PKGBUILD. Probably not needed.

Anonymous comment on 2012-05-18 11:05

curl: (9) Server denied you to change to the given directory

Anonymous comment on 2012-04-12 09:33

remove nvidia-pae & nvidia-utils - # pacman -Rdd nvidia-pae nvidia-utils

http://hastebin.com/peporefeva.vhdl - PKGBUILD for i686(x86_64 req new md5)

Anonymous comment on 2012-04-10 00:45

Installation with Linux Kernel 3.3.1-1-pae,

- Install kernel and headers first
- Remove 295.33-1
- Install 295.33-2

Problem : cat /lib/modules/extramodules-3.2-pae/version not found

Solution : Update all references of 3.2 to 3.3 in PKGBUILD and nvidia.install

.done && Works great

cambid commented on 2012-03-01 07:18

Hi folks

I've migrated my last x86-system to x86_64 yesterday and will orphan this package now.

Cambid

Anonymous comment on 2012-02-23 05:17

Hi, Do you have an unofficial repository for this package?

Anonymous comment on 2012-01-14 17:49

Works perfectly for me with 3.2.0-2-pae kernel ;)

OvsInc commented on 2011-11-11 12:00

Hi!
Patch for building nvidia-pae for linux-pae-3.1
--- PKGBUILD_old 2011-10-12 08:26:30.000000000 +0400
+++ PKGBUILD 2011-11-11 15:47:36.769009192 +0400
@@ -3,13 +3,14 @@

pkgname=nvidia-pae
pkgver=285.05.09
-_kernver='3.0-pae'
-pkgrel=1
+_extramodules=extramodules-3.1-pae
+_kernver="$(cat /lib/modules/${_extramodules}/version)"
+pkgrel=2
pkgdesc="NVIDIA drivers for linux."
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
-depends=('linux-pae>=3.0' 'linux-pae<3.1' "nvidia-utils=${pkgver}")
-makedepends=('linux-pae-headers>=3.0' 'linux-pae-headers<3.1')
+depends=('linux-pae>=3.1' 'linux-pae<3.2' "nvidia-utils=${pkgver}")
+makedepends=('linux-pae-headers>=3.1' 'linux-pae-headers<3.2')
conflicts=('nvidia-96xx' 'nvidia-173xx')
license=('custom')
install=nvidia.install
@@ -39,6 +40,7 @@
"${pkgdir}/lib/modules/${_kernver}/kernel/drivers/video/nvidia.ko"
install -d -m755 "${pkgdir}/etc/modprobe.d"
echo "blacklist nouveau" >> "${pkgdir}/etc/modprobe.d/nouveau_blacklist-pae.conf"
+ sed -i -e "s/EXTRAMODULES='.*'/EXTRAMODULES='${_extramodules}'/" "${startdir}/nvidia.install"
sed -i -e "s/KERNEL_VERSION='.*'/KERNEL_VERSION='${_kernver}'/" "${startdir}/nvidia.install"
gzip "${pkgdir}/lib/modules/${_kernver}/kernel/drivers/video/nvidia.ko"
}

Anonymous comment on 2011-11-11 11:47

This package no longer works after the 3.1 kernel has come out. The following PKGBUILD should however work, though I have done limited testing: http://files.tenzer.dk/arch/nvidia-pae-PKGBUILD-linux-pae-3.1.0-4

Anonymous comment on 2011-08-08 10:53

I have made an attempt at creating an up-to-date PKGBUILD for this package, which uses the NVIDIA 280.13 driver and works with the new "linux-pae" package. It works for me on a 32-bit system. Feel free to use bits of it as you please: http://files.tenzer.dk/arch/nvidia-pae-PKGBUILD-linux-3.0

cambid commented on 2011-03-26 12:11

@zuargo: Yes, you can install this packages aside to the "normal" nvidia-driver

cambid commented on 2011-03-26 12:11

updated to 270.30

Anonymous comment on 2011-03-07 09:24

Can I install this driver aside of the nvidia driver of the repository?

cambid commented on 2011-01-22 16:47

I've adopted this package and bumped it to the new version.

Anonymous comment on 2010-12-31 19:33

I've switched to x64, so I'm orphaning the package.

Anonymous comment on 2010-12-01 03:53

updated

cambid commented on 2010-11-30 13:11

Thanks for updating. The package works great but you cannot install it aside to the original nvidia-package.

Please change nouveau-blacklist.conf to nouveau-blacklist-pae.conf

Anonymous comment on 2010-10-24 20:25

Yeah, I've had this marked as out-of-date for a while now...the good news is that it's not hard to hack the PKGBUILD to make it install 260.19.12...so in my boredom I did so. I'm fairly sure that it worked, nvidia-settings recognizes that I'm using the latest.

If anyone is also bored and wants to at least give it a shot, I can post instructions.

Abram commented on 2010-10-20 06:39

Please update to 260.19.12.