Package Details: nvidia-pf 364.19-3

Git Clone URL: https://aur.archlinux.org/nvidia-pf.git (read-only)
Package Base: nvidia-pf
Description: NVIDIA drivers for linux-pf-haswell.
Upstream URL: http://www.nvidia.com/
Licenses: custom
Conflicts: nvidia-173xx, nvidia-96xx, nvidia-pf-atom, nvidia-pf-core2, nvidia-pf-k7, nvidia-pf-k8, nvidia-pf-p3, nvidia-pf-p4, nvidia-pf-pm, nvidia-pf-psc
Submitter: lucak3
Maintainer: Thaodan
Last Packager: Thaodan
Votes: 46
Popularity: 1.394144
First Submitted: 2010-08-24 13:58
Last Updated: 2016-06-10 22:54

Dependencies (5)

Required by (2)

Sources (2)

Latest Comments

3ED_0 commented on 2016-04-20 08:53

Bad md5sums and missing file: nvidia-drm.ko

3ED_0 commented on 2016-04-14 09:53

nvidia from repo has been updated: 361.28 -> 364.16

Thaodan commented on 2015-04-25 16:40

urev: new kernel

Thaodan commented on 2015-04-16 14:31

rebuild for 3.19.4

Thaodan commented on 2015-03-26 13:13

urel: new kernel

Thaodan commented on 2015-01-19 15:32

please don't report it out of date if there's no new version in extra

Thaodan commented on 2014-11-11 20:58

you need to blacklist nouveau, the file provided by the nvidia package thus I don't provides this.

TheAifam5 commented on 2014-11-11 20:35

nouveau E[ PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x002140 [!ENGINE ]
nouveau E[ PFIFO][0000:01:00.0] INTR 0x08800010
nouveau E[ PFIFO][0000:01:00.0] SCHED_ERROR [ UNK00 ]

I have Intel i7(i used now Intel Graphics) with "linux-pf"(v3.17) kernel, and i have Nvidia with Bumblebee...
How repair this?

gim commented on 2014-11-10 06:56

Why would you hardcode kernel version in to the PKGBUILD?

plasma commented on 2014-10-21 04:21

i have tried to adjust the PKGBUILD for the nvidia-340xx without success. anyone willing to fix this, since it will become common issue, after the split of the nvidia drivers now.

Thaodan commented on 2014-10-12 22:45

you mean downgrade? :D

BTW: all previus versions are here: https://github.com/Thaodan/thaopkgs/tree/master/nvidia-pf

impakt commented on 2014-10-12 22:41

Updated PKGBUILD for nvidia-utils 343.22
http://pastebin.com/kz60rLxB

impakt commented on 2014-08-15 14:40

Updated PKGBUILD for nvidia-utils 340.32
http://pastebin.com/DcWsCbuv

impakt commented on 2014-07-12 18:26

Updated PKGBUILD for nvidia-utils 340.24
http://pastebin.com/nFb1ifVM

pelinho commented on 2014-07-12 14:55

Will you update nvidia to latest version? Will you also update the nvidia-pf-k8?

impakt commented on 2014-05-31 22:46

Updated PKGBUILD for nvidia-utils 337.25
http://pastebin.com/JZ8msrdZ

folderol commented on 2014-05-28 15:29

I updated the package. http://pastebin.com/5gfaBpHu

brando56894 commented on 2014-04-24 02:15

[bran@ra ~]$ install nvidia-pf
resolving dependencies...
warning: cannot resolve "linux-pf<3.14", a dependency of "nvidia-pf"
warning: cannot resolve "nvidia-utils=334.21", a dependency of "nvidia-pf"
:: The following package cannot be upgraded due to unresolvable dependencies:
nvidia-pf

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: nvidia-pf: requires linux-pf<3.14
:: nvidia-pf: requires nvidia-utils=334.21



[bran@ra ~]$ pacman -Q linux-pf
linux-pf 3.14.1-1

[bran@ra ~]$ pacman -Q nvidia-utils
nvidia-utils 337.12-1

brando56894 commented on 2014-04-24 02:14

[bran@ra ~]$ install nvidia-pf
resolving dependencies...
warning: cannot resolve "linux-pf<3.14", a dependency of "nvidia-pf"
warning: cannot resolve "nvidia-utils=334.21", a dependency of "nvidia-pf"
:: The following package cannot be upgraded due to unresolvable dependencies:
nvidia-pf

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: nvidia-pf: requires linux-pf<3.14
:: nvidia-pf: requires nvidia-utils=334.21



[bran@ra ~]$ pacman -Q linux-pf
linux-pf 3.14.1-1

brando56894 commented on 2014-04-24 02:13

[bran@ra ~]$ install nvidia-pf
resolving dependencies...
warning: cannot resolve "linux-pf<3.14", a dependency of "nvidia-pf"
warning: cannot resolve "nvidia-utils=334.21", a dependency of "nvidia-pf"
:: The following package cannot be upgraded due to unresolvable dependencies:
nvidia-pf

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: nvidia-pf: requires linux-pf<3.14
:: nvidia-pf: requires nvidia-utils=334.21

ilkyest commented on 2013-12-23 01:37

what about the correct way. I 'should' name the kernel "xxx-300hz-nonuma" and, usually, I apend it on Xconfig.

If I do "nothing" the header package would be compiled?

ilkyest commented on 2013-12-23 00:38

more or less... generic flag I used cause I'm comparing with stock kernel....

pkgname I've unnaltered, but, on xconfig I made 'my name's package"

I've no worries if I should recompile it, but I need the "header package"...

ilkyest commented on 2013-12-23 00:38

more or less... generic flag I used cause I'm comparing with stock kernel....

pkgname I've unnaltered, but, on xconfig I made 'my name's package"

Thaodan commented on 2013-12-22 23:36

do you builded your kernel with non generic flag and selected include cpu arch in pkgname?

ilkyest commented on 2013-12-22 22:36

when compiling linux-pg , makepkg haven't create "linux-pf-headers"

but, nvidia-pf asks for
-> linux-pf-headers>=3.12
-> linux-pf-headers<3.13

How can I solve it?

Thaodan commented on 2013-10-08 14:19

updated depmod stuff

masolit commented on 2013-09-09 22:18

_SYSSRC="/usr/lib/modules/3.10.1-pf/build" ???

_SYSSRC="/usr/lib/modules/3.11.1-pf/build"

lockheed commented on 2013-06-16 19:29

What do you mean 'wrong page'?

This is TLP: http://linrunner.de/en/tlp/docs/tlp-linux-advanced-power-management.html

Thaodan commented on 2013-06-16 18:37

its the wrong page, but it doesn't. What you mean with TLP?

lockheed commented on 2013-06-16 18:31

Does this kernel inclide PHC patches, as required by undervolting capabilities of TLP?

Thaodan commented on 2013-05-22 12:24

As I said...

lockheed commented on 2013-05-22 12:13

How about if I run a game using opengl in Wine?

And why is there a separation on
NVIDIA-Linux-x86_64-319.17.run
and
NVIDIA-Linux-x86_64-319.17-no-compat32.run ?

Thaodan commented on 2013-05-22 11:19

Then install lib32-nvidia-utils, you need no 32 bit driver on a 64bit system.

lockheed commented on 2013-05-22 11:14

What do you mean 'not needed'? I need it.

Thaodan commented on 2013-05-22 11:01

Not needed since this package only provides drivers.

lockheed commented on 2013-05-22 10:54

Would you consider adding a package WITH compat32 ?

Thaodan commented on 2013-05-12 15:52

It don't see your point the post install file is up to date.

graysky commented on 2013-05-12 11:05

No, it was because of the old KERNEL_VERSION in your post install script: http://pkgbuild.com/git/aur-mirror.git/commit/nvidia-pf?id=4621046098c1d6648a8c449561990b5135531151

Thaodan commented on 2013-05-11 12:16

It wants 3.9.1-pf you have to reboot before updating this package.

graysky commented on 2013-05-11 11:44

Your repo package wants /lib/modules/3.8.1-pf but you are hosting 3.9.1-pf so it breaks!

Thaodan commented on 2013-05-04 20:45

new version will come when its in extra too.

nous commented on 2013-03-18 13:29

Erm, I changed the PKGBUILD of linux-pf to follow more closely that of official -ARCH. More specifically, the kernel version and modules follow a 3-number scheme (beginning with 3.8.1-pf) whereas the extramodules keep the good ol' 2-number versioning (3.8-pf). This requires an extra variable in the nvidia-pf PKGBUILD, as follows:
==============
pkgrel=3
_goodkver=3.8
_badkver=3.9
_modver=${_goodkver}-pf
_kernver=`uname -r`
_extramodules=extramodules-${_modver}
==============
Thanks.

nous commented on 2013-03-17 23:56

Please update for linux-pf 3.8.

Thaodan commented on 2012-12-28 00:42

Thanks nous

nous commented on 2012-12-28 00:41

lockheed: Read https://bbs.archlinux.org/viewtopic.php?pid=1210137#p1210137

lockheed commented on 2012-12-27 13:11

@Thaodan, I cannot install it:

==> Starting build()...
Creating directory NVIDIA-Linux-x86_64-310.19-no-compat32
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 310.19..........................................................................................................................................
==> Found optimized linux-pf-core2, building nvidia-pf-core2.
./conftest.sh: line 1703: [: too many arguments
If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.

*** Unable to determine the target kernel version. ***

make: *** [select_makefile] Error 1

lucak3 commented on 2012-12-22 10:22

@lockheed: I went back to using the repo kernel, since I don't have problems anymore with it. Performance doesn't differ much on my machine, at least on the load I give it usually, which doesn't include heavy compiling anymore.

Thaodan commented on 2012-12-21 23:57

Adopted it and updated the package to fit the corresponding kernel version.

lockheed commented on 2012-12-21 19:20

@lucak3, out of curiosity - what are you using now?

lucak3 commented on 2012-12-21 19:13

Since I'm not using linux-pf anymore and I don't have time to compile it just to maintain this package, I'll orphan it. It has been a long ride :)

Anonymous comment on 2012-12-21 17:07

Houston, we have a problem ... with version of "linux-pf"

nous commented on 2012-11-19 14:07

Please update.

Thaodan commented on 2012-11-17 19:23

My updated (310.19) PKGBUILD: http://pastebin.com/4SLdiXN1

Thaodan commented on 2012-11-07 02:03

My updated (304.64) PKGBUILD: http://pastebin.com/wcqrPpXM

travnick commented on 2012-10-20 18:08

Mine pkgbuild, enjoy:
https://www.dropbox.com/s/b69ka5rgho82qqy/PKGBUILD-nvidia-pf

jahiy commented on 2012-10-06 03:05

linux-pf has updated to 3.6.1

jahiy commented on 2012-10-06 02:59

linux-pf has updated to 3.6.1

HNKNTA commented on 2012-08-08 21:09

please update!

nous commented on 2012-06-12 15:37

It sure does, the pfkernel repo is already populated with precompiled nvidia-pfs.

lockheed commented on 2012-06-12 12:37

Does this work with the newest PF kernel?

Anonymous comment on 2012-06-05 15:40

Please update!

lockheed commented on 2012-04-06 17:54

Doesn't work with kernel 3.3

nous commented on 2012-03-31 00:32

Hey, people! I've uploaded precompiled binaries, generic and optimized (x86_64 only for now, sorry) to the [pfkernel] repo. Hopefully, they'll solve problems like the one rAX and Cape reported.

lucak3: To make the nvidia-pf PKGBUILD allow batch building, I modified it somewhat. Take a look at https://bitbucket.org/nous/nvidia-pf and if you agree, please merge it here. I'll give you the bitbucket repository if you want too.

Cape commented on 2012-03-26 19:32

I'm also having trouble with the "version magic". I'm running pf-core2 but somehow the module is packaged for k7.

0rAX0 commented on 2011-12-26 13:36

Hi, I installed this package with a pre-built Linux-pf-P4 from the pfkernel repo, It is giving me this error after I restart:
nvidia: version magic '3.1-pf SMP preempt mod_unload modversions K7 ' should be '3.1-pf SMP preempt mod_unload modversions PENTIUM4 '

Is it possible to make this compatible with P4? Or do I have to reinstall the generic linux-pf package? Thank you.

prMoriarty commented on 2011-11-12 23:31

linux-pf 3.1.1-2 actually now

akuznetcov commented on 2011-08-08 15:01

Yeap i meant kernel26-pf, sorry. Will check new one, thanks : )

lucak3 commented on 2011-08-08 14:13

What do you mean kernel26?
If you meant kernel26-pf, i made a PKGBUILD for you, but it's NOT TESTED! http://www.mediafire.com/?c3b6hvnipluk84f

akuznetcov commented on 2011-08-08 13:55

Could you please update it for kernel26? I have a really annoying bug with same tray icons in Gnome-Shell

http://www.nvidia.com/object/linux-display-amd64-280.13-driver.html
* Fixed a GLX_EXT_texture_from_pixmap bug that caused corruption when texturing from sufficiently small pixmaps and, in particular, corruption in the GNOME Shell Message Tray.

lucak3 commented on 2011-08-03 09:40

I need to wait until nivida-utils 280.13 comes to extra and, over all, pf patchset for linux 3.0 gets posted.

lucak3 commented on 2011-04-21 07:42

There's no need to leave a comment, i already got an email by AUR notifications.

kalpik commented on 2011-04-21 02:19

Please update to 270.41.06

lucak3 commented on 2011-03-27 09:04

Just what Ranguvar said, else you need to make a symbolic link /lib/modules/2.6.38-pf/build to /usr/src/linux-2.6.38-pf/

Anonymous comment on 2011-03-27 03:40

i got: "Unable to find kernel vesion" :(

Anonymous comment on 2011-03-27 03:10

Kernel must be compiled with options=('!strip')

shadowed87 commented on 2011-03-25 09:11

I'm talking about nvidia drivers ! that don't compile with the new pf kernel...

I tried with both yaourt and makepkg...and I tried different nvidia driver version...nothing...always fails

FATAL: vmlinux has no symtab?
make[3]: *** [__modpost] Error 1
make[2]: *** [modules] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!

thank you in advance for any suggestion

lucak3 commented on 2011-03-25 07:09

This is not really the place to ask for help compiling the kernel (try kernel26-pf AUR page), but i'll ask: are you using makepkg to build the package or some AUR helper?

shadowed87 commented on 2011-03-25 00:11

am I the only one having this problem?

FATAL: vmlinux has no symtab?

using the latest kernel26-pf 2.6.37-pf6...

so i cannot compile and use the nvidia drivers!

lucak3 commented on 2011-03-08 06:58

What are your versions of mkinitcpio and module-init-tools?

Anonymous comment on 2011-03-07 16:04

Sorry,but when it's finished it says: "Warning:can't read module /lib/modules/2.6.37-pf/kernel/drivers/video/nvidia.ko.gz Exec format error"

Thx for any response

lucak3 commented on 2011-03-07 06:53

What do you mean by 'compilation error'? Do you get an error building the package?
What tool do you use to build it? I mean, using makepkg i do not get any errors...

Anonymous comment on 2011-03-06 17:00

Hi,

Despite the 'gzip -9 "$pkgdir/lib/modules/${_kernver}/kernel/drivers/video/nvidia.ko"', there is still a compilation error.

Any ideas?

Thx in advance

lucak3 commented on 2011-02-15 13:18

Added line 'gzip -9 "$pkgdir/lib/modules/${_kernver}/kernel/drivers/video/nvidia.ko"' to use the compressed module

lucak3 commented on 2011-01-21 21:57

I shall repeat this just another time: it's useless to tag this not updated, i'll wait for official Arch repos release of nvidia-utils.

lucak3 commented on 2011-01-08 11:34

For those which get an error compiling with latest kernel, please read my comment on nvidia-bfs (https://aur.archlinux.org/packages.php?ID=37087)

lucak3 commented on 2010-12-18 16:02

changed the name of modprobe file so to exclude collision with others nvidia* packages

Cape commented on 2010-12-14 18:12

Hipe! New version just came out.
I tried to change $pkgver and sha256sum and everything worked fine.

x86
sha256sums('15edf89b614ca4027287acc8623b4522425ce8c5')

JokerBoy commented on 2010-10-31 23:03

depends=('kernel26-pf>=2.6.36' 'kernel26-pf<2.6.37' "nvidia-utils=${pkgver}")

makedepends is not needed in this case.

lucak3 commented on 2010-09-16 07:37

makedepends array updated

nous commented on 2010-09-11 11:48

260.x is out

lucak3 commented on 2010-09-01 08:24

As the others nvidia-* packages, i'll wait for an official Arch update, since we need nvidia-utils updated too.