Package Details: nvim-packer-git r574.ea0cc3c-1

Git Clone URL: https://aur.archlinux.org/nvim-packer-git.git (read-only, click to copy)
Package Base: nvim-packer-git
Description: A use-package inspired plugin manager for Neovim.
Upstream URL: https://github.com/wbthomason/packer.nvim
Licenses: MIT
Submitter: ouuan
Maintainer: ouuan
Last Packager: ouuan
Votes: 25
Popularity: 0.35
First Submitted: 2021-05-01 05:41 (UTC)
Last Updated: 2023-08-26 00:15 (UTC)

Latest Comments

pomelocarmelo commented on 2023-08-27 00:07 (UTC) (edited on 2023-08-27 00:08 (UTC) by pomelocarmelo)

the maintainer of the upstream repository has announced that this plugin is no longer maintained as-per this announcement:

https://github.com/wbthomason/packer.nvim#readme

they recommend transitioning to either pckr.nvim: https://github.com/lewis6991/pckr.nvim ~~ which is still in development, or lazy.nvim: https://github.com/folke/lazy.nvim ~~ which is more stable and actively maintained as of now.

eclairevoyant commented on 2022-07-19 05:34 (UTC) (edited on 2022-07-19 05:36 (UTC) by eclairevoyant)

@prometheus You'll have to do at least a minimal config - if you follow the example in the repo, you'll add the following data to the following files (creating them and their parent directories if they don't exist):

~/.config/nvim/init.vim:

lua require('plugins')

~/.config/nvim/lua/plugins.lua:

vim.cmd [[packadd packer.nvim]]

return require('packer').startup(function()
  -- Packer can manage itself
  use 'wbthomason/packer.nvim'

  -- You add plugins here  
end)

Of course you don't have to call the second file plugins.lua, but whatever name you do use would have to correspond to what you have in init.vim

prometheus commented on 2022-06-16 17:04 (UTC)

Any additional configuration require?

:PackerSync

throws

E492: Not an editor command: PackerSync

sshaikh commented on 2022-01-23 14:36 (UTC)

Thank you for this package. I was having trouble building it with aurtools, and after raising it with the author of that it's been suggested that cut/rev are not required in the version step:

https://github.com/AladW/aurutils/issues/898

The alternative provided is _reponame=${url##*/}. In anticipation of more formal advice is it possible to make this change for now?