Package Details: nvtop-nosystemd-git 3.0.2+31.r384.20231021.45a1796-1

Git Clone URL: https://aur.archlinux.org/nvtop-nosystemd-git.git (read-only, click to copy)
Package Base: nvtop-nosystemd-git
Description: GPUs process monitoring for AMD, Intel and NVIDIA. Without systemd dependencies. Latest Git checkout.
Upstream URL: https://github.com/Syllo/nvtop
Licenses: GPL3
Conflicts: nvtop
Provides: nvtop, nvtop-git, nvtop-nosystemd
Submitter: dreieck
Maintainer: dreieck
Last Packager: dreieck
Votes: 0
Popularity: 0.000000
First Submitted: 2023-02-26 12:28 (UTC)
Last Updated: 2023-10-31 18:38 (UTC)

Dependencies (8)

Required by (1)

Sources (1)

Latest Comments

dreieck commented on 2023-09-05 09:12 (UTC)

@fromtheeast710:

Thanks for reporting!, and I cannot reproduce the issue you reported.

fromtheeast710 commented on 2023-09-05 08:52 (UTC)

Package is failing to install with error:

[100%] Linking CXX executable interfaceTests
/home/theeast/.cache/yay/nvtop-nosystemd-git/src/nvtop/tests/interfaceTests: /opt/miniconda3/lib/libstdc++.so.6: version `GLIBCXX_3.4.32' not found (required by /home/theeast/.cache/yay/nvtop-nosystemd-git/src/nvtop/tests/interfaceTests)
/home/theeast/.cache/yay/nvtop-nosystemd-git/src/nvtop/tests/interfaceTests: /opt/miniconda3/lib/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /home/theeast/.cache/yay/nvtop-nosystemd-git/src/nvtop/tests/interfaceTests)
CMake Error at /usr/share/cmake/Modules/GoogleTestAddTests.cmake:112 (message):
  Error running test executable.

    Path: '/home/theeast/.cache/yay/nvtop-nosystemd-git/src/nvtop/tests/interfaceTests'
    Result: 1
    Output:


Call Stack (most recent call first):
  /usr/share/cmake/Modules/GoogleTestAddTests.cmake:225 (gtest_discover_tests_impl)


make[2]: *** [tests/CMakeFiles/interfaceTests.dir/build.make:101: tests/interfaceTests] Error 1
make[2]: *** Deleting file 'tests/interfaceTests'
make[1]: *** [CMakeFiles/Makefile2:953: tests/CMakeFiles/interfaceTests.dir/all] Error 2
make: *** [Makefile:146: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: nvtop-nosystemd-git-exit status 4

Please fix it and thank you for maintaining the package