Package Details: obconf-qt-git 0.1.0.18.gfe11967-1

Git Clone URL: https://aur.archlinux.org/obconf-qt-git.git (read-only)
Package Base: obconf-qt-git
Description: Openbox configuration tool. Qt port of ObConf
Upstream URL: http://lxqt.org
Licenses: GPL2
Conflicts: obconf-qt
Provides: obconf-qt
Submitter: virubakkh
Maintainer: jleclanche
Last Packager: City-busz
Votes: 28
Popularity: 0.012504
First Submitted: 2013-08-02 05:33
Last Updated: 2015-07-09 00:40

Latest Comments

pmattern commented on 2015-06-03 11:57

To build against Qt 5 qt5-x11extras is needed, see CMakeLists.txt. (Lack of package is masked by LXQt as several of its components like liblxqt are depending on it).

On a side note an explanation of those findings below regarding Qt 4 vs. 5 can be found on https://github.com/lxde/obconf-qt/issues/8.

archuser commented on 2015-05-04 22:55

Also I had to change "$srcdir/$_pkgname" in pkgver() to "$srcdir/$_pkgname-$pkgver" for it to recognise the update.

jleclanche commented on 2015-05-04 22:45

Regarding the version change: It's a fix that needs to happen upstream. I'll look into it.

jleclanche commented on 2015-05-04 22:44

No.

https://wiki.archlinux.org/index.php/Arch_User_Repository#Getting_started

archuser commented on 2015-05-04 22:33

You need to add "gcc" to makedepends for those that may not currently have it installed.

Faerbit commented on 2015-05-03 14:01

So will the version change happen anytime soon?

alium commented on 2015-04-26 08:03

need 'openbox' as dependencies

pmattern commented on 2015-02-27 13:39

Git version of recent code as seen by running 'git clone' and 'git describe' is something like 0.1.0-18-*.
As a consequence, pacaur erroneously considers this package updatable upon each invocation of 'pacaur -Syu'. Same thing probably applies to other AUR helpers as well.
So I think it would be helpful to adjust the package version accordingly.

On a side note it would be very nice if you could drop a quick note about how that downgrade 0.1.0-21 --> 0.1.0-18 came to happen (besides this is an upstream issue, of course).

cygoh commented on 2015-02-27 03:58

Add -DUSE_QT5=ON to cmake works without installing qt4

bwraith commented on 2015-02-26 18:46

I got the error below trying "pacaur -u obconf-qt-git" (this was after pacman -Syu, that updated lxqt packages v 0.8x to 0.9x that are now in community repo and after removing lxqt package that was installed via AUR)

Found unsuitable Qt version "5.4.0" from /usr/bin/qmake, this code requires
Qt 4.x

After "pacman -S qt4", the build succeeded.

All comments