Package Details: obconf-qt-git

Git Clone URL: (read-only, click to copy)
Package Base: obconf-qt-git
Description: Openbox configuration tool. Qt port of ObConf
Upstream URL:
Licenses: GPL2
Conflicts: obconf-qt
Provides: obconf-qt=
Submitter: virubakkh
Maintainer: jleclanche (yan12125)
Last Packager: yan12125
Votes: 29
Popularity: 0.000000
First Submitted: 2013-08-02 05:33
Last Updated: 2018-09-13 15:38

Latest Comments

1 2 Next › Last »

yan12125 commented on 2018-06-15 10:51

Need lxqt-build-tools-git:

CMake Error at CMakeLists.txt:38 (find_package):
  By not providing "Findlxqt-build-tools.cmake" in CMAKE_MODULE_PATH this
  project has asked CMake to find a package configuration file provided by
  "lxqt-build-tools", but CMake did not find one.

  Could not find a package configuration file provided by "lxqt-build-tools"
  (requested version 0.5.0) with any of the following names:


  Add the installation prefix of "lxqt-build-tools" to CMAKE_PREFIX_PATH or
  set "lxqt-build-tools_DIR" to a directory containing one of the above
  files.  If "lxqt-build-tools" provides a separate development package or
  SDK, be sure it has been installed.

pmattern commented on 2015-06-03 11:57

To build against Qt 5 qt5-x11extras is needed, see CMakeLists.txt. (Lack of package is masked by LXQt as several of its components like liblxqt are depending on it).

On a side note an explanation of those findings below regarding Qt 4 vs. 5 can be found on

archuser commented on 2015-05-04 22:55

Also I had to change "$srcdir/$_pkgname" in pkgver() to "$srcdir/$_pkgname-$pkgver" for it to recognise the update.

jleclanche commented on 2015-05-04 22:45

Regarding the version change: It's a fix that needs to happen upstream. I'll look into it.

jleclanche commented on 2015-05-04 22:44


archuser commented on 2015-05-04 22:33

You need to add "gcc" to makedepends for those that may not currently have it installed.

Faerbit commented on 2015-05-03 14:01

So will the version change happen anytime soon?

alium commented on 2015-04-26 08:03

need 'openbox' as dependencies

pmattern commented on 2015-02-27 13:39

Git version of recent code as seen by running 'git clone' and 'git describe' is something like 0.1.0-18-*.
As a consequence, pacaur erroneously considers this package updatable upon each invocation of 'pacaur -Syu'. Same thing probably applies to other AUR helpers as well.
So I think it would be helpful to adjust the package version accordingly.

On a side note it would be very nice if you could drop a quick note about how that downgrade 0.1.0-21 --> 0.1.0-18 came to happen (besides this is an upstream issue, of course).

cygoh commented on 2015-02-27 03:58

Add -DUSE_QT5=ON to cmake works without installing qt4