Package Details: oblige 7.50-1

Git Clone URL: (read-only)
Package Base: oblige
Description: A random level maker for games based on the Doom engine
Upstream URL:
Licenses: GPL
Submitter: None
Maintainer: grubber
Last Packager: grubber
Votes: 4
Popularity: 0.009074
First Submitted: 2009-05-24 03:24
Last Updated: 2016-09-30 11:26

Latest Comments

remussatala commented on 2016-03-06 03:19

problem with source

grubber commented on 2013-02-25 21:58

Nope, a missing unistd.h include. Anyway, updated to 4.28.

Zucca commented on 2013-01-22 20:58

Ouch. Because I cannot build 3.57: In function ‘void TimeDelay(u32_t)’: error: ‘usleep’ was not declared in this scope

A depency problem?

grubber commented on 2013-01-22 19:01

It is not possible to compile 4.28 from the source ATM:

Also, compiling 4.28 from SVN seems to be troublesome as well, as there are no version tags in Oblige SVN and I was not able to found a revision that matches 4.28 source zip.

Zucca commented on 2013-01-21 19:39

4.28 is out.

grubber commented on 2011-11-05 17:26

Oblige doesn't like FLTK 1.2.0+, even though it works fine with it. Fixed.

UFOKatarn commented on 2011-10-30 23:28

Hi :D! I get the following error when compiling: error: #error "Require FLTK version 1.1.7 or later"
make: *** [ui_window.o] Error 1
make: Leaving directory `/tmp/yaourt-tmp-blaz/aur-oblige/src/oblige_357_src/gui'

I did a -Syu a few hours ago.

grubber commented on 2010-04-09 17:36


Anonymous comment on 2010-04-09 15:14

OBLIGE 3.57 is the current version. :-)