Package Details: obnam-git 4380.bdc923b-1

Git Clone URL: (read-only)
Package Base: obnam-git
Description: Obnam is an easy, secure backup program.
Upstream URL:
Licenses: GPL3
Conflicts: obnam
Provides: obnam
Submitter: sarum9in
Maintainer: SanskritFritz
Last Packager: sarum9in
Votes: 6
Popularity: 0.000000
First Submitted: 2013-11-08 23:20
Last Updated: 2015-06-13 12:36

Latest Comments

SanskritFritz commented on 2018-03-02 18:22

Until obnam sources are deleted upstream, this package can exist.

sarum9in commented on 2018-03-02 11:04

Thank you for adopting it :)

sarum9in commented on 2018-03-01 17:50

Upstream dropped development of the project, I will no longer support it in AUR also.

sarum9in commented on 2014-08-30 04:19


sarum9in commented on 2014-08-29 01:57

I have fixed the issue. But I have trouble uploading source package into AUR. "error: failed to upload obnam-git-4380.bdc923b-1.src.tar.gz: The source package does not contain any meta data. Please use `mkaurball` to create AUR source packages". I am using "makepkg --source" command to build it. Checked both Chromium and burp to upload package into AUR, result is persistent.

While it is not fixed you can try PKGBUILD directly from git: .

bitsfritz commented on 2014-08-27 22:30

Hmm, got following error:
==> Starting build()...
sed: can't read tests/*.script: No such file or directory
==> ERROR: A failure occurred in build().

indeed src/obnam-git/tests/ folder doesn't exist.

removing "tests/*.script" check in PKGBUILD:
sed -ri 's|python|python2|g' check README tests/*.script
sed -ri 's|python|python2|g' check README

solved building issues

Did not investigate deeper yet.

sarum9in commented on 2014-03-20 17:32

Thank you for the information.
Initially it was made to allow users use python2-tracing instead of python2-tracing-git if they want, but seems it brings more troubles than solves. I fixed it and added missing make dependency for obnam-git (python2-yaml).

bricewge commented on 2014-03-20 15:20

Something is not right with the dependencies. Obnam need python2-larch-git and python2-tracing-git; but python2-larch-git need python2-tracing wich is in conflict with python2-tracing-git.

Changing the dependency of python2-larch-git from python2-tracing to python2-tracing-git may fix it.

bricewge commented on 2013-11-09 00:51

Thanks you sarum9in.

sarum9in commented on 2013-11-08 23:20

Please check out package.

All comments